Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


DokuWiki

2

Comments

  • Umpf: $Context->Session->UserID is always 0! Why?
  • @Tiggr: you probably need to put:

    define('NOSESSION', true)
    somewhere in dokuwiki.php.

    Anyway, I've written a new class for this purpose (ie. make DokuWiki use Vanilla authentication). The source is in the wiki at: vanilla:integration:dokuwiki

    Works for me, I hope someone else will find it useful too.
  • OK, now it works! Thank you very much!
  • edited August 2007
    Took me some time, until it realy worked, but now it runs like a rocket! Thank you very much! Tschüss Tiggr (aka Marcus) PS: Forum: http://www.orgaohnenamen.de/forum Wiki: http://www.orgaohnenamen.de/wiki (I still have to do something about design...)
  • edited September 2007
    Just to let you know, the reason you get all the errors is because Vanilla sets it's error reporting to all, but Dokuwiki uses a bad practice and doesn't check if the variables are set first. To put it simply, it's a Dokuwiki bug.
    To fix it, you can change the core of Dokuwiki, or you can add
    error_reporting(0);
    after the require_once lines in vanilla.class.php

    However, I can't log in. I get the same problem as Tiggr, but I've definitely got it in there (local.php actually, since that's where your settings should go).
  • I'm very sorry I can't help you, I've just deleted my first dokuwiki installation and did it again: And than it worked fine!
  • Well, for now, I'm going to give up on it and just leave the users seperate.
  • edited November 2007
    Hi,
    (sorry my english is not very good)

    I follow the instruction of the wiki page for integration of dokuwiki.

    I think i have done correctly the instruction. first I had the problem with magic-quotes-gpc. i created a file htaccess whith this line : SetEnv MAGIC_QUOTES 0. it's ok

    Now, I obtain these error

    have you a idea about that ?
    Thank

    I use vanilla 1.1.3 and dokuwiki 2007-06-26b
  • oups !!

    I add this line like rmccue :
    error_reporting(0);

    I don't have any mor error, but i don't believe the identification is working,
    I'm coming back soon
  • Im having issues with this as well.

    All I have done is make the changes noted in the documentation file located here:

    http://lussumo.com/docs/doku.php?id=vanilla:integration:dokuwiki

    I've not been able to get it working. Right now, all I get is a blank screen when I try and go to the wiki.

    Does anyone have more detailed steps... any order.. any things that need to be configured outside of those file changes... etc?

    Thanks in advance

    JB
  • Is there anyone that can help with this? Is the MediaWiki integration better? I'd really like to get this working asap. Thanks in advance JB
  • Hi!

    I took three tries, doing in my opinion always the same, but only the third try worked. :-(

    But I don't know, what the difference made!

    Tiggr
  • Hi Tiggr, Thanks for being willing to help. Could you maybe explain to me what you did exactly? Did you do anything different from what the documentation here says: http://lussumo.com/docs/doku.php?id=vanilla:integration:dokuwiki I'd really like to get this working as soon as possible. Thanks in advance JB
  • Is anyone successfully using a wiki integrated with Vanilla? I really need some help.
  • All I did, was following the instructions...

    And I've added two lines to local.php

    $conf['superuser'] = '@Administrator';
    $conf['disableactions'] = 'register,resendpwd,profile,login,logout';


    And this is changed/new in conf/dokuwiki.php:

    $conf['defaultgroup']= 'user'; //Default groups new Users are added to
    $conf['superuser'] = '!!not set!!'; //The admin can be user or @group
    $conf['manager'] = '@Moderatoren'; //The manager can be user or @group

    /* Vanilla */
    /* Mandatory */

    define('NOSESSION', true);
    $conf['authtype'] = 'vanilla';

    /* Optional */
    define('VANILLA_ROOT', '/home/orgaohnenamen_de/www/forum/'); /* This is the default */
    $conf['acl'] = 1; /* You probably have this set already */
    $conf['disableactions'] = 'login,logout,profile,register,resendpwd'; /* Now handled by Vanilla */
    $conf['passcrypt'] = 'md5'; /* Not really necessary, set automatically by the authentication backend */


    And this is new inside the .htaccess, it's very rude, but I did it:

    php_flag magic_quotes_gpc Off
    php_flag display_errors 0



    That's all I remember.
  • Woot! I don't know what happened (probably the magic quotes was my undoing), but it works! Now, to just set up ACL...

    Thanks Tiggr!
  • It is not necessary to make any changes to conf/dokuwiki.php. That file contains all the default settings for a dokuwiki setup, anything you place in conf/local.php will override what is in the dokuwiki.php.
    All default values are stored in a file called conf/dokuwiki.php. If you want to modify a setting you should do this in a file called conf/local.php – this makes sure your special configs are not overwritten by a later upgrade. The config manager will use this file as well.
    -- taken from http://wiki.splitbrain.org/wiki:config
  • Thanks Tiggr and sirlancelot for your help! I'm going to try again tonight, and hopefully I can get it working. If so, I'll try and document the process in detail for others. Thanks again, and if anyone else has any tips for this I'd appreciate it.
  • Hmm, it seems as though it's not working anymore. Damn. I'm going to look into this and see if I can get it working again, as it's locked me out of my wiki :P
  • Vanilla is reporting (well, the $Context variable is) that I'm not logged in, although I am. Could this be a cookie path problem?
  • Quite possible. Or an issue with your server if it's broken randomly. What have you got set as your cookie path?
  • Ah, it's set to "/forums/" — Should I set it to just "/"?
  • Yes, if you want to use Vanilla's auth outside of its own directory, setting the cookie's domain as "/" should do the trick.
  • Nope, still getting nothing. Maybe restarting the browser might help...
  • Nope. Now it doesn't seem to be setting a cookie at all :-(
  • OK, fine now. Thanks :-)
  • And what did the trick?
  • Yeah, I'm still having issues... Maybe the Mediawiki integration works better? Has anyone tried that?
  • I think it was setting the cookie path to "/"
  • edited December 2007
    just installed and integrated DokuWiki and so far it seems to be succesfully integrated. Used documentation from Vanilla comunity wiki and it works fine.

    I just wanted to mention that If you have spaces in role names you can use %20 as space in acl.auth.php
    For example if you have Role name e.g. "Allowed enough", you can use:
    * @Allowed%20enough 8
    Also utf-8 characters in role names work, you just need utf-8 capable editor to add such role into acl.auth.php

    I had to comment check for magic_quotes_gpc, because there is no way for me how to disable it by .htaccess (causes 500 ISE, I have to contact my provider).
    But anyway so far it works fine. Does anybody know what can happen if I have magic_quotes_gpc turned on?
2
Sign In or Register to comment.