Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us

Invite-Only System

edited November 2007 in Questions
This discussion is related to the Invite-Only System addon.
Invite-Only System


  • Uploaded version 0.3.0.a of Invite-Only System.
  • I think this is has a very good concept for like a private forum site. My developing site isn't private but now I want to make it private so I can use this.
  • I saw that one of the links in this AddOn wasn't using the GetUrl() function properly to make the link completely Friendly URL compliant. It is a quick change. This fixes the Invitations link under Account Options when on the Account page:

    Find (around line 292):
    $Panel->AddListItem($AccountOptions, $Context->GetDefinition('InvitationSystem_Link'), GetUrl($Context->Configuration, 'account.php', '', '', '', '', 'u='. ForceIncomingInt('u', $Context->Session->UserID) . '&PostBackAction=Sesame'));
    Change to:
    $Panel->AddListItem($AccountOptions, $Context->GetDefinition('InvitationSystem_Link'), GetUrl($Context->Configuration, 'account.php', '', 'u', ForceIncomingInt('u', $Context->Session->UserID), '', 'PostBackAction=Sesame'));
  • Possible to set which user groups can have invitations? :D Whoops, just studied the plugin more carefully. Got it now, thanks!
  • Where should the invitation Form appear? I copied the files in /extensions and activated it but there doesnt appear a link or something on the hole forum :/

    Invited by: and Invitations sent: stuff appears, only that link is missing
  • You need to go in the registration setting page to activate it and add the permission to send invitation to the role you want to allow to send invitation. Read the readme file for details.

    After you can sent invitation on your account page.
  • Errors... big error...

    For some reason this thing went bonkers! It messed up my settings.php and reset the fields in the admin page. I reset it and now it gives me this;

    A fatal, non-recoverable error has occurred
    Technical information (for support personel):

    Error Message
    Could not create the Invitation Table
    Affected Elements
    undefined.Invite System Installer();

    The error occurred on or near: Duplicate column name 'InvitationID'

    For additional support documentation, visit the Lussumo Documentation website at:


    So any suggestions? Should I just disable the invite system and delete the invite database and redo it?
  • Add "$Configuration['INVITATION_SYSTEM_FIRST_ACTIVATION'] = 1;" in conf/settings.php

    The installer should check the column exist before trying to install it. I have to add that.
  • Ummm.... thats already in my settings.php file....

    Okay, got it working now. Had to delete the database entries in User database and the complete Invitations database.
  • Sorry, it was $Configuration['INVITATION_SYSTEM_FIRST_ACTIVATION'] that needed to be added (I updated the previous post).
  • Any chance of getting an updated release with this fix as well?
  • Uploaded version 0.3.0.b of Invite-Only System with the above fix.
  • Uploaded version 0.3.1 of Invite-Only System.
  • Change log:
    + 0.3.1:
    - Fixed installer bug when the invitation fields in the user table exist already.
    - More friendly link (thanks to gpreston).
  • Nice one. Somehow I managed to ingore this add-on so far.
  • Woo, good deal! Thanks a lot for the great work on this addon :)
  • hello,

    i get this error after i install the extension...
    Could not setup the table or the settings for the Invitation System extension. Please check your permissions.
    the read/write ftp settings are all ok and readable so far.

    any hints?
    thanks in advance
  • You can try to drop the invitation table and the three invitation fields in the user table; remove the invitation settings from conf/settings.php; and then retry to install.
  • hm, still got the same error message, i also 777' all extension files and folders, but still no success so far.

    one more hint? :D

  • Uploaded version 0.3.1 of Invite-Only System.
  • @ fery: I added a new error message, that should tell us which part of the process fail (I didn't change the version number, nobody else than you need to upgrade).
  • ah ok, thanks dino I'll give this a try
  • ok, so the error messages finally are:

    1) Could not add column and tables for the Invitation System extension to your DB.
    2) Notice: Undefined index: Invitation in /srv/www/web391/html/Leute/extensions/InviteOnlySystem/conf/settings.php on line 31

    also if i remove the four mentioned db tables in database.php

    (all folders are chmod 755)
  • It seems the problem is with $Context->DatabaseTables['Invitation']. It can't find it but it's defined in InviteOnlySystem/conf/database.php. I don't know what is the problem.
  • Erm, Hi. Not too sure whether this has been answered or not, but I've installed this add-on on and everything seems to be running smoothly. The only problem is that I cannot locate the form for it. I mean, it is nowhere. I've read readme.txt and it says nothing. I've read the comments made and they do not help. I've set everything up in settings and it is not in my account section. Any help?
  • Quin, when you are logged in on your account page there should be a link in left column label "Invitations". Click on that to get to the form. If you don't see it then my guess would be that you did not enable the Invite-Only extension on your settings Registration page.
  • this is a great add on, thanks.

    are there any plans to add a text area so users sending out invitations can send a custom message to the invitee?

    without this customized message many invitees are thinking it's spam.
  • pretty god idea also it does not work for me
  • it just doesn't work. after it's enabling in "extensions" nothing happens :(
  • What is the problem? Have you read the instructions?
Sign In or Register to comment.