Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Notifi

1457910

Comments

  • Uploaded version 2.0 of Notifi.
  • Please see the changelog for this new version. There are quite a few new features, but some are still missing. I have been using this version for weeks on my forums and I don't know when I will complete all the features suggested here, so I just wanted to release it.
    If the feature you wanted isn't in this version I'm sorry, it isn't because I forgot or because it isn't important, I just happened to do them in this order (mostly the order in which they were suggested). When I have more time I will do the other features.
    Anyway, this version is really cool and I hope you like it too. Enjoy.
  • "Gonna" try it out. I'll give you feedback if anything goes wrong, so you probably don't want to read my messages here anymore. :P This Lussumo Bot guy should give us a direct link to download new versions so I don't have to visit the add-ons section, therefore wasting 2 clicks and 2 pageviews! Damn him! :D
  • Just installed it. A bit confused as to what has changed - what does "Force notification in all cases" mean?
  • Hmm. I just had a bounce back, where it was trying to send a notification to someone who wasn't even involved in the thread I posted in. not only that, but the text appeared to be flooded with ampersand html equivalents. I've turned off the "Force notification in all cases" for the moment I won't upgrade my other site until I understand what is going on.
  • This was in the e-mail - using BBCode:

    Just doing a test post for the new notification system to see if now <strong>supports</strong> <a href=" http://www.bbcode.com">BBCode</a>!
  • Just commenting on the way this is working for me. I am trying to get all posters to a discussion notified of a reply to a discussion, but it appears that a notification will be sent back to the most recent poster. This is my scenario, "force notification in all cases" is ticked. 3 users: user one (the OP), user two, user three User one posts, logsout. User two replies to post. User one receives email notification. User two logsout. User three replies to user two's post. User two receives email notification...but not user one. Doesnt it seem like user one and user two should BOTH receive notifications that user three has posted? Thanks for any advice. I am not sure if I am using this extension properly if only one person is getting notified of an additional post to a discussion...
  • @ spode:
    The changelog has a list of changes. Force notification in all cases is a setting for testing that has been there since 1.8.0, it just means that everyone will be notified of everything. I don't think it should ever be enabled in a non-testing environment.
    Hopefully disabling that will fix any problems you had.
  • @ cwwwwww
    Yes you're right. I will look into it.
  • thanks SJ. notifi and not many more addons make a perfect forum.
  • Hey SJ,

    I did see the Changelog, but I wasn't seeing any new options in the Notifi panel - such as "Added the option for users to be automatically subscribed to discussions they participate in". Where do I change that? Is that a forced option like we talked about?

    I've turned off the option you suggested - but I'm not sure that will solve my BBCode formatting issue? I'll give it another try at some point and see if it helps :)
  • With version 2.0 there should be the following options for admins in the settings:

    Allow users to subscribe to the entire forum
    Allow users to subscribe to categories
    Allow users to subscribe to discussions
    Convert BBCode to HTML
    Send emails as plaintext instead of HTML
    Force notification in all cases

    The option for users to be automatically subscribed to discussions they participate in is in each user's settings, because it is only fair to give them the option. It is enabled by default.
  • Why not make "Send emails as plaintext instead of HTML" a user setting, as users prefer different things... That would be preferred by my userbase.
  • Yeah I think I will do that.
  • thanks for the update. a couple of suggestions if I may...

    in the Account - Notification section there is a setting that allows a user to subscribe to the entire forum. The word "discludes" should be "excludes".

    also, your ZIP file doesn't create a Notifi directory. It always unpacks the files into the current directory. Could this be made to include its own directory?

    good work tho.

    cheers
  • Disclude is a word. It comes from the Latin "discludere" which means "to shut apart". It is a synonym for exclude.
    Sure I can zip a folder next time if I remember.
  • It may be a word, but nobody uses it that way. "Excludes" is what you should be using.
  • Both of you should stop using "should" as if you know any better than me.
    There are plenty of people who use disclude that way (here is a perfect example) and the fact that you aren't aware of it speaks more to your ignorance of the English language than to mine, as well as probably the area of the world in which we live, so stop embarrassing yourself by trolling and go argue with someone you have a chance of winning against.
  • I'm up for an English language argument as much as anyone - but I don't think they are arguing that it isn't correct, or that it isn't a word - but more that it's not that commonly used. if 2 people are already complaining of this - a lot more people might struggle too :)
  • Just wanted to report the same problem as @spode. Lots of & characters.
  • @ trolls and spode:
    Then they can go make their own extensions and call them Exclude and Excludes.
    The description of the extensions could be something like "Enables users to forgo their imaginations by only accepting the most commonly used synonyms. For every user who installs this extension we will tear up one (1) thesaurus and cause language graduates and enthusiasts to weep for the all-but-lost art of writing.".
    I see your point spode and thanks for mediating but for one thing I'm just having some fun (:-D), and for another thing it's obviously not causing them to understand the sentence incorrectly; they aren't suggesting the word be replaced by "includes" or "coffee mug".

    @iamspammer
    Is the force notification feature enabled or disabled? I think I will just remove that feature in the next version, it really doesn't serve any good purpose.

  • $mName = '';
    if ($val[2] != '') {
    $mName = ' '.$val[2];
    }


    There's no need to add an extra space there, as you do |Hello '.$mName.',| later on in the code. You can just do |$mName = $val[2];|. The extra space looks weird currently.
  • Would it be possible to add Jabber notification to this add-on? I was pointed out that http://code.google.com/p/xmpphp/ would be helpful. Thanks for the plugin though, I'll be using it soon :)
  • I have 2 problems with Notifi & I'm hoping you can help. Thanks so much for all that you've done so far. 1. I'm subscribed to the entire forum but rarely get any emails telling me about an update. There seems to be no rhyme or reason as to what gets sent to me. I'd have like 8 new postings to the forum but get 1 email which only has 1 message in it. Any idea what's going on? 2. When I tried to upgrade to Notifi 2.0, it causes an error. Some directory error. I'll have to reinstall to get the error again.
  • @SubJunk

    I din't have it on as I was testing it without that. I was thinking to turn it on when I received first notification with this extension. That email had @@ in it so I reverted back to older version.

    Thanks
  • First of all, Thank You for this Add-On, SubJunk! But as all readers might have guessed already, I have a problem: I downloaded and unpacked version 2.0 as of 2008-12-29 yesterday. After copying the Notifi directory into the extensions directory of my vanilla development installation, which has got an URL of 4 directory levels deep under the web server's root URL, I could not see it in vanilla's extensions pane. I added two extensions afterwards (InlineImages and LightBox) which show up as expected. Remembering from earlier discussions that there once had been an issue of a missing brace I checked for a regression of that kind, but couldn't find one. Because I'm more the sushi kind of coder (smalltalk, ruby, python in order of personal preference) It may be of course that I'm missing something potentially obvious. Can anybody help me out? Lots of thanks in advance from a newbie to this community (although a frequent reader since about two years).
  • Here are some more details about my installation as an addendum to my posting of yesterday about Notifi not to be seen on the extensions adminstration page: Mac OS X 10.5.6 Apache 2.2.9 (as pre-installed by the OS with virtual host declarations for development, added by me) PHP 5.2.6 MySQL 5.0.51b (via socket) Vanilla version 1.1.5a List of Add-Ons before adding Notifi: AddMember 1.0, Attachments 2.1, BlogThis 1.14, PageManager 2.5.3, TagThis 1.07, Textile 2.0. As already mentioned I installed after Notifi: InlineImages 1.3, LightBox 2.03.3 - c. For the sake of completeness, the additional installed language is "Deutsch-formal" and some themes. Both (languages and themes) do not seem to have any influence on the behaviour described in my previous comment, as is the case with the browser used (Firefox 3.0.5 vs. Safari 3.2.1). Any clues will be highly appreciated. Thank you for your time!
  • Ok, I figured it out, and it was quite too obvious: After unpacking the zip file on Mac OSX the directory's right mask is 700 (drwx------), hence it could not be read by the web server process. Good ole command line... Sorry for polluting the thread.
  • @reedloden:
    You're right, I have changed it for the next version. Thunderbird (the email client I use) ignores double spaces so I never noticed it.

    @Vadi:
    I've never used Jabber, I don't even know what that is, but if you want to write some code that gives Notifi that functionality feel free to do it and we can work out some kind of release.

    @Left Brain:
    1) By default, Notifi will email you only once until you visit the forum. You can set it to email you every time a comment is made in your account settings, though.
    2) It would be good if you can paste that error into here so I can see it. Thanks

    @iamspammer:
    I can't reproduce the bug, I have tried new installations and old ones and played with settings but can't make it produce those unwanted characters. Maybe it is a conflict with another extension, can you please tell me which other extensions you have enabled?

    @ofi:
    I'm glad you found the solution, sorry I wasn't here sooner to try to help.
  • Jabber is an IM protocol. Google uses it for GTalk.

    I'll see if I can get something going later on.
Sign In or Register to comment.