Fork me on GitHub
Current release is 2.1.6 (21 Nov 2014).

Users who have not yet upgraded to 2.1 should get security release 2.0.18.14 (1 Nov 2014). We will stop providing these security releases to 2.0 at the end of this year.

Error while enabling plugins, but no error text

edited July 2010 in Vanilla 1.0 Help
I've posted this in the issue tracker as well, but maybe someone here knows what this is. I can't enable plugins, I get an error. The first problem is that the red error box doesn't show an error, instead it dumps the listing of discussions from the front page into the box.

image

As for the plugin enable issue, I had two plugins enabled, and I disabled one, and can't re-enable it, either.

I just upgraded from RC2 to the latest Vanilla 2, last night.

Additionally, when I go to utility/structure, I get this:


update GDN_Permission p2
inner join GDN_Category c
on c.CategoryID = p2.JunctionID
and p2.JunctionTable = 'Category'
and c.Name = 'General'
inner join GDN_Permission p
on p.RoleID = p2.RoleID
and p.JunctionTable is null
set
p.`Vanilla.Discussions.Add` = p2.`Vanilla.Discussions.Add`,
p.`Vanilla.Discussions.Edit` = p2.`Vanilla.Discussions.Edit`,
p.`Vanilla.Discussions.Announce` = p2.`Vanilla.Discussions.Announce`,
p.`Vanilla.Discussions.Sink` = p2.`Vanilla.Discussions.Sink`,
p.`Vanilla.Discussions.Close` = p2.`Vanilla.Discussions.Sink`,
p.`Vanilla.Discussions.Delete` = p2.`Vanilla.Discussions.Sink`,
p.`Vanilla.Discussions.View` = p2.`Vanilla.Discussions.Sink`,
p.`Vanilla.Comments.Add` = p2.`Vanilla.Discussions.Sink`,
p.`Vanilla.Comments.Edit` = p2.`Vanilla.Discussions.Sink`,
p.`Vanilla.Comments.Delete` = p2.`Vanilla.Discussions.Sink`
where p.RoleID <> 0;


No matter how many times I run the script, I can rescan and still get that.

Anyone know where to begin to fix this stuff?
Tagged:
Sign In or Register to comment.