Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


2.0.3 themes bonk

edited August 2010 in Questions
Just installed 2.0.3 upgrading from 2.0.2.

If I change the theme to anything other than the default I get a BONK. Anyone else having this problem?

Update: Preview themes bonk as well.
Tagged:

Comments

  • Is it a write permission issue on conf/
  • Don't know. I copied my same config that worked fine with 2.0.2.
  • I've done a fresh install of 2.0.3 and themes work fine. Not that this helps your situation too much, but at least it doesn't seem to be a general bug.
  • Still broken. I guess I'll wait for 2.0.4 and see if that fixes anything.
  • have you tried changing your "bonk" to the developer's page? How-to Here

    What does the error say?

    What themes are you using?
  • Ok I had reinstalled 2.0.3, reimported my V1 database and this problem went away.
    Now I have installed 2.0.4 and the problem is back. After applying or previewing any theme other than the default it get:

    The error occurred on or near:
    library/vendors/Smarty-2.6.25/libs/Smarty.class.php

    1109: * @param integer $error_type

    1110: */

    1111: function trigger_error($error_msg, $error_type = E_USER_WARNING)

    1112: {

    1113: trigger_error("Smarty error: $error_msg", $error_type);

    1114: }

    1115:

    1116:

    1117: /**


  • @Desmanthus; Not sure if it's relevant, but I just copied 2.0.4 over 2.0.3 and on emptying the /cache/ folder I noticed /Smarty and /Minify folders there. After playing around without Minify enabled (as it caused theme errors for me) I find neither folder exists now, ie., they haven't been recreated. So I'm thinking Smarty is part of Minify? If you have Minify enabled you could try killing it and doing an aggressive cache clear-out..?
  • All plugins are disabled. Cache cleared. Same results. Do you think this has anything to do with running the utility/structure updater? That was the last thing I did before uploading the theme and trying to enable. I think I forgot to do that on the 2.0.3 that was working.
  • edited September 2010
    @Desmanthus; I ran the updater when upgrading 2.0.3 to 2.0.4 and all was ok. Sorry this isn't a quick fix answer, but I just changed themes and back again on a 2.0.4 site to test it, and everything is fine. Calling @Tim!
  • Ok thanks. Glad to know it's not widespread. I guess I will have to reimport that V1 data. That is what I did last time and it solved the problem.
  • Reinstalled, reimported and everything is working great!
  • @Desmanthus: I had this problem as well when I upgraded (or at least I got the same error). It happened when I deleted everything in my cache folder.

    I'm not entirely sure what I did. I went into the config.php and disabled all the add-ons and then I told Vanilla that I hadn't installed it. This brought me to the install screen, but I realized I didn't want to do that. So I went back and changed the config file *back* to say that I had installed it.

    And then it worked. I really wish I was more methodical sometimes. I'd love to know exactly how I fixed some of these problems.
  • it is permission issue, set the 777 recursive on cache and conf

    I got it fixed
Sign In or Register to comment.