Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Double breaks after every paragraph

tmilovantmilovan New
edited August 2010 in Questions
This discussion is related to the Markdown addon.
Hi,

I'd like very much to use Markdown on my site (2.0.3) but I'm getting double breaks after every paragraph. Any way to amend this?
Tagged:

Comments

  • Do you mean visualy you get double breaks?

    It should be possible by changing CSS style, to change p margin
    http://lab.artlung.com/change-space-between-paragraphs/
  • I don't see any double spaces in Markdown code, just in wordpress functions, but it's just new line, which should not be visible.

    Btw, isn't Markdown supported in the core of Vanilla? I use it w/o this addon enabled
  • I'm getting two br tags after every paragraph. If markdown is included how can I enable it?
  • Try just$Configuration['Garden']['InputFormatter'] = 'Markdown';in your /conf/config.php file
  • That works. Thanks.
  • Hi - I'm getting this issue too, but putting that line in my config file didn't fix it... anyone have any other suggestions?
  • Did you disabled the markdown addon?
  • edited December 2010
    like vanik the garden inputformatter method does not work for me using V2.0.15
    disabling the markdown plugin just switched off all markdown syntax processing.
    but it could just be a minor slipup like a package not in the install as in the recent missing empty folder in smarty.
    As a test I have identical text in a first post in thread and in a comment post
    viewing the source
    <h4>Paragraphs</h4><br />This is a paragraph. It has two sentences.<br /><br />This is another paragraph. It also has two sentences.<br /><br />etc....
    in the initial post and
    <h4>Paragraphs</h4><br /><br /><p>This is a paragraph. It has two sentences.</p><br /><br /><p>This is another paragraph. It also has two sentences.</p><br /><br /><p>etc.... in the reply post

    its a pain but markdown and vanilla together should not produce double br and p tags and consequent double spaced lines round paragraphs.
Sign In or Register to comment.