Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Enabling Friendly URL's

edited August 2010 in Questions
Hello,

I have Vanilla Forums now up and running at:
http://css-tricks.com/forums/

My friendly URL's are not working though. I notice that in the config-defaults.php file there is a setting for it.

$Configuration['Garden']['RewriteUrls'] = FALSE;

If I change that nothing happens, and if I make a config.php file (removing -defaults) it wants to reinstall the whole software.

Is there a way to enable this "after the fact"?

I do already have the .htaccess code in place, from another install of Vanilla that is doing Friendly URL's correctly.

Comments

  • You should already have a config.php located in the /conf/ directory, which is created when you first install Vanilla. Changes to config-default.php won't result in changes to the actual forum configuration, as far as I'm aware.
  • Thanks for the response!

    Ah yeah, my FTP client must have been caching that directory. It's there, and I changed the setting, and it works.... kinda.

    Last thing that seems weird is this:
    http://cl.ly/24P5

    Should in between those slashes be the "friendly" stuff?
  • It should be the thread title. I'm not sure what's going wrong, there. Sorry. :(
Sign In or Register to comment.