Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Double Text

edited August 2010 in Questions
This discussion is related to the CLEditor jQuery WYSIWYG addon.
Whenever I enable this plugin, the edit box doubles everything I type. It's hard to explain, but basically the top box (where I'm typing) is html and then there's like a bottom box that is the WYSIWYG version. Is that how this plugin is intended to work? It's very disconcerting.

Comments

  • @Lykaon: That's a known bug that we're trying to figure out. It's mentioned in the description on the Addon page

    (Not a true solution, but If you click the 'HTML' button a couple of times it will display just the WYSIWYG view.)

    Are you seeing it on 'Start a New Discussion' textareas also?
  • @rak: Thanks! I totally missed that on the page. I feel dumb for posting about this. Sorry.
  • @Lykaon: No worries! I almost missed seeing this thread!

    For others, check out the main CLEditor thread...
  • MarkMark Vanilla Staff
    I've fixed this issue, and a bunch of other issues with this plugin, like:

    1. Removed autogrow from textbox. Caused previous bug of showing both html and wysiwyg.
    2. Disabled safestyles. Caused inline css to be ignored when rendering comments.
    3. Added livequery so textareas loaded on the fly (ie. during an inline edit) get wysiwyg.
    4. Upgraded to CLEditor 1.3.0

    I hope rak doesn't mind me stepping on his toes a bit, but it was so close to perfect!
Sign In or Register to comment.