Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Last Edited Addon Not working for first post of the discussion*

tmilovantmilovan New
edited February 2011 in Questions
This discussion is related to the Last Edited addon.
Great you added "Last edited" functionality as a plugin. However, it works fine except for the discussion starting post.

Comments

  • Works ok for me in the first discussion post @tmilovan. Maybe it's a clash with another plugin?

    What I did notice though, is that a tag which was assigned to a test discussion which had been deleted was still in the tag list, and the link went to a 'Not found' page. @Tim may like a peek at this?
  • TimTim Lord of Servers Vanilla Staff
    This was fixed.

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • tmilovantmilovan New
    edited September 2010
    @Mikhae: tried to disable them but witout success. But I have turned on Markdown input method. Can that be the reason?
  • Just to bump this. It still does not work for discussion starting post on my forum. Vanilla 2.0.16.

    Also I have noticed that sometimes Markdown would not kick in for starter post too (but only sometimes, last edited never works). Can that be connected with the fact that I have migrated my forum from phpBB3.
  • Is this a permission issue? I've not tried this plugin, but in the permissions screens is there a way to turn it on and off for discussions and comments across the categories?
  • No. There is nothing in permissions screens.
  • edited December 2010
    I'm getting an error which seems to be associated with the first post, so I thought I would post it here:

    Fatal error: Call to a member function Get() on a non-object in /.../vanilla/plugins/LastEdited/class.lastedited.plugin.php on line 63

    I'm using the latest production release as of today's date.
  • @mostmodernist Did you convert a forum to Vanilla?
  • Hi there.

    I'm getting the same thing:

    Fatal error: Call to a member function Get() on a non-object in /.../vanilla/plugins/LastEdited/class.lastedited.plugin.php on line 63

    I get an odd problem in that when I navigate away from my Vanilla forum to another open browser tab and then return later, a lightbox (popup) has appeared with the text from the first post in the discussion and then the fatal error at the bottom.

    I have the latest version of VF - installed last week...

    Has anyone got any closer to the solution for this one - I really liked this plugin (last edit) but might have to disable until I can fix this.

    Thanks for any help...
  • I am getting this error too:
    Fatal error: Call to a member function Get() on a non-object in /home/libertat/public_html/platforma/forum/plugins/LastEdited/class.lastedited.plugin.php on line 63

    using Vanilla 2.0.17.8 and some other plugins, with the vanillapress2010 theme.
  • I'm getting the same error as above as well, using vanilla 2.0.17.8.

    For the time being I've disabled the plugin but would like to know if a fix is coming?
  • TimTim Lord of Servers Vanilla Staff
    I am getting this error too:
    Fatal error: Call to a member function Get() on a non-object in /home/libertat/public_html/platforma/forum/plugins/LastEdited/class.lastedited.plugin.php on line 63

    using Vanilla 2.0.17.8 and some other plugins, with the vanillapress2010 theme.
    Uploaded a small fix that should take care of that.

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • have updated my plugin, enabled it and so far not getting any errors!

    many thanks for sorting this out...
  • Dear Tim, thank you, this is great news!
    I will test it immediately and post a feedback.
  • I updated the plugin, now everything works fine! Thank you!
Sign In or Register to comment.