Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


[VanillaPress2010 Theme] Theme - This is for a localhost install of WP3 + V2

edited February 2011 in Questions
This discussion is related to the VanillaPress2010 addon.
This appears to me to be a proof of concept theme for a localhost install of WP3 and V2

It also gives the error "Unable to write to config file '/home/content/11/8579411/html/discus/conf/locale-en-CA.php' when saving." if you attempt to modify the banner text in the theme options.

I'd expect locale-en-GB for myself
so one for adaptation by the hobbyist but not quite ready from prime time.

Comments

  • Actually it works perfectly for me and is fully functional. I'll soon have it integrated with wordpress using the proxyconnect plugin.

    The error message might be due to your write permissions
  • RaizeRaize
    edited October 2010
    Actually, it's because the file you mentioned doesn't exist. It must have been moved in the newer versions of Vanilla.

    You can easily change that text by going into the default master view of the theme
  • WRONG
    the zipped archive has a file /views/default.master.tpl with explicit "http://localhost/wordpress" references
    My write permissions for the file are 604 and the directories 705 (so there is nothing wrong with them).
    In the error message /discus/ is the equivalent of /forum/ for my evaluation forum, i.e. not a fully live forum, my users can find it but are not being sent there for any support YET. (My current live forum is bbPress)
    I think without some language package there ( I see there are applications available for fr-FR de-DE es-MX pt-BR it-IT ru-RU, I'm surprised no fr-CA - so Vanilla has had very little localization done so far)
  • TimTim Lord of Servers Vanilla Staff

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • RaizeRaize
    edited December 2010
    did you read the post right after the one where i guessed it was your write permissions? i went back and checked, and there is NO "conf/locale-en-CA.php" in Vanilla 2.0.9 hence the error. The only thing affected is the banner text, and you can change that simply by editing the "default.master.tpl" file directly. I hope that's more clear
  • edited October 2010
    @raize - you miss my point the locale-en-CA.php appears to be an on the fly constructed path as part of localisation, which is at present incomplete, and may have errors.

    is your installation of WP a /localhost one?
  • RaizeRaize
    edited October 2010
    no it's live sorry i guess it's getting a little too technical for me! i'm just a marketing dude lol
  • @DavyB My apologies for answering this late. Your are correct. I accidentally left the localhost links in from dev ... just remove them and add your own links in there place and it should work without a problem.

    I also, updated the .zip as well.

    Community Manager for Vanilla Forums

  • You said that you updated the zip but I just installed this theme for the first time today and got the same error as @DavyB.

    It also just shows a broken image link where the header image should be. The image linked to mydomain.com/forum/index.php?p=/themes/VanillaPress2010/design/vanilla_offices.png so I had to go in and hard code the correct URL.

    Is there any way to make this work correctly as I am setting this up for a friend and don't want have to be editing files to make changes when he could be doing it himself.
Sign In or Register to comment.