Fork me on GitHub
Please upgrade to 2.1.x here. The 2.0 branch is no longer being updated.
Important security fix: 2.1.10, released 4 May.

Trying to install Vanilla Forum on web site problem

edited October 2010 in Vanilla 2.0 Help
I have my own domain name and I am creating a web site on a free server. I uploaded the Vanilla Forum and when trying to start it, having navigated in my browser, I got the following error: Fatal error: require_once() [function.require]: Failed opening required '/home/a3395946/public_html/vanilla-2.0.10/vanillaforums-Garden-b8cd4b4/library/core/functions.error.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/a3395946/public_html/vanilla-2.0.10/vanillaforums-Garden-b8cd4b4/bootstrap.php on line 21. Can anyone help? Thanks

Comments

  • I used to get a similar error when I didn't have the conf/ folder on the server. Can you please make sure once more if all the required files are on the server?

    /cd
  • Thanks. I reuploaded when I saw several files not there. I called the new folder "Vanilla" and , now when I navigate, thru my browser, to this folder, I see the Index of that folder. Question is, how should I start it? It doesn't automatically start, as the instructions said it would.
  • This is the list:
    Index of /Vanilla

    * Parent Directory
    * .gitignore
    * LICENSE.txt
    * applications/
    * bootstrap.php
    * cache/
    * conf/
    * js/
    * library/
    * plugins/
    * readme.html
    * themes/
    * uploads/
  • Ok, now uploaded index.php (it wasn't originally uploaded for some reason) and now get the following error: Fatal error: require_once() [function.require]: Failed opening required '/home/a3395946/public_html/Vanilla/library/core/functions.error.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/a3395946/public_html/Vanilla/bootstrap.php on line 21
  • Looks like the same error to me. This is what I have in my Vanilla installation:

    applications/
    bootstrap.php
    cache/
    conf/
    .htaccess
    index.php
    js/
    library/
    LICENSE.txt
    plugins/
    readme.html
    themes/
    uploads/


    Please make sure the conf/ folder has the original things, clear the cache and uploads folders and give it another spin. If it's still not working, try to get a screenshot of the entire file system tree on the server so we can compare it.

    /cd
  • I'm trying to reload the entire Folder onto the server, having a little trouble and short on time. It might be that the entire Folder DID NOT upload. I will let you know. It just might be a few days, since I won't be at this computer after today. I do appreciate your help, though and will let you know, one way or the other.
    Thank you.
  • I checked everything that was downloaded to my computer to what I uploaded to the server and it matches exactly. I now get the error: Fatal error: Class 'PDO' not found in /home/a3395946/public_html/vanilla/conf/config-defaults.php on line 16
    when I navigate to the folder "vanilla" which is what I called it. I presume I can call it anything I want, rather than what was downloaded?
    The tree structure is exactly what I downloaded. I could send you the zipped file that I got when downloading the software, if that would help?
    Thanks, as always,
    Ed
  • Do you have PHP MySQL PDO extension installed and enabled on your machine? It is one of the prerequisites of Vanilla.

    /cd
  • I just found out that PDO is not supported at the server I am using for the plan I have.
    I guess that's why it didn't work. Thanks for your help.
Sign In or Register to comment.