Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Error when posting: Fatal error

edited October 2010 in Questions
Whenever I attempt to post something on my forums, I get this error in an inline-popup:


"The "DraftModel" class could not be found." LOCATION: /home/seiferttristan/public_html/discuss/library/core/class.controller.php > 794: } else { > 795: $this->$Property = new $Class(); > 796: } > 797: } else { >>> 798: trigger_error(ErrorMessage('The "'.$Class.'" class could not be found.', $this->ClassName, '__construct'), E_USER_ERROR); > 799: } > 800: } > 801: } > 802: BACKTRACE: [/home/seiferttristan/public_html/discuss/library/core/class.controller.php] PHP::Gdn_ErrorHandler(); [/home/seiferttristan/public_html/discuss/library/core/class.controller.php 798] PHP::trigger_error(); [/home/seiferttristan/public_html/discuss/library/core/class.dispatcher.php 227] Gdn_Controller->GetImports(); [/home/seiferttristan/public_html/discuss/index.php 38] Gdn_Dispatcher->Dispatch();



What could be causing this? I have not touched a single file within a week or so, and this only started happening today.

Please help me with this, as I need it working urgently. Thanks :)

Comments

  • Hmm, I did a search for DraftModel throughout all files, and it did show up in a model file.

    I have figured the issue out - the file
    applications/vanilla/models/class.draftmodel.php
    is never included anywhere, so I simply added a

    require("/home/seiferttristan/public_html/discuss/applications/vanilla/models/class.draftmodel.php");

    in the files that had to require them.
Sign In or Register to comment.