Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Anonymouse 2.1.5 bugs and some fixes

edited January 2011 in Questions
This discussion is related to the Anonymouse addon.
I figured out what was causing 100% cpu usage.
anonymouse.plugin.php Line 151: change PHP_INT_MAX to 0.

There are still some other bugs that I don't know how to fix.
- Name doesn't show up when you start an anonymous discussion.
- When you delete a post it says "Fatal error: Call to a member function Get() on a non-object in /var/www/vanilla/plugins/Anonymouse/anonymouse.plugin.php on line 121

Minor bugs
- The captcha image and box are bigger than the name box.
Tagged:

Comments

  • SS
    edited January 2011
    @Bottiger
    1. Weird, changed PHP_INT_MAX => 2147483647
    This is used to set cookie value lifetime as max possible (2147483647 ~ Jan 2038)
    2. Known, just now fixed in 2.2.10
    3. Fixed few days ago in 2.1.7
    4. Settings for captcha image can be found in captcha\imagettfbox.php file.
    $Configuration['CharWidth'] = 25;
    $Configuration['CharHeight'] = 25;
    Css style for textbox of captcha code in anonymouse.css
    #Form_CaptchaCode
  • PHP_INT_MAX is larger than that on 64 bit php.

    And it looks like you fixed everything except some posts show IPs of '2147483647' which shows up as 127.255.255.255
  • how to enable spam filter for anonymouse users? that they cant write more than 2 comments in 1 minute? for registred users im set spam filter, but anonymouse can write unlimited comments
  • I'm having problems with the order of the anonymous coments...
    When an anonymous do a comment, the comment stays as the first in the list (even if it's not the first comment), and when someone that has a login comment in the same post, the comment made by the anonymous go to the right place (in the last position). Anyone knows what could be wrong? Thanks!
  • SS
    @psycocandy
    Go to Dashboard > Roles > Edit > Guest and make sure that guests has permissions to view category where you are trying to post anonymous comment (this requires to make category with custom permissions).
    Permissions from "Default Category Permissions" is ignored.
  • edited July 2011
    @psycocandy
    Go to Dashboard > Roles > Edit > Guest and make sure that guests has permissions to view category where you are trying to post anonymous comment (this requires to make category with custom permissions).
    Permissions from "Default Category Permissions" is ignored.
    Perfect! Thank you very much @S! =D
Sign In or Register to comment.