Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Vanilla is proud to present version 2.2.
Please upgrade to 2.1.x here. The 2.0 branch is no longer being updated.

[ProxyConnect Addon] is proxyconnect 1.8.4 compatible with vanilla Version

edited February 2011 in Vanilla 2.0 Help
Hi I am stuck with integrating wordpress and vanilla. Is proxyconnect 1.8.4 compatible with vanilla Version If compatible, why I am not able to install the plugin in vanilla and wordpress? I kept the plugin inside plugin directory of the vanilla but can't see it on dashboard to activate

Please help


  • I am having issues with ProxyConnect 1.8.4 and Vanilla as well.
    (trying to integrate with my own system).
    After copying ProxyConnect to the plugins directory, it does appear in the dashboard, however, when I try to activate it under authentication, the list box is disabled and shows only "Manual Integration". Furthermore, the form for AuthenticateUrl etc. is not shown at all.
    Has anyone managed to get these versions to work together?!
  • I'm having the same issues for Manual integration and those versions. I've briefly got ProxyConnector 1.8.4 working (Manual Integration) with 2.0.16 but even that is flaky as hell. If it could just say something more meaningful than the infuriating Bonk message as well.....
  • @odeclass, add this to your config.php file and you'll get a better error page...

    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

    ... got to love how these new release break features.
  • It's even better {SARCASM} in released yesterday - ProxyConnect plugin can't access any settings at all.
    I've tried a ProxyConnect 1.85alpha and that has the same issues as and 1.8.4
  • @odeclas Where did you get that alpha version of this plugin? Could not find ProxyConnect on github.
  • I think it was posted on here somewhere - sorry, can't remember (and it doesn't work, anyway). I'm going to try with an older version of Garden and see what fruits that brings.
  • Ok - 2.0.16 seems to work ok (download it from GitHub) with ProxyConnector 1.84 - I had mistakenly set the registration mode to Invitation at some point after I had configured it initially. The other gotcha is that config.php is sometimes not writeable by the process, so creating a blank config.php, then installing Vanilla, seems to fix that initial hurdle.
    Still no joy with either or
  • Just updated my Vanilla test-installation to 2.017.9 and luckily I cannot confirm that ProxyConnect does not work at all. Seems to be no change from earlier version: SSO integration with WP 3.1 generally appears to be working quite well, except for that annoying nag-screen upon logout from Vanilla.
  • I switched over to ProxyConnect 1.8.4 from 1.9.7 and it worked perfectly with Vanilla
    Fantastic. You guy have developed a great forum app.

    I hope this is helpful to someone else.

    Much thanks
Sign In or Register to comment.