Fork me on GitHub
Please upgrade to 2.1.x here. The 2.0 branch is no longer being updated.
You should grab 2.1.9, released 18 March. It's what all the cool kids are doing.

PostgreSQL Database Support for Vanilla

edited April 2011 in Vanilla 2.0 Help
We are looking for PostgreSQL support for Vanilla forums... The project we are working on utilizes PostgreSQL and we are wanting to avoid working between both MySQL and PostgreSQL...

Just wondering if it is supported out of the box or what steps might need to be taken to get it to work...

Thanks!

Comments

  • LincLinc Community Instigator Detroit Vanilla Staff
    It doesn't support it out of the box, but it *is* built on a database abstraction layer, so running it on PostgreSQL would require building a PostgreSQL driver, not changing the core code (generally). Watch out for some MySQL-specific things that have crept in like using FullText for search and maybe some of the column types.

    Sr Developer at Vanilla Forums, humble servant of Lord Brackos, & pro smatcher. [GitHub, Twitter]

  • does this mean we need to modify the code base of vannila. is there anything we can do so that it is confiugrable during the installtion time to support the postgresql database
  • LincLinc Community Instigator Detroit Vanilla Staff
    No, but you would need to write a new database driver, drop it into the /core/database folder, and then set the new database type in the config file.

    Also, several MySQL-specific things have snuck in, so you may need to work around that.

    This is a big, big project.

    Sr Developer at Vanilla Forums, humble servant of Lord Brackos, & pro smatcher. [GitHub, Twitter]

Sign In or Register to comment.