Fork me on GitHub
Current releases are 2.1 (gold) and 2.0.18.11 (security patch for 2.0)
Ready for 2.1? Find out if your favorite plugins are compatible.
The 2.0 branch will no longer receive updates after Dec 2014.

wordpress + vanilla - single sign-on

JonIndieJonIndie New
edited May 2011 in Vanilla 2.0 Help
hey all.. I just installed vanilla on my server along with wordpress and got it embedded nicely. I found several different tutorials for doing all of this and just wanted to make sure I did it right.. and also would like to know if this is the best tutorial for linking up the accounts for 'single sign-on' for me.

right now i'm the only user on wordpress.. so it shouldn't be that hard for me. the users would mostly just be using the forum.. but when they did want to comment on a blog post or something on wordpress i'd like them to not have to login a second time or make a second account to comment on a blog entry.

should I follow this guide to achieve this: http://vanillaforums.org/page/singlesignon

or is there a better one?

also for the embed..
I'm currently using wordpress 3.1.2 with plugin Vanilla Forums 1.0.5
on Vanilla forums I have Vanilla Version 1.0.1 activated

should I have any other plugins on either wordpress or vanilla activated?

Thanks for this solution so far.

Comments

  • FlipstyleFlipstyle New
    edited May 2011
    I followed the instructions for SSO. When you try use proxyconnect it is still a bit buggy and is giving users problems. You can give it a try or wait for a new proxconnect version update.
  • is there any other options available that work better.. or is proxyconnect pretty much it
  • Im also looking for another solution anyone know any other way to sync vanilla users with wordpress?
  • JonIndieJonIndie New
    edited May 2011
    guess i'll go ahead and try proxyconnect then.
  • JonIndieJonIndie New
    edited May 2011
    so.. I went ahead and installed it and linked my account.. after linking and signing out and back in.. a few things messed up at first.. left me logged in wordpress one time and had to delete my cookie manually.. and some weird things happened that i'm not even sure really.. but now i just logged in and back out about 5 times and it worked fine.. haven't really tested indepth by closing out the browser and reopening and what not.. but whatever.

    here's some questions though. I watched the video posted in the help file for proxyconnect and it only showed the manual integration. I chose the wordpress integration since that's what i'm using.

    EDIT: Read 3. first.. I didn't add it until edit.. but it's more important.. forget 1 and 2 for now.

    1. on wordpress it asks for vanilla's cookie domain. but since I chose wordpress integration it's not giving me that information over there.. it just setup everything for me when I set it up on vanillas side and didn't show me anything except a success note. so do I leave the "Vanilla's cookie domain" empty on wordpress?

    2. is it possible to change what page it goes to after login? I have vanilla embeded.. and instead of it going to the discussions page. i'd prefer it goto the homepage or return to whatever page they were on when they clicked sign in.

    EDIT:

    3. I'm trying to add a login link on the index page.. and my main problem i'm running into is the embed function I believe.

    wordpress: domain.com
    vanilla: domain.com/forums/
    vanilla embed: domain.com/discussions/

    using the same mysql database for both wordpress and vanilla.

    I added a login link in the header for wordpress.. and it redirects to: http://domain.com/forums/index.php?p=/entry/signin&Target=discussions

    it takes you to the correct login page.. but once you login it loads the entire site a second time inside of the embed frame.

    any ideas on how to fix this?

    if not.. do you think an ugly fix would work? such as making the login link on domain.com wordpress header link to a page inside of domain.com/forums/ and I could make a header redirect to the actual login page? ..if still no. have any other ideas?

    i'm really wanting to add all the user account links in the wordpress header.. so it's on every page.. and not just the vanilla page. (login/logout, inbox, my discussions, etc)
  • JonIndieJonIndie New
    edited May 2011
    I noticed this on the support page..

    "Annual support & maintenance subscriptions give you faster response times and regular maintenance updates."

    does this pretty much mean that their support team only helps the paid subscribers? ..and this forum is pretty much just for vanilla users to share their experiences and help each other?

    I'm not trying to bash vanilla here.. I'm just curious if the support team will eventually respond when they get around to it.. or if this is solely for nonpaying members to help each other.
    andste
  • lucluc ✭✭
    Official devs come from time to time, but they're currently spread thin.

  • well.. i'm not sure exactly what I did.. I found someone that had a similar problem with his embedded site and couldn't send out a new password and they suggested adding a few lines in functions.php for the rewrite embed url.. so i did this, and it didn't work.. took it off and then for some reason my login link started loading in a whole new page .. like: target="_top" and after i login it redirects back to the homepage.. so that worked that bit out. I added inbox, activity, account (profile page), logout links to my wordpress header when logged in.. and a login, register link when logged out.. and removed all the .banner css tables from my themes custom.css and added this

    .Banner { display:none; }

    to hide all the banner links since I have them at the top of my wordpress page instead of in the embedded page.

    everything appears to be working out slowly.. i believe it works decently enough now to link people too.. i want to add the other signup options using facebook, open id, google etc.. but i'm receiving this error when trying to enable it.

    This plugin requires the allow_url_fopen php.ini setting.

    I use 1and1 shared hosting and they said to edit the php.ini file i can add one into any folder but it only works in that folder and not the subfolders like the .htaccess does.

    so i created php.ini and added 1 line: allow_url_fopen = ON

    I tried going to the plugins page and putting php.ini in: OpenID, OpenID/views, and OpenID/design.. but still getting the same error.. any ideas if i need to put the php.ini in any more locations?

    also if you want to check it out so far you can goto: http://ecigkit.com/discussions/
  • I've got another issue with ProxyConnect, I'm trying to get it working with wordpress 3.1.2, but as soon as I enable the wordpress plugin and Log out, I can't login back to my wordpress site!
  • I have wordpress 3.1.2 installed and it's working for me.

    I'm guessing it worked fine before the update? ..i haven't had to update yet after i added proxyconnect so updating may break it.. and you have to reapply something. not sure.
  • edited June 2011
    "I have wordpress 3.1.2 installed and it's working for me."

    Mine too! I'm just having problems with comment... :(
  • I had a few problems integrating them, wordpress 3.1.2 and vanilla (with the Janrain Engage SSO) but I pretty much followed the instructions and with a bit of fiddling got it to work ok. I think almost everything is in the instructions except for adding the vanilla cookie location to the WP plugin but it was over a week ago now so memory's not too great. It does work though even if you do lock yourself out first time!
Sign In or Register to comment.