Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


How to disable the preview button

battersbatters New
edited May 2011 in Questions
This discussion is related to the Anonymouse addon.
How to disable the "preview button" any message when creating new topic for the anonymous user? Because it causes the error did not have enough memory on any hosting

Comments

  • i want to hide preview button at anonymouse, how do this?
  • SS

    .AnonymousCommentForm #Form_Preview {
    display: none;
    }
  • there does not help, I added it to a file anonymouse.css but the button "Preview" to remain anonymouse
  • I have same problem with this plugin, When I click "Preview" button on creating new discussion, It show Error message (Not enough memory). Is there any fix for this ?

  • on line 346 and line 402 of class.anonymouse.plugin.php you'll find this code:

        // TODO: TEST PREVIEW IF JAVASCRIPT IS DISABLED
                            if ($Sender->DeliveryType() != DELIVERY_TYPE_ALL) {
                                $Sender->View = 'preview';
                                return $Sender->Render();
                            }
    

    comment the code and you'll get an edit screen rather than the php memory error when you preview the discussion. it's not a fix but it's far less annoying than the error.

Sign In or Register to comment.