Fork me on GitHub
Current releases are 2.1.1 (2 Aug 2014) and 2.0.18.13 (5 Aug 2014)
Ready for 2.1? Find out if your favorite plugins are compatible.
The 2.0 branch will no longer receive updates after Dec 2014.

"Bonk" error occurs while applying Embed-Friendly theme.

edited May 2011 in Vanilla 2.0 Help
Hi everyone,

My website uses only vanilla forum and nothing else; and I wanted to use Embed-Friendly theme for it.

When I applied Embed-Friendly theme to my forum, "Bonk" error occured. Does anyone faces the same situtation or know how to solve it?

Comments

  • yep I got the same error, then I deleted it...
  • Oh. But how do you embed your forum then?

    And let me mention here that same error occurs when I open my site from a mobile device. I guess, something wrong in vanilla settings, instead of in themes. I recently updated vanilla to newest version. Otherwise my forum was working great.
  • I am having the same problem. I did a fresh install of the latest 2.0.18 beta 2 with the intent of testing a Wordpress embed. No plugins besides the default set are installed. If I change the theme to anything other than the default Vanilla theme, I get a bonk. This is both through an embedded Wordpress page and through a standalone Vanilla link. I set the debug configuration in config.php but no additional info was outputted.
  • I had the same problem. Here's how I solved it:

    QUICK ANSWER: Although, /cache/ was writable on my webserver, /cache/Smarty/compile/ was not. Therefore, activating any theme other than the default created the "Bonk" error. I made that dir writable and all was well.

    REGARDING ERROR MESSAGES:
    If you want to get a detailed error message (i.e. something other than the "Bonk" screen), change the following in /conf/config.php:

    ORIGINAL "BONK" MSG:
    $Configuration['Garden']['Errors']['MasterView'] = 'error.master.php';

    VERBOSE ERROR MSG:
    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';
    SirAnteli
  • @mwender said:

    REGARDING ERROR MESSAGES: If you want to get a detailed error message (i.e. something other than the "Bonk" screen), change the following in /conf/config.php:

    ORIGINAL "BONK" MSG: $Configuration['Garden']['Errors']['MasterView'] = 'error.master.php';

    VERBOSE ERROR MSG: $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

    I tried to change the "BONK" Msg in the /conf/config.php but I cannot find any line that has ['Garden'] ['Errors'] etc. (although I do get the BONK error). Any suggestions?

  • peregrineperegrine ☯ hasta luego :) In-Flight MVP

    you add the lines! in your config.php

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • I added the lines & finally got it to work. Thanks. I thought that since the post said ORIGINAL "BONK" MSG it would already be part of the config.php file.

  • peregrineperegrine ☯ hasta luego :) In-Flight MVP

    if somebody posts a config line and the line it is not in your file - you just add it. If it exists but the parameter on the right side of the equal sign is different you just modify the parameter.

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

Sign In or Register to comment.