Fork me on GitHub
Current releases are 2.1.3 (9 Sept 2014) and 2.0.18.13 (5 Aug 2014)

Ready for 2.1? Find out if your favorite plugins are compatible. The 2.0 branch will no longer receive updates after Dec 2014.

Vanilla on mobile phones?

edited August 2011 in Vanilla 2.0 Help
Maybe I have missed something, but my iPhone cannot reach the vanilla forums on my site. It just gives me the "bonk" error. I have been looking around and see that some people have kind of brought it up, but never finished the discussion. Anyway, is there something I have to do to allow the forums on my mobile phones?
Tagged:

Answers

  • It just works for me. Are you using an embed? If not, what theme?

    I'm sure more info will get you better help
  • I am just using the default theme thats included. And no I am not using embed. Think fresh off of installation with no modifications done.

    But I did try to enable the 2 other themes supplied and they give me the "bonk" error message.
  • same problem in here : herkesuzman.com
    I am just using the default theme thats included. And no I am not using embed. Think fresh off of installation with no modifications done.

    But I did try to enable the 2 other themes supplied and they give me the "bonk" error message.
  • I had an issue with my preferred domain being set to the www version while vanilla wanted it to be the non www version. Changed this via google webmaster tools and a redirect in my htaccess file and now I'm good.

    Not sure if it helps you or which if the 2 fixes actually helped me , but I'm all set now
  • Have you tried updating to the latest version of Vanilla? I had a similar problem when they were just testing the new mobile themes
  • I have the same situation here, I installed Vanilla 2.0 from scratch yesterday and I tried to enable a couple of themes -including the Classic theme- and after several bonks I gave up and I'm using the Default theme.

    I haven't done anything funky or else...

    When I try to see my forum in my iPhone I only get a Bonk Message.

    Any ideas?
  • LincLinc Community Instigator Detroit Vanilla Staff
    edited August 2011
    As a temporary fix you could drop this in your config.php file:

    $Configuration['Garden']['MobileTheme'] = 'Default';

    That will stop it from using the special mobile theme, which must be where the issue is. Doesn't help resolve the underlying issue, though. If you want to help by debugging, put this in your config instead:

    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

    Then you'll see a technical error message rather than 'Bonk' and can paste the contents here for more help.

    Sr Developer at Vanilla Forums [GitHub, Twitter] and humble servant of Lord Brackos.

  • edited November 2011
    I'm also having issues with mobile versions not working... even with the 'Mobile' theme activated.

    Themes work fine on the desktop, but produce 'Bonk' errors on mobile.

    My forum is being served up using a subdomain (ie. not 'www.mysite.com') - could that be causing the problem somehow?

    I'm guessing there's something strange happening at a system/config level, as you'd expect the 'web' to work (in some form) regardless of platform...?
  • edited November 2011
    Ok, after gaining appropriate access to manually alter config.php on the server I was able to use Lincoln's debug code to generate an error message and figure out the issue.

    In my case it turned out to be a permissions issue on the cache/Smarty/compile directory on the server. Once I gave that directory full read/write permissions (777) the mobile themes started working.

    I'm not sure whether this permissions change poses any significant security risks... I'd appreciate any thoughts on this from those with more knowledge about this sort of thing!

    Oh, and also Lincoln's other suggestion of adding:

    $Configuration['Garden']['MobileTheme'] = 'Default';

    to config.php also worked... even without altering the cache/Smarty/compile permissions.

    Thanks Lincoln!
  • ToddTodd Chief Product Officer Vanilla Staff
    Your cache directory should be 777. The installer asks you to do this if it isn't writable. Did you see this message when you installed Vanilla?
  • x00x00 MVP
    edited November 2011
    why does everyone 777? it is not necessary, 755 is sufficient for cache/Smarty/compile. with cache set to 775.

    the risk to exposing cache isn't significant at all. even attempting to view the smarty cache entries directly results in a page not found, but you can also hide the folder from view.

    grep is your friend.

  • I have been seeing this issue on HTC phones where you can see the theme and all but cant reply or post, when you click on the links on the forum the teh keyboard on the phone doesnt display...

    works fine on iphones and others, just not the HTC ones...

    I have made the same above adjustments to no avail...any possible ideas?

    thank you in advance for any help...
  • I'm also having this problem and I'm not quite confident in using the 777 thing discussed in the forum.

    I only just installed my first Vanilla forum (in Bluehost) a few days ago and most functionality is fine and as expected including plugins; apart from, viewing my forum on a mobile (Google Nexus in this case) I get the "bonk" and I also get the "bonk" when trying to change or preview a new theme via the dashboard. I need to go back to the default for the "bonk" to go.

    Now, I'm obviously no IT genious but I can handle a bit of tech; however, I've been unable to solve this issue so far from reading anything online hence this post for HELP.

    BTW, I really like the general format of Vanilla forums - funky.

    Cheers :)

  • Ok, I tried 777 for the Smarty cache on my server and it made no difference.

    Then, I tried Lincoln's temporary fix and now I can finally see the forum on my mobile (no bonk) but it is the desktop version, which isn't ideal for a phone screen but when you can't find a better solution - it's better than nothing.

  • peregrineperegrine ☯ hasta luego :) In-Flight MVP
    edited May 2012

    I believe you have to use a theme that supports the mobile function. what theme are you using? and what mobile device are you testing on?

    x00 suggested these permissions to solve some errors
    755 is sufficient for cache/Smarty/compile. 
    775 /cache
    

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • peregrineperegrine ☯ hasta luego :) In-Flight MVP

    also did you try it with this

    $Configuration['Garden']['MobileTheme'] = 'mobile';

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • Right - I found the soultion over here: vanillaforums.org/discussion/comment/155906/#Comment_155906 My cache didn't create the "Smarty" folder on install so just create it manually.

Sign In or Register to comment.