Fork me on GitHub
Please upgrade to 2.1.x here. The 2.0 branch is no longer being updated.
Critical: Update to 2.1.8, released 15 Jan.

Errors when performing moderation actions (such as delete discussion)

jspautschjspautsch Themester ✭✭✭
edited September 2011 in Vanilla 2.0 Help
I'm running Vanilla 2.0.18b2 and I'm getting a very strange assortment of errors when performing certain moderation actions:

1) The first I ran into was a 404 error after deleting a discussion, I fixed it by manually changing the redirect url in class.discussioncontroller.php, as described here: http://vanillaforums.org/discussion/15381/deleting-a-discussion-ends-in-a-404/p1 It was redirecting me to /vanilla/discussions, but my install was in /forums/. This would only occur if I deleted the discussion from within the discussion itself.

2) The second issue is that if I delete a thread from the All Discussions view (by clicking on the Options drop down moderation menu), I get redirected to /forums/discussions. The problem here is that I don't have clean URLs, so /forums/discussions doesn't exist, it should be /forums/index.php?p=/discussions. The problem is I can't find where this is specified. Similarly, if I delete from within a specific category it tries to redirect to /forums/categories/categoryname when it should be /index.php?p=/categories/categoryname

3) Finally, if the homepage is set to the "Categories & Discussions" view, and I try to delete a discussion from there, it brings me to a blank page that just says "TRUE" (the discussion, however, is still successfully deleted), which is the weirdest behavior I've seen yet, and I have no idea what's going on. This also happens if I close/reopen, sink/unsink, and announce/unannounce. So pretty much every moderation action performed from the Categories & Discussions homepage completes the action and brings me to a blank page that says TRUE on it. Any idea what might be causing this and how to fix it?

As a side note, shouldn't the All Discussions page auto-update when I close a thread? It will if I announce a thread, but I have to manually refresh to see that a thread has been successfully closed. Just curious.

Best Answer

Answers

Sign In or Register to comment.