Fork me on GitHub
Current releases are 2.1 (gold) and 2.0.18.11 (security patch for 2.0)
Ready for 2.1? Find out if your favorite plugins are compatible.
The 2.0 branch will no longer receive updates after Dec 2014.

Vanilla search does not work

edited October 2011 in Vanilla 2.0 Help
How does vanilla search work?

I have 3 discussions. With tags. But whatever search criteria i enter it does not find a single document.

If i use a plus sign + it finds only documents which have this word in it. But it does not search the tags.

Why is this search function so bogus? Can anybody help me with instructions to modify the system to get it to work? A good search function is essential to a helpdesk system

Answers

  • x00x00 MVP
    edited October 2011
    that is is how mySQL fulltext indexing works. Once the number of record have increased it will be better indexed, and will return more results.

    it is nothing to do with vanillin, however you can use google site search, and also like based queries (although the overhead will be high at large numbers of records)/

    grep is your friend.

  • As I have discovered, the vanoogle plugin is no good if your site is secured (password or IP protected) and/or you don't want your forum content appearing in public results, like my site (used for support on an application for internal staff)
    How does the + bit work? I tried for example 'pdf' and get no results when I should. If I try +pdf or pdf+ or even +pdf+ I get the same result. Site now has 70 plus users and over a 100 discussions running currently, so the issue of the number of records should not be an issue!
  • @meadwayk. So basicly you are saying that the statement that mysql is causing this is bogus.

    I think it a search should work even with one post in the forum. So i also think those arguments about mysql and how thinks work are not done. The software should perform a search when it is needed. So i would like to suggest to the developers to look into this and modify the search, because many of the forumsoftware users are having this problem.
  • it is not bogus. the default search works on FULLTEXT indexing. That is the way it queries, unless you enable like search. The index needs time to be cross propagated.

    You have various configuration options for your search

    $Configuration['Garden']['Search']['Mode'] = 'matchboolean'; // matchboolean, match, boolean, like

    You think that, but you also may not be aware about the overhead involve in database querying, especially search for non exact matches.

    Many big site run search engine software, for indexing their site, separate from their db. It is a whole other kettle of fish.

    grep is your friend.

  • Hello x00,

    Thank for your detailed info. But where and how do we enable this like search?

    another question. If I add one article in a wp site i can search on any word, category of tag and get the result. Why is this different from vanilla? It is the same MYSQL database.

    Looking forward to your reply,
    Thanks

  • @BackuPs it's just not set up that way. If your site isn't private, try looking into a third party search solution. You could try Vanoogle, or try to roll it yourself.

    The fact is, MySQL is database software, not search software. It has rudimentary search, and has to be painstakingly configured for it to be performant and accurate.

    The devs realize they could pour hours and months into search and still not please everyone, so they choose to focus on things that will make a positive impact in other areas. There is no shortage of things to be done. Also, this is open source software... so if you feel passionately about it there's always the option of diving in and providing a fix for them to include in releases.

    My addons: NillaBlog | Vanoogle

  • @BackuPs

    put the line
    $Configuration['Garden']['Search']['Mode'] = 'like';

    in conf/config.php

    blogs tend to hold fewer entries, people use the search less often.

    grep is your friend.

  • ChanuxChanux Admin of Geek.lk ✭✭
    ooooooooh thanx. its working. thank you verry much :)
  • thank you, the "like" config line did it for me too

Sign In or Register to comment.