Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

  • 422 December 2011
  • Donal December 2011
  • Tim December 2011
  • Todd December 2011

Follow Us


How to debug?

edited December 2011 in Questions
This discussion is related to the Vanilla Proxyconnect addon.

I am using proxy 1.9.8 and vanilla Version 2.0.18.1 my cms uses smarty, My Authenticate URL is created by smarty and seems to be outputting the correct info and format All the link urls work ok ie: when i click login i am directed to my main site login page etc. My problem is that users are not created or logged in. When I use the "test" feature in the dashboard I receive a blank page, with no apparent errors reported.
So at this point I'm unsure how to check exactly what is or is not happening. code used to output auth:

    {assign var="user_login" value=$CI->session->userdata('user_login')}
    {assign var="user_email" value=$CI->session->userdata('user_email')}
    {assign var="user_id" value=$CI->session->userdata('user_id')}
    {assign var="layout" value="UniqueID=$user_id,Name=$user_login,Email=$user_email"}
    {if $node->title() == 'v'}
    {if $session_user_id}
    {$layout|replace:",":"\n"}
    {/if}
    {else}
       {include file="frontend/header.tpl"}
    
    ......etc

"node" being the template and "v" being the title of the page called in smarty for the ath url

this outputs source code:

UniqueID=1
Name=donal
Email=me@mydomain.com

any hints on how to proceed would be appreciated

Best Answers

Answers

  • Vannilla does not render at all, completly blank page

  • placed it at end of config.php still same result blank page and blank source code

  • ini file set to all and display

  • still nothing reported :(

  • edited December 2011

    still trying to get this to work, Reinstalled vanilla, installed proxy connect 1 9 9. slight progress in that I can see a result when I run the test,
    > Could not understand the ini response received from the AuthenticateURL. Your application is not responding in a way that ProxyConnect understands! Using firebug to check the AuthenticateURL I am sure it is in the right format. So not sure where I should go from here? Any suggestions?

  • TimTim Lord of Servers Vanilla Staff

    Do you have cURL?

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • ToddTodd Chief Product Officer Vanilla Staff

    Are you sure your template is correct? It looks to me like you are adding a bunch of extra hard returns. Do a view source on the page and make sure it is correct.

    Smarty is not the best option for writing. You should concatenate your string in php where you can control every character being output.

  • TimTim Lord of Servers Vanilla Staff
    edited December 2011

    With my new parsing algorithm in 1.9.9, even spare newlines should be handled ok, though Todd is right about them being less than desirable.

    My guess right now is that you may not have cURL, a more reliable and better tested connector than fsockopen.

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • TimTim Lord of Servers Vanilla Staff
    edited December 2011

    Additionally, you seem not to have followed the spec. The spec states that when requested, the Authenticate URL should return either the credentials of the logged-in remote user, or a BLANK PAGE (NO CONTENT WHATSOEVER) if there is no session.

    If I am understanding the bottom of your snippet correctly, it looks like you're including a template in that case. That would be wrong.

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • @todd yes i'm sure the template is correct I have viewed it in source and with firebug. And I did try outputing it with a seperate php file using a codeigniter function to obtain the details and then echo'd the result in the correct format @tim the template you are seeing is the result of the "else" statment in smarty, if the title of the page requested is not "v" then output the smarty template.. so if the tittle is "V" and there is no session it will output a** totally blank page**

    I am not sure about cURL but according to phpinfo: cURL support enabled cURL Information libcurl/7.19.7 NSS/3.12.9.0 zlib/1.2.3 libidn/1.18 libssh2/1.2.2

    thanks again for your help

  • 422422 Developer MVP

    Tim said: Can you try putting

    $Configuraton['Debug'] = TRUE;

    Into your config file?

    That should read Configuration !

    422 Real Estate Australia , now open Check it out

Sign In or Register to comment.