Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Approval Idea

x00x00 MVP
edited January 2012 in Feedback

I think the Approval system needs reviewing it can be quite misleading, at this stage it is to fickle to have approved plugins across versions.

Why not have approved plugins, for specific versions, just a little tag that says the addon is approved for a specific version? Perhaps a dropdown with versions of vanilla, so they can check support.

grep is your friend.

Tagged:

Comments

  • Domos123Domos123 New
    edited January 2012

    I agree, as there is currently currently no way of knowing what version of vanilla many plugins are for, other than the release date and a bit of fingers-crossed blind luck

  • Actually that is not quite true, you can specify it in the meta but it is not strict or a requirement.

    However approved, is more than just working. There is a track record and a standard.

    grep is your friend.

  • hbfhbf wiki guy? MVP

    it would be great if there was a bit more transparency to the approval process as well.

    I uploaded some very simple plugins, i'd love to have them code reviewed. I would like to learn if what i did would be considered best practice or not, and im sure the people who are using my plugins would like the assurance from having them reviewed as well.

    I'm not expecting a miracle, just some idea as to when, if ever, i should expect my code to be looked at.

  • 422422 Developer MVP

    Better still would be an automailer that gets sent to the downloadee asking for their opinion, and redirect them to support thread for the addon.

    422 Real Estate Australia , now open Check it out

  • Currently you can set the version, with greater than. However there isn't the "compatible up to" option like wordpress. My view is the plugin makers of plugins should be notified when new version of vanilla and only after they confirmed it works will they set compatible up to that version.

    grep is your friend.

  • 422422 Developer MVP
    edited January 2012

    In fairness its hard to know what version is current for vanilla from downloads page

    422 Real Estate Australia , now open Check it out

  • that's what I'm saying

    grep is your friend.

Sign In or Register to comment.