Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Users who confirm their email address lose permission to log in.

edited February 2012 in Questions
  1. New user registers by filling out e-mail etc.
  2. The new user can post and comment right after registration is complete. (user has status BetaTester)
  3. If/when the new user click the confirmation link in the mail, they get a "ErrorPermission" message, and can't log in. (user has no user status what so ever (NULL))

Does anyone know what's wrong here? It seems like the settings are doing the opposite, giving those who don't confirm permission to post, and those who confirm no permissions...

Any ideas where i should start looking to fix this problem? :)

Best Answer

  • x00x00 MVP
    Answer ✓

    User roles cascade. You try dragging and dropping the user roles.

    Check which roles the user actually have, they can have more than one.

    grep is your friend.

Answers

  • Role and Permissions.

    Check Member settings. view,edit, etc.

    grep is your friend.

  • In dashboard/settings/registration:

    Method Description Basic New users fill out a simple form and are granted access immediately.

    Require users to confirm their email addresses (recommended) Email Confirmation Role: Beta Tester

    In dashboard/role: In Beta Tester:

    Log in: accept: √ Comment: add: √ Discussions: add & look: √

    Try registering yourself, and see for yourself: http://turbolego.com/finnvegg/entry/register?Target=discussions

    You will be able to post and comment before you confirm your e-mail, but you will not be able to login after you've confirmed you e-mail.

    unbeknownst to me why...

  • Nevermind, i fixed it. If you have the same problem as me do the following:

    1. go to /dashboard//role/defaultroles and check (√) the role(s) you want your users to have BEFORE they confirm their e-mail.

    For me this was only "Beta Tester".

    1. go to /dashboard/settings/registration and set "Email Confirmation Role" to Confirm email.

    I used this thread: Confirmation email required badge always appearing

    Thanks @x00 for your help.

Sign In or Register to comment.