Fork me on GitHub
Please upgrade to 2.1.x here. The 2.0 branch is no longer being updated.
Critical: Update to 2.1.8, released 15 Jan.

Blank screen

edited February 2012 in Vanilla 2.0 Help
This discussion is related to the Signatures addon.

I'm getting a blank screen, when following the "Signature Settings" link in profile/edit.
The settings link points to profile/signature, and when I change it to something else (like profile/siggggnature), I get a normal 404 screen.

So that tells me the method is available in the controller. But no matter what I've tried, I just can't get it to return anything but a white screen.

How do I debug this?

I'm using Vanilla v2.1a10

Best Answer

Answers

  • I found the solution myself:

    In Signatures/views/class.signatures.plugin.php:70 i changed ProfileController_Signature_Create(&$Sender) to ProfileController_Signature_Create($Sender).
    Then it works.
    But I'm not exactly sure why this was necessary ... ?

    KezzB
  • objects are passed by reference in php5. Some people don't know this.

    grep is your friend.

  • x00 said:
    objects are passed by reference in php5. Some people don't know this.

    So, because $Sender is an object, there's no need to use the explicit pass by reference operator, or what?

    I don't quite understand your answer ... :)

    I'm unsure about my solution, because I can see the plugin was tested and approved - yet I have to make this change to make it work.

    This has me wondering, if there's something else wrong with my code.

    zodiacdm
  • I had the same problem and the same change fixed it :)

    Perhaps a code change is in order? Is the plugin on Github?

Sign In or Register to comment.