Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

In this Discussion

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Please upgrade to 2.1.x here. The 2.0 branch is no longer being updated.
Current version is 2.1.11, released 12 June.

404 after editing homepage/url

edited March 2012 in Vanilla 2.0 Help

Hello, i'm trying to embed vanilla in wordpress, the embed itself is done and working properly, but when i try to change the permalinks in vanilla, i have a 404 error. I do have the .htaccess in the root of vanilla (it is in a subdir, wordpress is in /).
Also, if a try to change the homepage of vanilla, for example displaying /categories/all, I have the 404 error too, it works only when selecting /discussions

here's the link for the embed page http://bit.ly/wNhhH4 , vanilla is located here http://bit.ly/zPJelM

here's my htaccess

# Original
# If you modify this file then change the above line to: # Modified
<IfModule mod_rewrite.c>
   RewriteEngine On
   # Certain hosts may require the following line.
   # If vanilla is in a subfolder then you need to specify it after the /. 
   # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
   RewriteBase /forum-londra
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
</IfModule>

i dont know if you need the "routes" settings

Comments

  • x00x00 MVP
    edited March 2012

    just comment the line RewriteBase /forum-londra like so # RewriteBase /forum-londra
    most likely you don't need it.

    grep is your friend.

  • edited March 2012

    I've tried that too, with no success.
    I also tried to add, in the routes, DefaultController with target categorie/tutti (rather than categories/all) and i have 404, but if i go to /categories/all it is working, so i think it is something with permissions? (htaccess is 755, i tried with 777 and it's the same)

    edit- i tried with a new installation on a localserver, and it's the same. When i change the permalinks to something different than the default (ie from discussions to discussioni), it gives 404 :(

  • ive decided to give up and re-try customizing bbpress

Sign In or Register to comment.