Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


[Solved] Cannot Activate the Facebook Authenticator

edited April 2012 in Questions

Hi

I want to enable logging in through Facebook and enabled the plugin, created the fb app, added the app id and secret id and saved the information. When I go to Authentication under the Users tab, I can see Facebook in the dropdown. I click that and the configure fb menu comes below with the app id and secret id filled in. I click the save again and then try to click the Activate button besides the dropdown (Configure the Authenticator), but nothing happens. I believe I should get some options like mentioned in this blog entry vanillaforums.com/blog/help/setting-up-facebook-login-and-new-account-registration-for-your-forum/

I can see the fb icon on the forum page. I click on that, allow the app to access my fb account and then I get this error 'Facebook Connect - UniqueID is required'. I search the forums and find that most of the threads mention this one - vanillaforums.org/discussion/comment/135304 I follow that, open my class.facebook.plugin.php file and configure as mentioned. Unfortunately nothing happens. It still shows the same error. I've uploaded a phpinfo.php file and checked that OpenSSL feature is enabled for cURL.

cURL support enabled cURL Information libcurl/7.13.2 OpenSSL/0.9.7e zlib/1.2.2 libidn/0.5.13

I have spent hours on this and will really appreciate if @Tim or @Alibaba31337 or @UnderDog can help me. Thank you in advance.

Best Answer

Answers

  • Anyone please?

  • I'm stuck with the same problem too.. unable to login with FB userid/password.. it throws an error Unique Id is required.. please help. thanks.

  • YohnYohn New
    edited March 2012

    I know when you set up the facebook app p facebook you have to scroll down and make sure you put in the website you're using the app on. Its near the bottom of the app page, you have to have a green checkmark next to website

    Ok, go to facebook where the app is at, and then edit the app you're using.. theres 2 spots you have to put in your domain name. one at the top for "App Domain", and then near the bottom "Select how your app integrates with Facebook" click "Website" and make sure you fill in "Site URL:"

  • Have put in the website field, let me confirm if it is in the App Domain field as well.

  • Yohn, tried that. Added the domain in the 'App Domain' as what was added in the 'Website'. Same error! :(

  • @hkrohit I've added the code correctly. You mean the '$' before 'this', right? Did making this change work for you? No more Unique Id errors??

  • Did the changes work for you? I tried renaming the file, class.facebook.plugin.php to something else thinking that it will throw up an error, it didn't and it actually worked! I've asked a few users to now login through FB and it is working, but am not sure that this is the correct way to do it - will this not create a problem in the future?

    @Tim Does the fb thing work without class.facebook.plugin.php?

  • Update: I deleted all the files, uploaded it again and made it work by again following instructions at http://vanillaforums.org/discussion/comment/135304. And it worked! Thank you all for your support.

Sign In or Register to comment.