Fork me on GitHub
Current releases are 2.1 (gold) and 2.0.18.11 (security patch for 2.0)
Ready for 2.1? Find out if your favorite plugins are compatible.
The 2.0 branch will no longer receive updates after Dec 2014.

Why is Email Confirmation Role dropdown empty?

edited April 2012 in Questions

My new users are unable to join the forum. Whenever they login, it gives them a "permission denied" message. I think this is due to the "Email Confirmation Role" setting. I attempted changing it, but the dropdown is empty. What is causing this?

image

Answers

  • peregrineperegrine ☯ hasta luego :) In-Flight MVP

    SELECT * FROM `GDN_Role

    Do you have any names assigned in the table? If you don't that is your answer.

    Did you just do a conversion and/or upgrade?

    Your problem may be related to the last 10 people who posted a problem within the week if you do a search, role and permissons table under some guise.

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • All I did was install a fresh copy and start themeing it.

    I'll check my database backup, but I just wiped and reinstalled Vanilla, and the problem was solved. Could a bad plugin cause something like that?

  • peregrineperegrine ☯ hasta luego :) In-Flight MVP
    edited April 2012

    that would be interesting if it was a plugin - what plugins did you install. I also wonder if there was a bug in one of the interim versions, did you download a new version or just use the same zipped version as the one that gave you the permissions problems.

    edit

    Perhaps their will be a pattern that people will see.

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • The only ones I used outside of Garden were FirstLastName, SyntaxHighlighter and WhosOnline.

  • peregrine said: SELECT * FROM `GDN_Role

    Do you have any names assigned in the table? If you don't that is your answer.

    Did you just do a conversion and/or upgrade?

    Your problem may be related to the last 10 people who posted a problem within the week if you do a search, role and permissons table under some guise.

    According to my backup, this is the status of my GDN_Role:

    INSERT INTO `GDN_Role` (`RoleID`, `Name`, `Description`, `Sort`, `Deletable`, `CanSession`)
    VALUES
    (2,'Guest','Guests can only view content. Anyone browsing the site who is not signed in is considered to be a \"Guest\".',1,0,0),
    (3,'Confirm Email','Users must confirm their emails before becoming full members. They get assigned to this role.',6,1,1),
    (4,'Applicant','Users who have applied for membership, but have not yet been accepted. They have the same permissions as guests.',2,0,1),
    (8,'Member','Members can participate in discussions.',3,1,1),
    (16,'Administrator','Administrators have permission to do anything.',5,1,1),
    (32,'Moderator','Moderators have permission to edit most content.',4,1,1);
  • peregrineperegrine ☯ hasta luego :) In-Flight MVP
    edited April 2012

    Nothing unusual pops out with the table. I am only assuming it was reading that table because that is where it would pick up the names for the select box. What about the version question? did you download a new version or did you use the same one that went south.

    In any event - you solved it (just thought it might be related to other people's problems.)

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • edited April 2012

    All I did was delete my config.php file and reinstall over my current setup, so I'm still running 2.0.18.4.

    Is there no other place where things could've gotten crazy? I went and set the /roles/defaultroles like I'd read, and I made sure to double-check all my role permissions.

  • I just had the same issue.

    I think the issue was using the Porter import script. I did that, importing from a former BuddyPress (bbPress) database, and my guess is, it wiped out the role's permissions associated with this form.

    The fix, for me, was to define a new role called "Email confirmation" or something, and then make sure that the Email > Manage setting was enabled.

    That made just that role appear. I think the other roles were missing email management, and thus excluded from the dropdown.

    That sound about right? (Maybe I should be adding that to the other permissions, as well?!)

  • I have the same problem on a fresh install of 2.0.18.8. This version of vanilla does come with the "Confirm Email" role, but the drop-down menu in "Registration" still shows nothing. To fix this, I had to go to "Roles & Permissions" and enable "SignIn" under "Garden". (i.e. Dashboard > Roles & Permissions > Click "Edit" under Confirm Email > Tick "SignIn" under Garden Permissions)

    hgtonightzangano
  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    I found when using the Porter between 2.0 and 2.1 that the permissions didn't carry over properly, and I couldn't set permissions via the dashboard as the original admin user.

    The only solution I found was to export the gdn_permission table from the 2.0 forum, and then import it into the 2.1 table.

    hgtonight
Sign In or Register to comment.