Please upgrade to 2.1.x here. The 2.0 branch is no longer being updated.
Current version is 2.1.11, released 12 June.

Removing StopForumSpam

Hi, I'm in Singapore now where everyone uses a shared IP address. I set up a forum for my friends and I, however, because we all use a shared IP, StopForumSpam sees us as spammers and we have to go through a captcha every minute or so which is annoying.

I did not download the StopForumSpam plugin and I can't find a way to disable it. I understand that StopForumSpam is supposed to protect the forum from spammers but the con of my users and I needing to go through a captcha every minute outweighs the pro of stopping spambots (if any).

So, how would I disable StopForumSpam?

Every minute or so, I get redirected to this site:

And the IP address varies every now and then.

If it helps, I don't see a StopForumSpam plugin in my plugins folder and I've been searching but I can't find "stopforumspam" anywhere in the directory and sub-directories.

I have no idea where this is coming from.


  • ToddTodd Chief Product Officer Vanilla Staff

    Are you sure you're using Vanilla? If you are there must be some other plugin that is causing this because we only use captchas on registration.

    I didn't realize that all of Singapore uses the same IP address. That's a bummer.

  • peregrineperegrine MVP
    edited April 2012

    just guessing. somebody probably reported a spammer with the ip octet and listed you on the database at the Stopforum host site or with your provider. Maybe you can also clear it up at the site admin.

  • Man that sucks. Singapore is basically a city state. I wonder if you are using some other software like wordpress.

    grep is your friend.

  • edited April 2012

    After some FireBug-ing, I noticed that every minute, async posts were made to "dashboard/notifications/inform".

    The moment that post was made, I got redirected to main-hosting.
    So, I searched the directory and found a file that referenced that location:

    I just changed this:
    (Ugh, I can't get the code to show properly =/)

    // Ping for new notifications on pageload, and subsequently every 1 minute.
    pingForNotifications = function(wait) {
    if (!wait)
    wait = 60000;

        setTimeout(function() {
                type: "POST",
                url: gdn.url('dashboard/notifications/inform'),
                data: {'TransientKey': gdn.definition('TransientKey'), 'Path': gdn.definition('Path'), 'DeliveryMethod': 'JSON'},
                dataType: 'json',
                error: function(XMLHttpRequest, textStatus, errorThrown) {
                    gdn.informMessage(XMLHttpRequest.responseText, 'Dismissable AjaxError');
                success: function(json) {
        }, wait); // Ping once a minute.


    to this:

    // Ping for new notifications on pageload, and subsequently every 1 minute.
        pingForNotifications = function(wait) {
            if (!wait)
                wait = 60000;

    I then saved it and the problem was gone.
    I'm guessing I borked the whole notification system in the process, though.
    This was really an ugly hack on my part =x

    I didn't want to bring this up with StopForumSpam because those people listed were probably spammers; just my luck to be assigned their IP address at that point in time =/

  • edited April 2012

    The problem has not been fixed.
    It doesn't happen once every minute but it happens whenever I try to access a plugin.
    I downloaded "Groups" and "Membership"

    After enablig them, I cannot access their pages because I get automatically redirected to

    It's seriously annoying.
    Trying to access "plugin/groups" (The plugin's page, I presume) sends me to main-hosting.

    Is there a way to stop this behaviour?
    If it's any help:
    $Menu->AddLink('Users', $LinkText, 'plugin/groups', 'Garden.Settings.Manage');
    The above line is found in class.groups.plugin.php

    What exactly is Garden.Settings.Manage?
    Better still, how do I remove StopForumSpam entirely?

  • I don't know. But maybe it is worth investigating these/

    applications/dashboard/controllers/class.notificationscontroller.php: public function Inform() {

    applications/vanilla/settings/class.hooks.php: if (Gdn::Session()->CheckPermission('Garden.AdvancedNotifications.Allow')

  • I don't see anything out of the ordinary there =/
    Oh, well.

  • AoleeAolee Hobbyist & Coder ✭✭

    I also live here in Singapore but never had encounter this issue. do you have the "manage spam" link in the dashboard? i manged the stopforumspam there.

    Check out my other Plugins here

  • Yes, I have that link in my dashboard but it doesn't mention StopForumSpam anywhere.
    I see an empty list of (probably) spam posts and buttons that say "Not Spam" and "Delete Forever".

  • UnderDogUnderDog Moderator

    JustinAnyhowStep said:
    I see an empty list of (probably) spam posts and buttons that say "Not Spam" and "Delete Forever".

    An 'empty list'? Maybe it's time for a screenshot? Mask the things on the screenshot we're not allowed to know, like address bar, admin username, etc :-)

  • x00x00 MVP
    edited May 2012

    You are redirected, this could possibly be something higher level, ie your host. What type of redirect is it?

    Do you have any other software in your web folder that could be causing the issue.

    Do you have a vanilla anti spam plugin, that also uses stop forum spam.

    grep is your friend.

  • edited May 2012

    I never got any anti-spam plugin and, also, I have no idea what kind of a redirect it is.
    I've had this problem ever since a "vanilla" installation of "Vanilla".

    I do have other pages hosted other than a Vanilla-based forum but they don't suffer from this problem; so I'm guessing that it's only Vanilla that's affected.

  • not necessarily, it could be a conflict, for instance routing and conflicting uri.

    do you keep these pages separate?

    grep is your friend.

  • Separate?
    I keep them in separate folders, if that's what you're asking =x
    And the other pages I have don't link to the forums (and vice versa).

    The forum, is just a little side-thing for my friends and I because we're all super disorganized.

  • peregrineperegrine MVP
    edited May 2012

    I'm a bit confused. Does the problem occur going to this forum or to your forum.
    If its going to your forum, did you check your access logs - they may give you a clue.
    e.g. On my test machine in the access log, I suspect you would see redirects here too.- I see
    POST /vanilla/dashboard/notification
    messages every minute.

  • edited May 2012

    "dashboard/notifications/inform" <-- That is the link that redirects me to with a StopForumSpam captcha. I've already mentioned that in the above comments.

    And, yes, every minute, too.
    I fixed that by breaking the notification system because the notification system is what makes POST calls to that link.
    But it would be nice to be able to fix it without breaking something else.

    The problem occurs when using the Vanilla forums hosted by my web-space provider (the one for my friends and I).
    I don't get the problem on this forum (

    However, it shouldn't be a problem with my provider because all my other web-pages do not have this issue and I'd never even heard of StopForumSpam until I tried to host a vanilla-forum.

    Hold on..
    I just tried to manually visit the link.
    I got this:

    I don't get stopforumspam anymore..

  • so if you point directly to dashboard/notifications/inform it will do this every time? Or just some of the time?

    I suspect that there is some restriction up stream, as dashboard/notifications/inform is one of the most polled,

    dashboard/notifications/inform is a usually pinged the background, which means if you are redirected from the page you viewing, that would imply the redirect is javascript rather then server side, which would imply that there is some conflict with notifications and another software, you could try with a clean install of vanilla.

    In any even there is nothign here that point to vanilla core begin the problem. it is most likely some conflict or restriction.

    grep is your friend.

Sign In or Register to comment.