Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Vanilla 1.1.9 Released

MarkMark Vanilla Staff
edited September 2009 in Vanilla 1
Vanilla 1.1.9 has been released and is now available at http://vanillaforums.org/download

This version fixes a bug in the installer. The upgrade is very simple, instructions are here.

A big thank you to all of the contributors!
Dinoboff
sirlancelot

Comments

  • Is Vanilla 1 going to continue to have upgrades? I was just curious about that
  • Can Vanilla 1 upgrade to 2? I was just curious about that
  • @vicred: Once version 2 is out of beta testing I could only assume there will be an upgrade path that can be taken for version 1 owners.
  • MarkMark Vanilla Staff
    There already is an upgrade script for the V1 -> V2 import - but it needs testing before we tell people about it :/
  • In the install instructions for upgrading from 1.8 to 1.9 it says...

    "(there might be any $Configuration['HTTP_METHOD']). It should either be set to "http" or "https"."

    Was it supposed to be "there might not be any"? 'Cause I don't have a HTTP_METHOD.
  • MarkMark Vanilla Staff
    @reflector - Good eye! I think you're right that Dinoboff meant to say "there might not be any". You can safely add that setting and make it "http" - unless you're using https, of course.
  • I have an installation of Vanilla 1.1.4 at http://scienceboom.com/forums/. Is it possible for me to upgrade directly to 1.1.9 or do I have to do it incrementally to 1.1.5. 1.1.6 etc.

    I have read over the upgrade instructions and I just want to clarify one thing. If I use an FTP client I would just upload all of the contents of 1.1.9 into where I have 1.1.4 installed and that will upgrade it. Right?
  • edited September 2009
    You can just copy over Vanilla 1.1.9 other your current installation (be carefull with the conf/ and themes/ folder, your os might overwrite them instead of merging them - you could lose your settings and themes). You should check the discussion about upgrading to 1.1.5. There is a change to the database schema; In some cases (that I fail to remember the details), the login was broken.

    To check everything works fine, after upgrading to 1.1.9, log-out, log-in, log-out again and then login. On the first login, vanilla will reset your password hash (vanilla 1.1.4 hash password is weak). The second time you login, it will use the new hash.

    Here is a fix if you have this issue:
    http://vanillaforums.org/discussion/comment/90712/#Comment_90712
  • Dinoboff, thank you for your help. Success!
  • Thank you a lot for the hot knowledge close to Vanilla 1.1.9 Released! If students are willing to buy essay
    and essay writing choose really good essay writing service. This is the good way to academic success!
  • Thanks Dinoboff! I upgrade from 1.1.5a to 1.1.9 and looks like it went well so far. I appreciate the developers efforts and the community support. <3 !
  • testing the forum software. liking it alot!!!
  • We've been testing 1.1.9 and found an issue with Private Message Extension 1.1. when trying to send a PM all test users gets the error:
    'Some problems were encountered
    You must select a category for this discussion'

    Admin user went to:
    Settings> Extension Options > Private Messages

    Confirmed and 'saved' correct Category and error still appears. Should I take this to the issue tracker?
  • heya mark, i believe there's an update check problem for vanilla 1x on the new addon server. New extensions uploaded onto vanillaforums.org are not not detected by vanilla 1.1.9.
  • MarkMark Vanilla Staff
    @vanoob - I think you're right. We'll need to get that fixed ASAP...
  • hey mark, thought i'd keep you updated but with regards to the update check problem for vanilla 1x. No feedback are being returned to vanilla. Does vanilla 1x need it's update url changed? or will you be able to pass the check from lussumo.com to vanillaforums?
  • MarkMark Vanilla Staff
    @vanoob - I'll be able to redirect the check. I'm working on a ton of issues related to the addons site this week. Should get it fixed up in a few days.
  • @mark yeah it's cool, yeah i figured there might be other problems as well, we're not in a hurry. Just keeping you updated. I believe most of us here know what we are after for addons and know how to obtain them anyway. Good luck, we'll see you on the other side :)
  • Should new installs go straight for Vanilla 2 ? I want to experiment with a semi-forum-mailing list if this can be done..
  • MarkMark Vanilla Staff
    edited November 2009
    I always recommend giving Vanilla 2 a shot if you are even a novice developer. If nothing else, you can help us get through issues and get closer to release.
  • Hi, we are running a 1.1.5a version of Vanilla on the current server and as we're moving to a new host I'm investigating the best way to go : is there a way to move only data to get a 1.1.9 running with the old dataset ? Should I copy all the forum and run thru the upgrade process version by version ? Thanks for any info.
  • MarkMark Vanilla Staff
    @oxomoxo - Check out the upgrade instructions to see what is involved with the upgrade from each version. The only time you need to worry about jumping versions is if there is a database change. It doesn't look like there were any after 1.1.5a, so you'll just need to make sure you update all of the updated files from each release:

    http://vanillaforums.org/page/UpgradeInstructions

  • I'm sorry to be so ignorant. I used to be a vanilla 1 user way back, and a forum regular, but I haven't been active much lately. I decided to do a new install and just assumed that Vanilla 2 was simply the latest version. Now it seems that Vanilla 1 and Vanilla 2 are being developed side by side. So I wonder why?

    You've probably said this a thousand times, but I couldn't find it anywhere, so can someone tell me please:

    1. Why is Vanilla 1 continuing?
    2. What are the reasons someone would choose 1 or 2?

    Thanks.

  • MarkMark Vanilla Staff

    The core development team stopped working on Vanilla 1 years ago and have been actively developing Vanilla 2 ever since. The open source community still releases patches to version 1. We highly advise that you use Vanilla 2 over Vanilla 1.

Sign In or Register to comment.