Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Friendly Urls

13»

Comments

  • Now I have a new issue which is related to this topic. I hope we can solve it.

    I registered on the forum with an alias and got this email upon approving my own membership:

    Hello xyz,

    This message is to inform you that your account at Aavaas Forums has
    been changed.
    You have been assigned member status.

    You can review your role change at the following url:
    http://aavaas.com/forums/account/5/

    The only problem is that I am unable to see my role change at that url !

    When I click on that, I am redirected to : http://aavaas.com/forums/discussions/

    Please help.
  • Hello minisweeper i am not logged in. if i am, i am able to see the page. also, when i click on someone elses account page, i do not see that correctly.
  • Well if it works when you're signed in then it's not a problem with friendly urls...
  • I've got an odd error with Friendly URL's. if I turn them OFF, I go to start a new discussion, and i "forget" to put in a discussion topic. I get redirected to http://www.screenflex.com/forum/comments.php and I get an error saying: Some problems were encountered. The requested discussion could not be found. First off, shouldn't the error tell me that I need to add a Discussion Title? seems a little unfriendly. But, that's not my point. When I turn Friendly URL's ON. I don't get directed to the error message screen, I get redirected my website's error document. What's the deal with that? Any suggestions?
  • Yes, it should, and Vanilla actually does--but there is a bug in an extension somewhere that fiddles with the new discussion object (marked invalid at this point) and makes it appear as valid, so Vanilla makes the mistake of taking you to it when it doesn't exist.

    Friendly URLs just changes slightly how this bug works. With friendly URLS, the address of the non-existent post appears more like a file address than a Vanilla/PHP/friendly URLs address, so Friendly URLs ignores the request and lets the web server try to handle it--which fails.

    I suspect attachments or notify is the cause of this, but I can't seem to reproduce it.
  • Thanks Wallphone. --- you've given me a starting point to look.
  • Hey all, not to jump slightly off-topic, but I've been having the same problems with rewriting subdomain URLs with this extension as Zhak on the previous page. I had everything up and running perfectly, when I was using

    http://mysite.com/forum/
    but

    http://forum.mysite.com/
    redirects everything back to index.php. Any reasons this might be happening?

    (BTW, I'm using Dinoboff's .htaccess file in my root Vanilla directory.)
  • Any idea on the comment by in Friendly Urls # 39 about the issue with PageManager?

    thank(also using Dinoboff's .htaccess)
  • sstawarz did you solve it? I have the same problem and I have test without attachment extension and it runs sucessfull, but I don't know how solve it with attachment extension activated. thanks
  • No, not yet. My forum has primarily been used by our own company people and a few others. Since activity is slow, I've been able to let this sit for a bit.

    Sorry. If you solve it before me, let me know.

    thanks.

    I should add, that part of the reason it redirects to my home page is the URL is not found, and then apache kicks in with the default error document which I found to be is set to my website's home page by the hosting company.
  • sstarts/wakeup--Try changing the core code like outlined here: Forced Category # 10.

    And let me know if it works or not.
  • Anyone using this on 1.1.5a? Anything to help with SEO would be great edit: working great with 1.1.5a it was a pretty easy install (i guess mod_rewrite and apache were already activated, because i had no idea what to do about that). hopefully this helps with seo because google does not seem to like my site

  • Marvelous - worked very well.
    (1) Breaks Community Moderation addon. The AboutCommunityModeration page/link does not work.
    (2) Breaks Tag This addon. Gives the following noticeif trying to start a discussion without any tags or message:
    "Notice: Trying to get property of non-object in .../public/extensions/TagThis/library/Function.TagThis.php on line 96"
  • Hello guys!

    im trying to use this plugin but it doesnt seem to work.. do i need to get a fresh start with i use this plugin or what???

    help needed.
    thanks
  • I think the trailing slash issue can be treated in a simpler way. Instead of:

    RewriteRule ^discussions/([0-9]+)$ index.php?page=$1 [QSA,L]
    RewriteRule ^discussions/([0-9]+)/$ index.php?page=$1 [QSA,L]


    what about that:

    RewriteRule ^discussions/([0-9]+)(\/?)$ index.php?page=$1 [QSA,L]

    and so on with every "double" rule?
  • does anyone knows how to get rid of #Item_ ending for the guest users? Or at least how and where url generation is happening?
13»
Sign In or Register to comment.