Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Notify

12346

Comments

  • That was the fix I added in the latest version :)
  • ah! sorry :) next time I should update to the latest version first :)
  • This extension gives problems to manage categories: it is not possible to change the order any more. The javascript error is: uncaught exception: script.aculo.us requires the Phototype JavaScript framework >= 1.5.0 Looking at the source of the page, I see that the order of the script tag in the head is: - scriptaculous.js - /extensions/Notify/functions.js - /js/prototype.js So scriptaculous.js is loaded before prototype.js and doesn't work. Is there a way to solve this problem ? Thanks.
  • Download the latest version.
  • I seem to be the only one getting this:

    A link to the server could not be established in /home/.batzi/cbabas/cbabaseball.com/board/extensions/Notify/default.php on line 435

    That line is:
    if ($Context->Session->UserID > 0)
    mysql_query("UPDATE ".$Context->Configuration['DATABASE_TABLE_PREFIX']."User SET Notified = 0 WHERE UserID = '".$Context->Session->UserID."'");
  • Minisweeper: I use Notify 1.2.1 (downloaded today) with Vanilla 1.1.4 and now the problem seems to be given only by Safari 1. Thanks
  • I've a feeling the drag and drop never did work in Safari 1. I might be wrong.
  • Is it just me, or do {user}, {title} and {comment} not equal anything in email_notify.txt?

    Also, {topic_url} refers to an "ugly" permalink, rather than the "pretty" mod_rewrite permalinks I have set up. Any ideas?

    If I can get all the code worked out, I may be able to continue some development on this.
  • I cannot move the categories up and down when i have 'notify' installed
  • I have this problem either. I guess it is something with order or loading prototype.js and scriptaculous.js
    Just have had no time to find the cause
  • Try the latest version it should fix that.
  • I have the latest version of notify installed and believe my smtp, user and pass settings are correct. I am getting the following error whenever I add to a discussion. Any help would be greatly appreciated. Notice: Undefined variable: mComment in /home/content/g/s/1/gs1991999/html/vanilla/extensions/Notify/default.php on line 309 Notice: Undefined variable: mUser in /home/content/g/s/1/gs1991999/html/vanilla/extensions/Notify/default.php on line 309 Warning: fsockopen(): unable to connect to smtp.gmail.com:587 in /home/content/g/s/1/gs1991999/html/vanilla/library/Framework/Framework.Class.Email.php on line 196 A fatal, non-recoverable error has occurred Technical information (for support personel): Error Message Could not connect to SMTP host smtp.gmail.com:587 Affected Elements Email.SMTPSend(); The error occurred on or near: 110: Connection timed out
  • It may be that your host prevents outgoing connections on port 587. Try 25.
  • I seem to be one of the lucky ones that have Notify working correctly.

    My question is: where does X-Mailer: Lussumo Mailer in the header of the received email come from?

    I have searched all the associated files but it's not there, I even checked the language file.

    Posted: Friday, 28 December 2007 at 9:37AM

  • Wanderer, it's near line 145 of /library/Framework/Framework.Class.Email.php
  • Great extension by the way.

    However I just installed this for the first time and I'm getting a similar error to above:

    Notice: Undefined variable: mComment in /public_html/extensions/Notify/default.php on line 309, referer: http://xxxxx.com/post/474/
    Notice: Undefined variable: mUser in /public_html/extensions/Notify/default.php on line 309, referer: http://xxxxx.com/post/474/


    I don't see either of those variables anywhere else in the add-on, except for line 309. So, I'm thinking that the error is true.

    Any ideas??
  • Thanks Dan-Man, I didn't think of looking outside the Notify files.

    Posted: Sunday, 13 January 2008 at 8:32AM

  • I'm having an odd issue. I've installed and tweaked a good 20 other add-ons, but can't even get this add-on to register in the extensions menu, therefore can't enable it. I'm tempted to add the code into the include file myself, but it seems odd that It doesn't come up?
  • Ok, solved that issue. Manually added it into the extensions.php myself, and it chucked up a permissions error. Chmod 755 the folder and it installed. Not tested it to see if it works yet, mind you :P Odd, as no other extension gave me that issue - almost as if the zip archive retained the previous permissions.
  • Sorry to add a third post....

    It's working a charm with my install. However...

    1 - When you tick/untick a notification setting on the account page, it does the AJAX doo-da and works, but leaves you with a blank line rather than a ticked/unticked box.

    2 - Forcing e-mail notification on, would be lovely, if people also had the option to force it off. Or, perhaps make it default that whenever you post a new discussion, you automatically subscribe.
  • Hi, hope my question wasn't already answered - at least i couldn't find anything. Some of my users who subscribed to the whole forum get mail notifications for discussions they don't have rights to participate which genereates an error message. Is this "normal"? how can I prevent this?
  • does notify work with 'user wall' ?
  • I could not install it without solving some problems. The permission settings of the "Notify" folder were wrong. The groupt "Others" needs to have read-rights.

    There is also a little Bug in default.php on line 153. You hardcoded "LUM_User" there.

    PS:
    Notify seems to conflict with the LowCal Plugin. When LowCal the subscription link stops working.
  • I am experiencing the same problem that a few people have mentioned in this thread - when you click one of the subscribe/unsubscribe links, the three green 'AJAX' loading dots appear infinitely, and the change is never applied.

    As above, disabling LowCal seems to fix the problem so there is obviously a conflict here.

    I have also found that this extension conflicts with Comment Links - it disables the JS drop down.

    Any idea what can be done? I've informed each of the extensions of the conflicts they are having...
  • Hi,
    today I tried to translate "Notify" and some other Add-ons, too, into German and noticed most of them use the "old style" for declaring the language variables.

    So I made a convertion (with the help of "sed" described here) to use the documented "new style" for the "Notify" extension.
    If you want (an I recommend it) you can download the patch or/and the new "default.php" from my site at http://sokai.name/code/vanilla/add-ons/.

    For all German people: The translated text can be downloaded from http://sokai.name/code/vanilla/translation/. :)

    Thanks a lot,
    sokai
  • Joey,

    How did you do the following? I'm having the same problems with JQMedia. I'm still not 100% comfortable with the Vanilla scripting/extension language, so any help with this would be loved.

    "It did not interact well with JQMedia on my configuration. I now eventually have alot of the features working after disabling JQuery v12-1.1.4 and all other JQ extensions temporarily to enable the Notify extension first then I re-enabled the JQuery v12-1.1.4 and other JQ extensions afterward. I had to modify the default.php for JQmedia 0.5.1 to have JQmedia included in all the pages that had Notify panel links, not just the comments.php and posts.php pages (as is where JQmedia appears to be included by default). For some reason JQmedia and some other JQuery extensions had a bad effect on the Notify extension's javascript includes in the header when displayed in certain various orders even when notify was enabled first through the settings extension control panel. The quickest way I discovered to fix the JQmedia conflict in my configuration was to either disable JQmedia or, as I stated above, just simply included JQmedia on all pages containing the Notify extension "subscribe" and "unsubscribe" links."

    mcs
  • anyone have any updates on this? i installed it and it either works for everyone all the time (forcing $Configuration['NOTIFY_AUTO_ALL'] = '1';) or when i set it to 0, the ajax doesn't work (it doesn't save the options in the account notification area) and the 'subscribe to forum' link just links to the main forum page and doesn't do anything. any help would be greatly appreciated! thanks
  • if there r to be updates for this can the updates include notify working for comments on the user wall? that would be awesome ^_^
  • @rmccue
    Is it just me, or do {user}, {title} and {comment} not equal anything in email_notify.txt?

    Also, {topic_url} refers to an "ugly" permalink, rather than the "pretty" mod_rewrite permalinks I have set up. Any ideas?

    If I can get all the code worked out, I may be able to continue some development on this.
    I'm having the same problems as you, the {title} tag doesn't appear to work.
  • I always wanted to get rid of the prototype/scriptaculous dependence (for me only occuring when using Notify) of the non-administrative Vanilla frontend to increase speed a little. So I replaced the scriptaculous calls with Vanilla-native ones and added some functionality. See the script here. It is only compatible with Browsers supporting w3c-dom functions!!

    edit- oops forgot to say that if you want to use it, it makes sense to remove the injection of prototype and scriptaculous at the end of default.php

    change:
    $Head->AddScript('js/prototype.js');
    $Head->AddScript('js/scriptaculous.js');

    to:
    //$Head->AddScript('js/prototype.js');
    //$Head->AddScript('js/scriptaculous.js');

    or just remove it.
This discussion has been closed.