Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


GoogleMapDirectory

1235

Comments

  • Oh, I thought I only needed one API key from Google to activate the add-on. I need multiples?
  • The api key is based upon url. So the WP url is different from the Vanilla url.
  • So which one would I use on this page of mine: http://stirbinatorlabs.com/wordpress/?page_id=22 ? I have my Forum in an iframe on my WP page so I'm not sure which URL to capture for google. I've tried inputting a few into the google maps API generator with the same results: stirbinatorlabs.com stirbinatorlabs.com/wordpress stirbinatorlabs.com/wordpress/Vanilla-1.1.2 These all give me the error that "The Google Maps API key used on this web site was registered for a different web site. You can generate a new key for this web site at http://www.google.com/apis/maps/." Have any suggestions on the URL I should use? In the default.php, am I putting the API key in the correct place? // THESE ARE YOUR BASIC SETTINGS AddConfigurationSetting($Context, 'GOOGLEMAPDIRECTORY_TABPOSITION','25'); AddConfigurationSetting($Context, 'GOOGLEMAPDIRECTORY_TABNAME','GoogleMapDirectory'); AddConfigurationSetting($Context, 'GOOGLEMAPDIRECTORY_KEY','I paste the API key here'); AddConfigurationSetting($Context, 'GOOGLEMAPDIRECTORY_CATEGORIES','General,Restaurant,Shop'); AddConfigurationSetting($Context, 'GOOGLEMAPDIRECTORY_HEIGHT','300'); Thanks for looking!
  • What's different between your setup and mine is the location of the applications:

    jwurster.us/wordpress
    jwurster.us/Vanilla.1

    This setup seems to work for me.
  • I see, so maybe I'll keep a lookout for more updates on this thing, but for the meantime it seems that I won't be able to use this awesome plug-in. Here's for hoping though! Thanks for the help, Jim!
  • Cool, I was about to code my own standalone version of this sort of thing, but this is even better. Just downloaded it, lets hope it all works :D
  • OK, maybe I'm going back to coding my own, with the Google Maps 2 AJAX API. This was a really good idea, just not a very reliable implementation...
  • So It seems this plugin does not work with friendly url and the new version of vanilla, any plan on releasing a new version, I thought it was just me but the things that I found not to work were: 1. adding location (friendly url doesnt like it) 2. the little up and down zoom things do not appear 3. and adding a location doesn't append to the map This is such an amazing extension thanks for all your work so far!
  • anyone have any luck getting to this to work?
  • I have it working with the new version but I don't use friendly urls and I am using version 0.3.
  • Gotcha , Thanks Jimw for the info, guess I'll just have to wait it out. What are you using yours for?
  • I use it to identify where family and friends live.
  • Does anyone know of a way to link to a specific pinpoint from another page or discussion (i.e. not by clicking on the links at the bottom of the map page)? Is it possible to go to the map page and select a pinpoint all with one click?
  • Yes, you can do that. I made a myfriends page with a pull-down menu using some information I found about google maps.
  • Thanks jimw, but that's not exactly what I would like. Say your dropdown was on another page - like within a discussion - is there a way to get it to load the map page, then pinpoint the location all at once?
  • Great example jimw I might "imitate" that script since that's the best form of flattery?
  • @skube, first it's not my script. It is one of the examples I found on Google in the mapping area. You want to be able to generate some geo data when someone clicks on a link in a discussion and then pass that to the Google Map page so that the map will be generated with your location. Making that kind of add-on is beyond my skills at this point.

    @Wanderer, thanks.
  • I might come back and take another look at this c.February. I realise its not a perfect implementation but I put it out to the community hoping for someone to help develop it. Seems its just annoyed people when it hasn't work first time. I'll start with Friendly URL's, as I suspect that may be causing a lot of the fundamental issues of not storing markers? Then hopefully move onto ironing out the RoleID error. I detect a few on this thread are far better coders than me, any tips or links that might cover where these areas are going wrong, please do enlighten me.
  • Thanks Davidk as I'm not a coder I plan on helping you test
  • Version number changed from 0.4 to 0.5.
  • Uploaded version 0.5 of GoogleMapDirectory.
  • Here's the next version then.

    In 0.5 the updates are:

    - Fixed bug in RoleID reference - hopefully ironing out a bunch of errors.
    - Added standard vanilla database table prefix
    - Now works with the FriendlyURLs plug-in
    - Click on a category filters the markers to only that catgory
    - Added option to control googlemap zoom/controller

    Now obviously the first statement is a bold one as I've no way of knowing how much this has or hasn't fixed some of the more common problems. I set up about 3 different vanilla forums to test and noticed a few errors I hadn't seen before so I'm hoping those are the ones other users were experiencing and are now fixed. Most of this was centred around referring to the RoleID incorrectly and not integrating the vanilla table prefix properly - I had 'LUM' hard-coded all over the place. doh.

    On the compatibility with friendlyUrls, this is dependent on it being correctly installed and the 'URL_BUILDING_METHOD' setting being added to conf/settings. If its not correctly installed then the googlemapdirectory reverts to the default 'extension.php' type urls.

    There is one new variable in the settings install to enable controlling the map, er, controller so I suggest fully ripping out the previous version and cleaning out all GOOGLEMAPDIRECTORY variables from your settings file in the conf folder. You can leave your database table as is and the new version will pick up the locations once reinstalled.
  • well got a chance to give this a try again...for some reason once installed it doesnt create a tab in the navigation hmm any ideas?
  • I'll look into it. I usually find a refresh shows the tab, are you use page manager? if so you'll need to add a tab manually via that. Anything to report back asides from that?
  • yea that was it, had to add it manually, sofar so good no errors seems to be working, im not using friendly urls on this site but so far so good http://253hiphop.com
  • A got this error: I've installed this extension, activated it, tab is showing up, but when I click on it return me to the first tab page. I' ve added api key into extension settings and to the php file. I 've installed delbat theme and basecamp style. Using firefox 2. Any one have idea how to make it work? Thanks
  • Not quite clear what's happening Zed, can you explain a little clearer please? First thoughts is temporarily set your themes and styles back to the default vanilla ones, see if that makes any difference, also what other add-ons are you running? Often another add-on can affect things.

    Also what have you called the tab, what is the link. Any javascript errors? Perhaps install Firebug and see if anything is getting thrown back at you that might helps me understand a little more...
  • I had the same problem and noticed the link to the Google Map Directory was not using extension.php so it wasn't going to the correct page. I simply edited the default.php line 114 to add extension.php as the second param to GetURL. Hope this helps, Eddie
  • Also, aside from the bug trouble shooting, I have a feature request. Is it possible (I think it should be) to have the marker be governed by the address. So when you add a location you don't move the marker around, you just put in the address and the marker pops in. I think this plug-in would be a lot more useful with that kind of functionality.
  • i am trying to get this AWESOME extension working on our new forum: http://krosswerdz.com/munity/ and i can't get it happening. i am not an expert on php / code at all.... so any help would be great! thanks! - you can even email me direct on djp1972 {at} gmail.com thanks heaps!
Sign In or Register to comment.