Fork me on GitHub
Current releases are 2.1.1 (2 Aug 2014) and 2.0.18.13 (5 Aug 2014)
Ready for 2.1? Find out if your favorite plugins are compatible.
The 2.0 branch will no longer receive updates after Dec 2014.

Blog

13

Comments

  • Glad it's working. Looks like my educated guess worked.
  • When I install in my extensions, the blog page show errors: Warning: render(/home/content/q/u/e/domain/html/extensions//Blog/theme/Theme.Blog.php): failed to open stream: No such file or directory in /home/content/q/u/e/domain/html/extensions/Blog/library/Control.Blog.php on line 76 Warning: render(/home/content/q/u/e/domain/html/extensions//Blog/theme/Theme.Blog.php): failed to open stream: No such file or directory in /home/content/q/u/e/domain/html/extensions/Blog/library/Control.Blog.php on line 76 Warning: render(): Failed opening '/home/content/q/u/e/domain/html/extensions//Blog/theme/Theme.Blog.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/content/q/u/e/domain/html/extensions/Blog/library/Control.Blog.php on line 76 Please help, I'm a newbie...Thank you
  • Are you sure you not only activated it under 'Extensions' but followed the instructions on the extensions site? There seems to be a problem with the URL:
    ...extensions//Blog...
  • I did install the files in the Extension folder and activated it under Extensions. I already change it // to / see below Warning: render(/home/content/q/u/e/localhost/html/extensions/Blog/theme/Theme.Blog.php): failed to open stream: No such file or directory in /home/content/q/u/e/localhost/html/extensions/Blog/library/Control.Blog.php on line 76 Warning: render(/home/content/q/u/e/localhost/html/extensions/Blog/theme/Theme.Blog.php): failed to open stream: No such file or directory in /home/content/q/u/e/localhost/html/extensions/Blog/library/Control.Blog.php on line 76 Warning: render(): Failed opening '/home/content/q/u/e/localhost/html/extensions/Blog/theme/Theme.Blog.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/content/q/u/e/localhost/html/extensions/Blog/library/Control.Blog.php on line 76
  • Does the theme file it's looking for definitely exist under the extension directory? and is it readable by the web server?
  • can someone give me more detailed instructions how to incorporate the "more" tag?
  • I activated the Blog extension and am met with the following error message:

    Notice: Undefined index: Draft in /home/lookhere/public_html/forum/library/Framework/Framework.Class.SqlBuilder.php on line 251
    A fatal, non-recoverable error has occurred

    Technical information (for support personel):

    Error Message
    An error occurred while retrieving discussions.
    Affected Elements
    DiscussionManager.GetDiscussionList();
    The error occurred on or near: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '= '0' and t.CategoryID <> 1 and t.Active = '1' and (cb.Blocked = '0' or cb.Block' at line 1

    Mean anything to anyone?
  • (Note: Latest version of Vanilla and the Blog extension)
  • http://lussumo.com/community/?CommentID=69927 (Blog # 25) Did you ever figure out how to change it so only admin can post? I implemented CategoryRoles, but I still have that 'Start new blog post' link.
  • Hmmm... I still need a fix for this:

    Notice: Undefined index: Draft in /home/lookhere/public_html/forum/library/Framework/Framework.Class.SqlBuilder.php on line 251
    A fatal, non-recoverable error has occurred

    Technical information (for support personel):

    Error Message
    An error occurred while retrieving discussions.
    Affected Elements
    DiscussionManager.GetDiscussionList();
    The error occurred on or near: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '= '0' and t.CategoryID <> 1 and t.Active = '1' and (cb.Blocked = '0' or cb.Block' at line 1
  • @joewhitsitt: To hide posting from all but admins, you'll need to hack one of the template files.

    Instructions can be found here.
  • I also get this error: Notice: Undefined index: Draft in /www/.../library/Framework/Framework.Class.SqlBuilder.php on line 251 A fatal, non-recoverable error has occurred Technical information (for support personel): Error Message An error occurred while retrieving discussions. Affected Elements DiscussionManager.GetDiscussionList(); The error occurred on or near: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '= '0' and t.CategoryID = '6' and (t.WhisperUserID = '0' or t.WhisperUserID = 0 o' at line 1 For additional support documentation, visit the Lussumo Documentation website at: lussumo.com/docs Anyone know why?
  • Now it works, I've set the $Configuration['BLOG'] to '0'. What does this setting do?
  • It makes it work mate!

    Sorry I couldn't resist, too much wine with dinner tonight!

    I'll shut up now and go back for dessert!

    Posted: Thursday, 13 September 2007 at 6:28PM

  • thanks bshultz for helping with my last problem, but now i got a new problem. when I click the sign in link from the Blog page I get the following error: Notice: Undefined index: CssClass in .../themes/people_banner.php on line 5 The only PHP i know at the moment is where to copy and paste. Can anyone help with this. Thanks in advance!
  • The only way it works for me without getting that error:

    Notice: Undefined index: CssClass in .../themes/people_banner.php on line 5

    Is by adding these lines to the .htaccess file:

    RewriteRule ^extension/category/([0-9]+)$ extension.php?CategoryID=$1 [QSA,L]
    RewriteRule ^extension/category/([0-9]+)/$ extension.php?CategoryID=$1 [QSA,L]
    RewriteRule ^extension/discussion/([0-9]+)$ extension.php?DiscussionID=$1 [QSA,L]
    RewriteRule ^extension/discussion/([0-9]+)/$ extension.php?DiscussionID=$1 [QSA,L]
    RewriteRule ^extension/([0-9]+)/([0-9]+)$ extension.php?CategoryID=$1&page=$2 [QSA,L]
    RewriteRule ^extension/([0-9]+)/([0-9]+)/$ extension.php?CategoryID=$1&page=$2 [QSA,L]


    Assuming you're using friendly urls
  • Everyone who's getting the Notice: Undefined index: Draft in /www/.../library/Framework/Framework.Class.SqlBuilder.php on line 251 error... just add the following lines to your /conf/database.php // Featured Story Table Structure $DatabaseColumns['Discussion']['Draft'] = 'Draft'; maybe your database.php file was not writeable when you installed the extension
  • So everything is solved now.
    one person asked if it is for admin only. I have forgotten whether i made it for admins only or every member.
    I'll have to look at the code again
    will get back to this
  • For those of you who have experienced the following error when signing in from the 'Blog' page:

    Notice: Undefined index: CssClass in /***/html/themes/people_banner.php on line 5

    I've added a small workaround in my DefaultPage add-on. It removes ReturnUrl from the URL and seems to work. Only problem is that you will not be returned to the page you were viewing before signing-in.
  • First thanks for the excellent extension.

    I am using Blog with CategoryRoles and am finding that the 'Start a new blog post' is visible for members who only have 'ReadOnly' access to the 'Blog' category. Am I missing something or is this an issue?
  • Hey is there a way to get this blog extension to work outside vanilla, by including certain vanilla files? IF so, how could i do this... ??? wayne
  • NO idea how you would do this.
    why would u wnat it outside vanilla?
    can't u use wordpress instead
  • :P, i'm just trying to come up with a solution to my problem. and thought it could be an idea :)... I just need a way for pages that are created outside vanilla where i could Display comments from Discussion->Topics... I guess i'm really just trying to use vanilla as a CMS :P I want to right an Article and Not have the Panel side bar attached and have users comment on this article.... That's it, this is why i'm seeming to have so many problems, because i want to use vanilla as a CMS lol, well then I guess it would be better if i made vanilla work with joomla 1.5 :)
  • got this error while using with Ajax quote: Fatal error: Call to a member function on a non-object in /www/forum/extensions/AjaxQuote/default.php on line 60 also got some problem with attachments ext (attachment not shown in blog, only in discussion view) and discussion tags (completelly incompatible)... one more issue: latest blog header not shown in nugget on discussion page despite all others
  • you want attachments to appear in the blog post. have you tried using [Image_1] within the blog post.
    Whats your site
  • i've disabled blog so far because dudes needs this site working... also i met a problem that after disabling it, some users sees a "discussion not found" message when trying to create new discussion (not a blog post). but i got an idea to make a whole site on vanilla (despite the modx is cool too - easy keywords and metategs edit is serious advantage for seo-ing the static info) - vanilla allows to create a true clubing atmosphere and it's very cool soft too. :) about the discussion tags compatibility i might be hurried, sorry, i think appearing troubles follows of the dis.tags extension itself (0.3.1) and my newbie status to vanilla and sites creation. btw, anybody thought about an extension compatibility discussion creating and adding kinda table for it?
  • your ajaxquote things is not a conflict with blog extension. check line 60 of default.php file of Ajax quote.
  • sorry, i meant while ajax quote enabled when was trying to add a blog post it wrote me this stuff. when i disabled a-quote, it's ok to add a blog, but actually i don't remeber whether was it fine with simple discussions :) i'll get in touch with it (and ext-s' compabl.) more closely, for now there is a lot of admin's routine
This discussion has been closed.