Fork me on GitHub
Current release is 2.1.5 (31 Oct 2014).

Users who have not yet upgraded to 2.1 should get security release 2.0.18.14 (1 Nov 2014). We will stop providing these security releases to 2.0 at the end of this year.

BlogThis

12346

Comments

  • Hi Elm,

    From what I remember - the Attachments Code attaches images to a Discussion, not a Comment.

    I'm very tempted to fork the code off for Attachments to work with BlogThis and add in Video support too.

    Brad - I'm really not sure what's going on there. As you say, it works on all my sites perfectly.

    Drop me an e-mail and we'll do some debugging together - let me know what server you're running and what PHP/MySQL Versions.
  • I've looked through the posts here, and I didn't see an answer to this question; however, if it is there, and I skipped it over, forgive me...

    I'm looking to make multiple blogs, but not in the sense of the "&BlogUser=userid", but in the sense of two or more blogs on different subjects, which I can assign posts to separately.

    So, Blog A & Blog B could have their own tabs, and, with the proper role, I would be able to assign a post to either Blog A or Blog B, or both.

    I could do it where I made users such as "blogA" and "blogB", made tabs, and set it up that way, but I want to make these collaborative blogs that I can assign posts from any users to, if possible.

    So, any hope for me?

    -David
  • Hi David,

    That sounds a little complex. Filtering by Category may well be the closest you can get to this. I can't remember if I included category filtering in the code or not - if not I'll add it into the next release for you. Then you could manually add two tabs (via Page Manager) with the category filtering in place.

    - Spode
  • Feature request for next update:

    Is it possible to have blog posts archived by month and year like other blogging platforms? Well in actuality they aren't really archived, links are automatically created in the side panel based on what date the post was made.

    Kinda like this:
    image
  • Hi broddy, thanks for this excelent extension!!!

    I have a problem. I have installed your extension and this one as well http://lussumo.com/addons/index.php?PostBackAction=AddOn&AddOnID=399
    When I browse discussions, the extension Make It Simple Text Formatter works very well. But it doesn't work in your extension.

    Do you get me? Any tip on how to make them work together??

    Thanks
  • Hey bochenn, I got around this issue by using HTML Formatter

    It's not as user friendly as the add on you are trying to use, but at least it allows you to embed youtube videos and images in your blog posts using html tags. Good enough for now!
  • To get it working, I would imagine you need to edit the extension and add "extension.php" into the code.

    I've been thinking I *might* have a plan that will stop this issue :)

    Raize - feature request taken onboard. I might liaise with you on e-mail on exactly how you want it :)
  • Thanks, Spode, can you explain me a little bit more on how to get this to work? I'm not a big user of PHP.

    Thanks
  • Hi Spode, is there a way to add manually (in a post) a code to break the content so in the blog will a show up the link Read More?

    I really need this.

    Thanks
  • Go into settings, under Blog settings. There you can set the maximum number of words to show, after which point it will break the content into a Read More link.

    I hope that's what you meant...
  • Hi Raize, what i want to mean is to add manually a code or something in the input field of a comment or post to break it in the blog.

    I don't want something automatic like the feature you mean. I want something like in Wordpress or Joomla!

    Do you get me?

    Thanks
  • bochenn - currently this is not a feature. How does Wordpress do it - maybe I can mimmick it for you :)
  • I have installed BlogThis and Page Manager.
    When I set Blog page as second (after "all discussions") My guests can't see "all discussions" tab. Its strange, because I can see this page (loged as admin)
    I try to resync Tabs, all users have permissions to see Tabs.
    When I put Blog page as first - all tabs are displayed correct for all users.
  • I think that is probably a Page Manager issue. It adds a tab using the Vanilla framework functions - so it's doing nothing unusual!
  • From experience with other users using BlogThis on thinkabouttech.com, people seem confused at the idea of posting a discussion and then making it a blog post afterwards. That is why, with version 1.14, as well as the "Start a discussion" link, you'll now also find a "Start a blog post" button. This takes you to an identical screen to posting a discussion, aside from the fact that when it is submitted the post is automatically blogged. This should make it a little more user friendly!
  • Can you please provide a setting to turn the "Start a blog post" button off in the next release? Thank You

    //EDIT: I think you made a litte mistake in the default.php:

    $Context->SetDefinition['BlogThisSettings'] = 'BlogThis Settings';

    should be:

    $Context->SetDefinition('BlogThisSettings', 'BlogThis Settings');
  • Hi, I have an other suggestion :) I would like to see the role of each blog poster. So I added
    if ($Row['AuthRoleDesc'] != '') $BlogPost->DisplayName .= " (".FormatStringForDisplay($Row['AuthRoleDesc'] .")");
    to Control.BlogThis.php
    after line 105: $BlogPost->DisplayName = FormatStringForDisplay($Row['FirstName'] ." ". $Row['LastName']);
    and after line 109: $BlogPost->DisplayName ...
    maybe you can add this with the correct setting to turn it on and off.

    greetz
  • This is probably a very silly thing to post, but as a new Vanilla user I am probably missing something obvious.

    I have set up Vanilla for the first time, and added only a handful of plugins (FeedThis, Page Manager, HTML Formatter, FCKEditor, Category Roles) and have been pretty quick to figure out how to get them running.

    After uploading and enabling BlogThis, I am not having so much luck. I cannot figure out how to show the Blog interface -- which is to say that I get a Blog tab, and in the extension manager I see that BlogThis is enabled, but I don't know what to do in order to have buttons that will allow me to designate posts as blog entries.

    I'm using Vanbook as my theme, and I realize I may need to make some modifications like I did for Category Roles, but I don't see where to begin if that's what I'm missing.
  • Make sure you have given your user the permission to blog.
  • And that is of course what it was. I had a feeling it would be obvious in hindsight.

    I don't know if you've considered adding permissions to administrative users by default during installation, but if not that might be a good idea for folks like me.
  • Hi Spode,

    Great piece of work, this, and it's working just fine. I have Vanilla installed in a testing subdirectory on an unrelated live site, so far with just this extension with friendly URLs, and I've run into just one tiny quirk that's driving me up the wall - making the blog page the default. The standard...


    RewriteRule ^$ /extension.php?PostBackAction=Blog


    ... just drops me (as I suppose it should) to the live site's root URL. I've tried changing it to:


    RewriteRule ^testdir/$ /extension.php?PostBackAction=Blog


    and while that doesn't throw up any errors, it also doesn't have any effect whatsoever. Discussions remain stuck as the default page view. I notice that the blog page URL has been rewritten to /extension/?PostBackAction=Blog, but using that instead of the original version doesn't do any good either. I don't know enough about htaccess files to know if I'm missing something blindingly obvious or if that particular rewrite simply won't work for a subdirectory. Any thoughts before I pull out my remaining hair?
  • I ran into this too, and the answer in your case is probably the same as it was in mine.

    Somewhere before the RewriteRule line in your .htaccess you need to have a line that reads:

    RewriteEngine on


    After doing this I also discovered that I needed to use the Page Editor to change the Discussions tab URL, because by default it was pointing to the site root and would therefore take you to the Blogs page once the rewrite rule was in effect. Changing it to /index.php did the trick.
  • Thanks, Mark, but I'm afraid that's not it. The rewriting for friendly URLs on the regular discussions grid and on the blog page are working just fine and the call to turn mod_rewrite on is at the top of the file. It's purely that last line to set the blog page instead of the discussions grid as the default view when entering the site that's causing trouble. It may just be that for one reason or another it only works if Vanilla is in the root directory, not in a subdirectory, in which case I can stop worrying at it because it means the site should be fine in its live form. Or it might just be that my pitiful grasp of Apache/htaccess syntax is making me screw up rewriting to a subdirectory instead of root...
  • I don't have time to debug your rewrites right now - but I use the method I published on all my sites without problem, so I would suggest it'll be fine when you put it onto the site root :)
  • I have read through the Forum, and haven't seen what I'm sure is a simple remedy, but I don't have a blog tab! I have enabled the extension, and have given permission for users and administrators to add blogs etc, which I can do, but they only appear in the Discussions page, like any other discussion, though I can "Unblog" them, which again makes no difference. What haven't I done?
    I tried to go to the page with:
    http://beerpie.com/forum/extension.php?PostBackAction=Blog
    but only got:
    A fatal, non-recoverable error has occurred

    Technical information (for support personel):

    Error Message
    An error occurred while attempting to retrieve the requested comments.
    Affected Elements
    Blog.BlogComments();
    The error occurred on or near: You have an error in your SQL syntax near '.CommentID AS CommentID, m.DiscussionID AS DiscussionID, m.Body AS Body, m.Fo' at line 1
    As I said I'm sure its something obvious, as nobody else seems to have such a problem.
  • I have Resynced Tabs, which produced the tab, however clicking on it still produces the same error message.
  • Something more severe going on there - the tab isn't the issue. Nothing is jumping to mind either! Other than the fact you're in a sub-folder. I've not tested with Sub-Folders.
  • Hi. I installed and tried this, but decided I don't need it at the moment. So, checked 'off' in Extensions panel, then took it off the server. BUT, I have spurious garbage left in my Admin role settings. Latest Discussion has done this too. There are settings left in the DB roles table for Admin, but I can't get them out without breaking it (not sure exactly what to remove).

    Any hep appreciated - it's really niggling.
Sign In or Register to comment.