Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Forced Category

edited February 2008 in Questions
This discussion is related to the Forced Category addon.
Forced Category

Comments

  • I tried installing this, once I tested it by hitting submit without choosing a topic it didnt validate but send me to a not found page when trying to post, any ideas?
  • When i tested this and didnt select a category i got this error....

    Fatal error: Call to a member function on a non-object in /home/content/n/i/c/nickandmandy/html/mysite.com/vanilla/extensions/AjaxQuote/default.php on line 60

    will i have to disable ajax quote for this extension to work?
  • I'm not quite sure whats going on in either case--what URL does it say doesn't exist? What version of PHP?

    Ajaxquote looks like it should work OK, at first look this extension doesn't appear to step on its toes, yet I get a different error message pasted into the comment box instead of when trying to post... in fact it does this to me even when it's the only extension installed:[quote][cite] wallphone:[/cite]<br />
    <b>Notice</b>: Undefined index: Body in <b>...extensions\AjaxQuote\ajax.php</b> on line <b>26</b><br />
    [/quote]
  • I get the error that MichaelPierce gets. The frustrating part is that it doesn't save what you had in the textbox!
  • Friendly URLS?

    edit:
    Apparently friendly URLs work fine for me. And works fine with a bunch of random extensions on PHP 4.4.7.

    I'll need more info about these errors before I can fix them!
  • I'm using php 5, friendly urls,

    when I hit start discussion without a cat chosen

    and I put like test in subject and body test

    I get the error

    404
    Not Found

    The requested URL /discussion/test/ was not found on this server.
  • That could be a core bug--it looks like it is building a URL as if the discussion was saved properly-- If you leave the body blank does it leave a message?
  • OK, try changing the bottom line of this section in library/vanilla/Vanilla.Control.DiscussionForm.php from this: $this->DelegateParameters['ResultDiscussion'] = &$ResultDiscussion;
    $this->CallDelegate('PostSaveDiscussion');

    if ($ResultDiscussion) {
    To this: $this->DelegateParameters['ResultDiscussion'] = &$ResultDiscussion;
    $this->CallDelegate('PostSaveDiscussion');

    if ($ResultDiscussion && ($ResultDiscussion->DiscussionID > 0)) {
    And test again... It then should give the actual vanilla error that should be showing up.
  • Fatal error: Call to a member function FormatPropertiesForDisplay() on a non-object in /***/community/library/Vanilla/Vanilla.Control.DiscussionForm.php on line 219
  • Notice: Trying to get property of non-object in /home/17364/domains/253hiphop.com/html/extensions/Attachments/default.php on line 698 Notice: Undefined property: stdClass::$DiscussionID in /home/17364/domains/253hiphop.com/html/library/Vanilla/Vanilla.Control.DiscussionForm.php on line 124
This discussion has been closed.