Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Notifi

1356710

Comments

  • Version number changed from 1.7.1 to 1.7.
  • Uploaded version 1.7.1 of Notifi.
  • Notifi is finally compatible with Low-Cal Vanilla! Be sure you download the new versions of both the extensions or you will get an error (of course there is no error if you don't already have Low-Cal Vanilla, don't worry it isn't a dependency).
  • Hi SubJunk. I have installed 1.7.1 and notice an error message after activating the extension: Notice: Undefined index: LOWCALVANILLA_TOOLS_PATH in Hostpath\httpdocs\forum\extensions\Notifi\_includes\install.php on line 76
  • Can you please tell me if you have Low-Cal Vanilla installed, or if you have ever had it installed, and which version?
  • oops... you should use: if (!empty($Configuration['LOWCALVANILLA_TOOLS_PATH'])) { to check if LowCal is installed
  • No I don't have Low-Cal Vanilla installed or ever had it installed. The extensions I have installed are: # Community Moderation 1.0 # FCKeditor 2.5.4 # Forum Statistics 0.4.5 # Global Preference Setting 0.1 # Html Formatter 2.4 # Janine 1.1.1 # MembersList 1.2 # Notifi 1.7.1 (temp deactivated) # Preview Post 2.5.2 # Set List 1.0.1 # Stuff Displayer 2.1 # reCAPTCHA 1.10.0
  • @ Dinoboff - thanks I changed the line as you suggested to check if LowCal is installed and it did the trick
  • Uploaded version 1.7.2 of Notifi.
  • Ah dino beat me to it ;) anyway that is exactly the same thing I did in this update. Sorry for the trouble palmdoc I didn't do enough testing before release.
    Dino you might want to edit this post with the updated code too.
  • Wow that was fast ;) Anyway great work Subjunk!
  • Uploaded version 1.7.3 of Notifi.
  • Funny I am still getting the occasional error. Error Message An error occurred while sending the email. Affected Elements Email.ServerParse(); The error occurred on or near: Couldn't get mail server response codes. after the latest Notifi update. I have not made any SMTP server changes but it seems to work only on and off. Any clues?
  • Thanks for letting me know. Can you please tell me exactly what you do to get that error? It will be much easier for me to fix it if I can reproduce it
  • I'm not quite sure. After the updating with the latest default.php file, it seemed to work. Later on I got the message again so I disabled the extension. Then I enabled it again and it seemed to be OK for a while but it then gave the same error again when posting comments in threads. I don't know how to reproduce it. I don't know if it is sensitive to server time outs perhaps? But I don't have any issues with email from my main Wordpress blog anyway. It's in http://palmdoc.net/forum if you want to check it out At the moment I enabled the extension but I am getting the error
  • Well instead of taking a lot of space up on this discussion why don't you email me, my email address is in Notifi/default.php. I signed up at your forum but it appears you disabled Notifi again so I can't test it. Anyway I'll wait for your email.
  • Many thanks for the work done on Notifi. Version 1.7.3 is working very well for me. Would it be possible to configure it to just post the first e-mail of each discussion? This would enable people to go to the forum on the web if they were interested in the topic and would not block up everyone's e-mail too much with the answers. I am working with a group who are used to an e-mail forum and getting them to accept Vanilla has been an uphill struggle. Our old forum (MailMan) works by e-mailing the question and the answers are sent only to the person who asked the question. This person then has the task of summarising all the answers and sending the summary to the forum. If we could use Vanilla in this way the summary would be redundant.
  • To Tony:
    Yes that is very possible to make and it's a good idea. I was hoping someone would make a new feature suggestion soon. I don't have much free time at the moment in between work and other personal projects, but when I get a chance I will make that feature.
  • Thank you very much SubJunk. I look forward to that and when completed I will owe you a few beers or something!
  • Just thought you should all know that this extension does not work with Vanilla 1.1.2

    No errors are generated but no emails either :-(
  • On the main page for Notifi it has always said "Requires Vanilla 1.1.4", why would it say that if it wasn't true?
  • Alright already so I missed that little snippet, never said it wasn't true, in fact my statement verified it!

    Posted: Friday, 26 September 2008 at 8:59PM

  • A few ideas and wishes if you're doing a rewrite: 1. Shift focus from notification only when there is something new to subscribing by e-mail (but with the option to only get a notification when there is something new if the user so wishes). 2. Send the mail with the correct headers, so it's sent as a reply to the actual thread - thus allowing for threaded e-mail notification. 3. Send the e-mail with the from-address not as the system normal, but as the user who wrote the posts (if that e-mail is public). Would also love to see a different type of mail for editing comments, moving threads etc. Love the extension! Best, Daniel
  • I seem to running into an error. Whenever I add a new comment to a discussion, with Notifi activated, I get the error below. I ran into a similar error with other emails that Vanilla sent (such as lost password), but I added 'date_default_timezone_set('Europe/London');' to the /library/Framework/Framework.Class.Email.php file and it fixed it. I tried a similar approach with Notifi's Framework.Class.Email.php but it didn't fix the issue. Any ideas? Notice: Undefined variable: rolesAry in /home2/ourbigea/public_html/dev/forum/extensions/Notifi/default.php on line 296 A fatal, non-recoverable error has occurred Technical information (for support personel): Error Message An error occurred while sending the email. Affected Elements Email.Send(); The error occurred on or near: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Denver' for 'MDT/-6.0/DST' instead For additional support documentation, visit the Lussumo Documentation website at: lussumo.com/docs Thanks! tate
  • Are you using Notifi 1.7.3 and Vanilla 1.1.5a, or are you using older versions? The reason I ask is that if you use the latest version of both, the Framework.Class.Email.php file in the Notifi folder will be skipped, it isn't needed anymore with Vanilla 1.1.5+.
  • Hi SubJunk, Yes, I am using both Notifi 1.7.3 and Vanilla 1.1.5a. I tried removing the Framework.Class.Email.php from the Notifi folder and I got an include error.
  • Hmmm...
    Well let's do an experiment.
    Open extensions/Notifi/default.php and find lines 273 to 279, they should be this: // Include the custom email class
    if (!isset($Configuration['DEFAULT_EMAIL_MIME_TYPE'])) {
    include_once('_includes/Framework.Class.Email.php');
    }
    else {
    $Configuration['DEFAULT_EMAIL_MIME_TYPE'] = 'text/html';
    }
    Replace them with just this: $Configuration['DEFAULT_EMAIL_MIME_TYPE'] = 'text/html';and tell me what happens, and if it does work, if the emails look normal or like a bunch of code.
  • Hi SubJunk, I switched out the code in default.php and I am getting the same error (below). No email was sent either. Notice: Undefined variable: rolesAry in /home2/ourbigea/public_html/dev/forum/extensions/Notifi/default.php on line 290 Notice: Undefined variable: php_errormsg in /home2/ourbigea/public_html/dev/forum/library/Framework/Framework.Class.Email.php on line 165 A fatal, non-recoverable error has occurred Technical information (for support personel): Error Message An error occurred while sending the email. Affected Elements Email.Send(); For additional support documentation, visit the Lussumo Documentation website at: lussumo.com/docs Thanks! tate
  • Ok I'll whisper you from now on until we find a solution
Sign In or Register to comment.