Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us




  • The mailto: function doesn't seem to be enabled on my installation. Plus, it appears that http:// must be before the hyperlink in order to make it active. Am I correct? Please see here for this problem:
  • woot woot

    anyway you could implement FAIRTILIZER embeds? Right now it really doesnt work because it takes me to the fairtilizer site sans the side panel that has the music player in it, so I cant even link to the fairtilizer site to hear the music.

    many thanks!
  • @jasonrocks7: I couldn't see you using any mailto: links, but you literally have to type, "" for it to work. And yes, you are correct, links that begin "http://" (or "https://", etc) are automatically made in to links. If this weren't the case, the extension might make some things that aren't links in to links.
  • version 1.5
    • added support for (requires iframes to be permitted)
    • bugfix: also detect images to embed from URL params
    @banjanqrum: there you go. Don't forget to allow the 'iframe' HTML tag through if you use the HtmlFormatter with the above modifications. You do this by removing it from the $Html_DisallowedTags list, in the same way as you do the 'embed' tag (see the end of the instructions on modifying HTML Formatter manually).
  • I'm sorry, but it doesn't work. I'm using Vanilla 1.1.9 and added Autolink 1.5 and the modified Markdown 1.12 form here

    When I activate Markdown and switch my comment from text mode to markdown mode, all videos disapear.
  • Hi, I'm having the same issue. I'm not getting it to work and I'm using Vanilla 1.1.8. Any ideas?
  • @mkadi, @swisswebmiss: Ok, sorry for the delay. I've figured out what's causing the problem you're having. Try disabling and re-enabling the AutoLinks extension and that should fix it.

    It's because Vanilla runs the extensions in the order they were enabled and AutoLinks adds it's self as a child formatter of any formatters that exist at the time it runs. If the HTML or Markdown formatter extensions haven't been run at that point, they won't exist. So AutoLinks has to be enabled last. I'll look at converting AutoLinks in to a global formatter instead, which should fix it properly.
  • @edam,
    This extension is exactly what we've been looking for.

    Is it possible to limit the length of displayed URL links? If someone enters a really long URL it would be cool if only 50 characters or so were displayed and end with "..." like:

  • I just solved my own problem... If anyone is interested in doing what I posted above, I modified this extension as follows:

    I replaced line 132:
    return '<a href="'.$link[0].'" rel="nofollow" class="auto-embedded" >'.$link[0].'</a>';

    With the following:

    $linkDisplay = $link[0];
    if (strlen($linkDisplay) > 50) {
    $linkDisplay = substr($linkDisplay,0,50) ;
    $linkDisplay = $linkDisplay."...";
    return '<a href="'.$link[0].'" rel="nofollow" class="auto-embedded" target="_blank">'.$linkDisplay.'</a>';

    The code does two things. First, it limits the display length of URL's to 50 characters (or whatever you set it to). Second, I added target="_blank" to the anchor tag so the link will open a new tab (my preference when viewing a forum).

    Hope this helps someone else!
  • Hello there.

    anyone here can make Autolink replace .FLV link to embed obj code?
  • Can you add support for
  • pls fix AutoLink to work in Blogthis addon.
  • @ken524: that's a good idea! I'll add it to the next release. Thanks!

    @Bers40k: If you (or anyone else) can suggest a free flash flv player on the web that I can use (or even include?), then I'll happily add this feature.

    @MacTyler: I looked in to that. I don't think that it's possible. They have deliberately made their embedding URLs different to their video links, probably to try and avoid automatic embedding.

    @Bers40k: I'll have another look at BlogThis, see if I can get them to work together. In the mean time, try disabling and re-enabling the AutoLinks extension. I realised a while ago that it has be enabled last, or it is unable to hook in to the other extensions!
  • @ken524 - Thanks for edited with your mod and it works great.
    @edam - Thanks for great plugin, is it possible to add Chinese Youtube version Youku?
    > free flash flv player on the web that

    may be this ?

    > and re-enabling the AutoLinks extension

    i try but AL dont work
  • this works well except for one thing...

    when i type ( it doesn't recognize it as a link unless i put spaces between the URL and parenthesis
  • in regards to the above... somehow that worked in this forum but not in my vanilla version 1.
  • I get this at the top of the page after posting a link; how does one fix it?

    Deprecated: Function split() is deprecated in /home/ooveecom/public_html/forum/extensions/AutoLinks/default.php on line 140

    Deprecated: Function split() is deprecated in /home/ooveecom/public_html/forum/extensions/AutoLinks/default.php on line 142
  • I enabled the extension. How does it work? I refreshed my forum site and tried to copy and past some YouTube code, but it didn't work. I'm new to RW and Vanilla, so all the extra code work above is over my head.
  • To fix the split issue just replace split( with explode(
  • doesn't work with Forced BBCode
Sign In or Register to comment.