Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


phpbb to Vanilla conversion tool

2»

Comments

  • ToddTodd Chief Product Officer Vanilla Staff
    I took the phpbb3 export out because I didn't have proper test data and there were reports of bugs. Since then people have had it work on their forums because of some work Lincoln did I think.

    I now have an dump of a phpbb3 forum and @lincoln also has something he will hopefully forward to me. I cross-my-heart promise I will get those tests done this weekend.
  • @buzz_lightyear & @todd
    Thanks for your replies! I see, guess one week of waiting doesn't hurt! :D
    Great work!
  • candymancandyman ✭✭
    edited July 2010
    And what about phpBB2? I have to upgrade to phpBB3 and then made the switch?
  • ToddTodd Chief Product Officer Vanilla Staff
    @candyman, I won't be supporting phpbb2. I couldn't even find a download for it when I went to look. Isn't phpbb2 really, really old?
  • I don't think it's entirely unreasonable to require people to upgrade to phpbb3 first is it? Although it could mean some people don't bother upgrading to Vanilla as they might be happy with their upgrade to phpbb3 :D
  • There are still some problems. Lists and code blocks are not imported correctly. Here are some examples:

    List:

    [list][*]alternative ZIP-Klasse[/*:m][*]Zusätzliche Alternativfunktion (exec)[/*:m][*]Verwendung eines anderen Dateiformats zum Speichern von Backups[/*:m][/list:u]

    instead of:
    • alternative ZIP-Klasse
    • Zusätzliche Alternativfunktion (exec)
    • Verwendung eines anderen Dateiformats zum Speichern von Backups
    Code block:
    <br />&lt;object type=&quot;application/x-shockwave-flash&quot; data=&quot;autoviewer&#46;swf?xmlURL=gallery&#46;xml&amp;amp;preloaderColor=0x000000&quot; width=&quot;650&quot; height=&quot;630&quot;&gt;<br />&lt;param name=&quot;bgcolor&quot; value=&quot;#ffffff&quot; /&gt;<br />&lt;/object&gt;<br />
    instead of:
    <object type="application/x-shockwave-flash" data="autoviewer.swf?xmlURL=gallery.xml&amp;preloaderColor=0x000000" width="650" height="630">
    <param name="bgcolor" value="#ffffff" />
    </object>
  • The problems I posted a month ago are still not fixed. This really prevents me from switching.
  • Am i the only who get no conversations at all after the import ?

    Thanks for yout help.

    I'm running the whole thing on my localhost (MAMP).
  • a few years ago I programmed this script and it worked fine for me:
    http://salmacis.com/import-vanilla.cgi.txt
  • lucluc ✭✭
    @_keith_: yours is for vanilla 1.1.4. This discussion pertains to vanilla2. (though one might use your tool to v1, and then export/import to v2).
2»
Sign In or Register to comment.