Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Avatars / picture

edited August 2010 in Questions
Is it just me or am I missing the "change my picture" option in my forum? i can see it on the vanilla forums here but not on mine.. is it a special add on? i've tried to find it in documentation and searching the forum but no luck.. any help appreciated. thanks.
«1

Comments

  • I mind, Avatars & Profile Picture?
  • Sorry I didn't get that.. i'm talking about the avatars I guess. nowhere to upload/change them..
  • @sc2fan have you tried click on your name, and Change My Picture is in your profile, or you have a faulty installation, so i think.
  • Edit My Account
    Change My Password
    My Preferences
    Signature Settings

    those are all the options i have under 'options'...

    faulty installation you say? hmm, can it be re-installed without losing all the posts?
  • I get a "Page Not Found" when I finish "Edit my Thumbnail".
  • i also get a "page not found" when i attempt to change my picture. i tried changing my permissions on the upload folder to 777 but no dice. brand new installation of vanilla
  • same problem as RJRiley
  • Same problem here. Was working with the Vanilla 2.0 but lost them when I did an upgrade and "updated my database". Only lost the thumbnails of some of my users and got an error that it can't change an externally linked image. I was able to delete the generic "?" picture but when I try to upload a new one it gives me the "page not found" error. Any more on this?
  • Same here, just installed Vanilla 2 (clean install)
    When I try "change my picture" I get the "page not found" any ideas?
    Thanks
  • Check if the uploads directory has the right permissions. When I uploaded my forum to the live environment I had the same problem, but it turned out I forgot to set the permissions for the uploads directory again. Since the pictures are uploaded into this folder, the options disappear when the directory isn't writable.
  • edited August 2010
    Upload directory did not have the right permissions so I gave the folder 777 permission but still get the "page not found" error. Strange thing is that I only lost the pictures for myself and a few other users. Some of them are still there. I was running PresetAvatars under Vanilla 1 and the pictures converted to Vanilla 2 until the 2.03 update. Did the conversion to Vanilla 2 move the pictures? I don't see them in the new install upload directory. Not familiar enough with forum software to know where the pictures were in Vanilla 1 and where the are/or should be, now.
  • Note: My solution is a response to the problem in the original post (options are missing). It is not however a solution for the "page not found" problem.
  • Thanks Pixelspin,

    Good to have everything in order even if it doesn't totally apply to the problem. I have been able to add some of the avatars back by "changing the picture" option, let the "page not found" error come up, hit the back button twice on safari browser (1st back refresh produces a locked up page), and then the user icon is restored. Does not however work for me as the admin. My icon remains the blue apple icon.
  • Edit My Account
    Change My Password
    My Preferences
    Signature Settings

    those are all the options i have under 'options'...

    faulty installation you say? hmm, can it be re-installed without losing all the posts?
    sc2fan,

    I wonder if you have found a solution to this? I am on 2.0.6 and some of my users are missing the Add and Remove picture option also. It is there for some users but not for others. I do have 777 permissions for the uploads folder
  • Anybody else have the problem of the missing options "Change Picture" and "Remove Picture"? They are missing on only a few of my users. I believe these users never defined a picture in Vanilla 1 before I upgraded.

    Edit Account
    Delete Account
    Edit Preferences
    Send xxxxx a Message



    Most of them are correct, like this:

    Change Picture
    Edit Account
    Delete Account
    Remove Picture
    Edit Preferences
    Send xxxxxxxx a Message

    Version 2.0.6 with the default theme.

    TIA
  • Having the same issue, permissions on the uploads directory is global read/write. I can't find any users that can actually change their pictures. Though users who had previously defined avatars in 1.x do have them still displayed, there's no way to change them or for other users to set them.
  • same problem..

    any ideas?
  • php gd library installed... solved my problem.. thanks
  • Ok ruifelipe,

    I checked with my hosting site and I have GD installed. I updated to Vanilla 2.0.9 but still have the same problem I mentioned above. Unlike Gillingham's problem my users are able to change their picture but SOME of my users do not have the "Change Picture" option available in their prefs and they do not have a picture on their account. Anybody that can help on this? I looked at the users that do not have the "Change Picture" option available and I cannot find any similarities in those users that may account for the fact they do not have the picture options.
  • Anybody else have the problem of the missing options "Change Picture" and "Remove Picture"? They are missing on only a few of my users. I believe these users never defined a picture in Vanilla 1 before I upgraded.

    Edit Account
    Delete Account
    Edit Preferences
    Send xxxxx a Message



    Most of them are correct, like this:

    Change Picture
    Edit Account
    Delete Account
    Remove Picture
    Edit Preferences
    Send xxxxxxxx a Message

    Version 2.0.6 with the default theme.

    TIA
    Ok, I checked with a forum member today who I see is missing the Change Picture and Remove Picture options while I am in the dashboard. Strange thing is that when the user is signed in under his account he indeed does have the Change Picture and Remove Picture options. When I check the user in the dashboard the user does not have those two options. This happens only for some users on my forum. Some of the other users indeed do show the Change Picture and Remove Picture options in the dashboard. I confirmed this by using the Spoof plugin on a few of the users in question. Any idea why the dashboard is displaying one set of options for one user and a different set for another user? Other admins who have the missing options may want to check this out, perhaps they really are not missing at all. Running Vanilla 2.0.11 at this point.
  • Same problem here. My user only has the "Change Picture" option, not the "Remove Picture" option. The "Create Thumbnail" option is also missing. What's happening?
  • I have the same problem, but I install vanilla in Windows 2003 and IIS 6.




  • I have the same problem, but I install vanilla in Windows 2003 and IIS 6.

    Did you check with a user to see if the options are truly missing or if they are just missing to you when you look at his account signed in as admin? That appears how it is working in my situation. I am running 2.0.17.8 now and I still have strange behaviour!

  • Dan,

    I create another user and behaviour is the same.

    Do you use the Windows or Linux?

    I really appreciate the work done in vanilla, I would not want to use the bbpress.


  • Dan,

    I create another user and behaviour is the same.

    Do you use the Windows or Linux?

    I really appreciate the work done in vanilla, I would not want to use the bbpress.


    I am not too technical on this but the forum is on a Dreamhost server and I am using MacOSX on all my machines here. I just checked again and it appears the problem is no longer there for me. When signed in as admin and I check the user screen all the options are there now for the users that were missing before. What version of Vanilla are you running? I am running the latest now (2.0.17.8) and I don't know when it was fixed but it appears that my problem was fixed somewhere between version 2.0.11 (when I first reported it) and this latest version. Update to the latest version and see if you still have the problem. Sorry I can't be more helpful.

  • Thanks,

    I downloaded and installed today, I think is last version.





  • edited April 2011
    Hi,

    I have similar problem, no "change picture" option visible by users.
    If I log in as admin and click user name in dashboard - works fine, change picture link is visible. I try to create uploads/userpics directory with 777 permission but no luck.

    Vanilla 2.0.17.9 9 (fresh install, embeded), Linux server witch GD2 installed.

  • edited April 2011
    I've just installed a Vanilla forum, and learning how it works.

    It won't let me upload any pics with the file extension .jpeg, yet will allow .jpg for some reason. Yet when I signed up to this (Vanialforums.org) forum it lets me do it. Why is that?

    Is there also a way of limiting the size of file that is uploaded by a user, or changing the dimensions of an avatar?
  • @Gizmoduck
    It won't let me upload any pics with the file extension .jpeg, yet will allow .jpg for some reason.
    FileUpload 1.1 Released - Vanilla Forums
    Is there also a way of limiting the size of file that is uploaded by a user,
    Max file size - Vanilla Forums
    or changing the dimensions of an avatar?
    Avatar Size in Vanilla 2 - Vanilla Forums
  • LincolnLincoln Community Instigator Vanilla Staff
    FYI, jpeg and tiff files will be allowed by default in the next release.

    Sr Developer at Vanilla Forums [GitHub, Twitter]

«1
Sign In or Register to comment.