Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Directing feeds into Categories and missing body

edited March 2011 in Questions
This discussion is related to the Magpie Feeds addon.
Hello,

How would I direct feeds into a certain category names "News"? Also, it seems everything is working except for importing the body of a feed. Maybe a future feature would be to be able select the category you want the feed to populate to. Nice work btw!

http://theguttural.com/discussion/128/experts-outlook-positive-for-hospitalized-japan-plant-workers-cnn-international#Item_1

Comments

  • Why is the body missing? In the code, the title is concatenated to 'temporary body'! What's up with that? Also, the delete does not delete the active feeds. In fact, if you completely remove the plugin and reinstall it, the former feeds are still there because they haven't been deleted from config.php.
  • preachurpreachur New
    edited July 2012

    The 'temporary body' error makes this useless for me. I am trying to feed code red dogs (shelter dogs who are about to be destroyed.) from facebook pages into a vanilla forum. This would only work if the body of the feeds displayed and they could be directed into the proper categories. If these 2 issues are solved, this plugin could (and would) help to save many lives. It would allow many rescue efforts in many parts of the world to be easily viewed and discussed in one place.

  • preachurpreachur New
    edited July 2012

    I fixed the "temporary body' error on mine.

    in class.magpiefeeds.plugin.php

    Find where it says:

         $StoryBody = $Item['title']."temporary body";
    

    Replace it with:

         $StoryBody = $Item['description'];
    
  • preachurpreachur New
    edited July 2012

    Actually, I decided I wanted the link to the article above the body, so I changed it to this:

    Replace this line:
    $StoryBody = $Item['title']."temporary body";

    With this line:
    $StoryBody = $Item['link']."<br>".$Item['description'];

  • The idea of this is really good, but unfortunately in it's present state, it's quite defunct. The formatting of the imported posts are also wacky.

    -k0nsl

  • Fatal error: Cannot redeclare debug() (previously declared in /home6/diwanagc/public_html/travelguide/library/core/functions.general.php:691) in /home6/diwanagc/public_html/travelguide/plugins/MagpieFeeds/magpierss/rss_fetch.inc on line 244

  • peregrineperegrine MVP
    edited December 2012

    @travelguide

    seeking clarification from the spirits...

    Fatal error: Cannot redeclare debug() (previously declared in /home6/diwanagc/public_html/travelguide/library/core/functions.general.php:691) in /home6/diwanagc/public_html/travelguide/plugins/MagpieFeeds/magpierss/rss_fetch.inc on line 244

    Ahhh grasshopper let me see . incense burning. incantations cast. cauldrons boiling....

    I will be your searchbox travelguide and oracular consultant today, for tomorrow, it will be up to you.

    type "redeclare debug" in the "magic" box aka "search box"

    which "automagically" guides you to the answer that you have long sought.

    ¡shazaam!

    http://vanillaforums.org/discussion/19627

    sincerely,

    your delphic oracle.

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

    vrijvlinder
  • I'd also like to direct the RRS Feed into a category; at the moment it just posts into a 'Root' directory, and I'd appreciate anyone who has the time to point me in the right steps to correct this, please?

    Thanks!

  • @Reedswood said: I'd also like to direct the RRS Feed into a category; at the moment it just posts into a 'Root' directory, and I'd appreciate anyone who has the time to point me in the right steps to correct this, please?

    Thanks!

    I've got the same issue. I've specified the category ID that I want the posts to go in to, but its not happening. :(

  • it's a shame as Vanilla Forums deserves an RSS Feed function system!

Sign In or Register to comment.