Fork me on GitHub
Current release is 2.1.6 (21 Nov 2014).

Users who have not yet upgraded to 2.1 should get security release 2.0.18.14 (1 Nov 2014). We will stop providing these security releases to 2.0 at the end of this year.

Fatal Error when I try to activate Vanilla in the applications on localhost

edited July 2011 in Vanilla 2.0 Help
I've been working on a couple of designs for Vanilla that I plan to release, but my localhost stopped working last week so I reset everything on my computer and choose to install Zend Server CE as my localhost. I've never had problems with Vanilla before so I'm wondering if it's Zend Server.

I installed a new copy of Vanilla(downloaded 5 minutes ago) into my localhost and installed it at vanilla.local

I can login and do whatever, but I can't seem to import the dummy data OR activate the vanilla application. Everytime I try to, I get this error:

Fatal error: Class 'CategoryModel' not found in C:\sites\vanilla\public\applications\vanilla\settings\structure.php on line 60

I'm not a PHP guy and have no idea how to fix this stuff. I've uninstalled/installed a number of times and still get the same error!

I'd be very very very grateful to anyone that can help me fix this problem.

Thank you, MatthewAlan Designs.

Best Answer

  • TimTim Lord of Servers Vanilla Staff
    Answer ✓
    There was a bug that I thought had been fixed (perhaps some merge SNAFU) where enabling applications didn't pre-initialize the autoloader in time to handle any possible includes in the structure / other setup actions. This has been fixed in 2.0.18 beta.

    Download that from our github, or by going to the Vanilla addon on our addons site and specifically choosing to install the beta.

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

Answers

  • TimTim Lord of Servers Vanilla Staff
    If that doesn't fix it, you might be running into a problem that is specific to Zend Server, in which case you are screwed.

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • I tried installing that as you asked, and now I'm getting this error:

    Incorrect integer value: '`Garden.Users.Edit`' for column 'Garden.Moderation.Manage' at row 1|Gdn_Database|Query|insert GDN_Permission (`Garden.Email.Manage`, `Garden.Settings.Manage`, `Garden.Routes.Manage`, `Garden.Messages.Manage`, `Garden.Applications.Manage`, `Garden.Plugins.Manage`, `Garden.Themes.Manage`, `Garden.SignIn.Allow`, `Garden.Registration.Manage`, `Garden.Applicants.Manage`, `Garden.Roles.Manage`, `Garden.Users.Add`, `Garden.Users.Edit`, `Garden.Users.Delete`, `Garden.Users.Approve`, `Garden.Activity.Delete`, `Garden.Activity.View`, `Garden.Profiles.View`, `Garden.Moderation.Manage`, `Garden.AdvancedNotifications.Allow`, RoleID, JunctionTable, JunctionColumn) values (:GardenEmailManage, :GardenSettingsManage, :GardenRoutesManage, :GardenMessagesManage, :GardenApplicationsManage, :GardenPluginsManage, :GardenThemesManage, :GardenSignInAllow, :GardenRegistrationManage, :GardenApplicantsManage, :GardenRolesManage, :GardenUsersAdd, :GardenUsersEdit, :GardenUsersDelete, :GardenUsersApprove, :GardenActivityDelete, :GardenActivityView, :GardenProfilesView, :GardenModerationManage, :GardenAdvancedNotificationsAllow, :RoleID, :JunctionTable, :JunctionColumn)


    I would really like to see vanilla up and running tonight, because I have about 4 styles waiting to be released/finished up. I would really like them to be able to be released this week if at all possible.
  • TimTim Lord of Servers Vanilla Staff
    After upgrading to 2.0.18, did you run /utility/update?

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • I didn't upgrade, I uploaded a brand new copy, cleared the database, and ran the installer as I normally would. I still haven't managed to get it working on my localhost, but I am working online which is slower but I found a copy that I had installed online for testing a couple of weeks ago.
  • TimTim Lord of Servers Vanilla Staff
    So you downloaded 2.0.18b2 from somewhere, and encountered those issues during a normal fresh install?

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • Yes, I installed for GitHub. I'd imagine it's my localhost. That would just be my luck. I uninstalled XAMPP because it stopped working :/
  • TimTim Lord of Servers Vanilla Staff
    I just downloaded a fresh copy of our absolute latest code from GitHub and it installed flawlessly.

    Get it here, and try: https://github.com/vanillaforums/Garden/tarball/unstable

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • I'm getting the same error with that copy. I had a quick look at the database shows that only 11 database tables were created.

    I'm not sure what the problem is, but it seems to be Zend Server and the latest copy of Vanilla. I was able to install 2.0.17 earlier, but I haven't been able to install 2.0.18. I seem to remember trying to install the first beta of 2.0.18 on my old localhost running XAMPP about a week or two ago. I wasn't able to install that either, but I wasn't getting the same error.

    I guess my luck is very good, eh?
  • TimTim Lord of Servers Vanilla Staff
    I'd try and stick with XAMPP and figure out what was wrong with that which prevented it from working. We have no support Zend Server and you're probably just asking for trouble by running some weird proprietary server with Vanilla.

    As for your other problems - what version of MySQL are you using? Are you sure the DB is totally empty when you start your install?

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • I guess I'll install XAMPP sometime again this week. I figured Zend Server would be pretty good since I had a number of people refer me to it. It's all good. Thank you for your help.

    I'm running 5.1 I think. I'm not actually sure. And as far as I can see that database is totally empty. Or at least it is in phpMyAdmin.
  • TimTim Lord of Servers Vanilla Staff
    Sorry to hear you're having such a rough time of things. 5.1 is relatively old, but should still work fine. Let me know what you find by @ mentioning me with any responses here.

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • On windows the installation succeeded when I commented out line

    sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

    from MySQL's config (my.ini).
  • Hmm, I changed that line but still seem to be producing the same error that I had previously.

    I have another idea that I am going to try. I'll get back to you guys and let you know if it works!
  • I tried downloading the copy of Vanilla I have online and the database with it, but that was no use. I am going to uninstall Zend Server CE and try XAMPP for my localhost again. Thank you for your help
  • Well it appears to be a problem with Zend Server CE + Vanilla. I have XAMPP installed and didn't have a single problem with the installation.

    I was actually a little afraid to try to uninstall Zend because last time I did that it messed up both ports 80 and 3306(I think that's the MySQL port) and I couldn't install anything that used either of those. But thank you for your help, I be working on my themes more now and hopefully get some out the door!
Sign In or Register to comment.