Fork me on GitHub
Current release is 2.1.6 (21 Nov 2014).

Users who have not yet upgraded to 2.1 should get security release 2.0.18.14 (1 Nov 2014). We will stop providing these security releases to 2.0 at the end of this year.

FileUpload plugin stalls on "Uploading...", throws JSON error

ericcarlericcarl New
edited September 2011 in Vanilla 2.0 Help
This discussion is related to the FileUpload addon.
I just got the FileUpload plugin installed and when I attempt to attach a file I get the following error in Chrome's inspector:

Uncaught Invalid JSON: <br>
<b>Fatal error</b>: Call to undefined method Gdn_Upload::Parse() in <b>/Users/gnomonINC/Sites/vanilla-2/plugins/FileUpload/class.fileupload.plugin.php</b> on line <b>716</b><br>


I'm not super inspector-savvy but it looks like it's originating in jquery.js. I've already set all of the user role permissions to allow for uploading and downloading. I'm using Vanilla 2.0.17.10.

The comment in this thread (http://vanillaforums.org/discussion/13124/file-upload-always-shows-uploading....-and-never-finished#Item_31) from jahudka regarding "{JSON response}" seems like it might be my same problem but I couldn't quite follow his solution. Thanks for any help!
Tagged:

Best Answer

  • Answer ✓
    Solution!!

    I had this bug too.

    When I first uploaded the plugin (1.5.1) to my plugins folder I did it through Dreamweaver.

    I decided to try using the older version (1.4.4) and see if that one worked. I didn't take any chances on the upload (sometimes Dreamweaver misses files) so I used Cyberduck just to be sure. I enabled it, and shazam! It works now!!

    Maybe it was DW, or maybe it's the latest version of the plugin that has a bug.

    I'll have to try the new version uploaded through Cyberduck and see if it still works.

Answers

Sign In or Register to comment.