Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us

[GitHub Bug #1169] What now vanilla? Dashboard fatal Error

camocamo New
edited October 2011 in Questions
Im so tired of this crap! after enabling open id

Fatal error: require() [function.require]: Failed opening required '/s101-2/home6/camosreptiles/forum/conf/config-defaults.php' (include_path='.:/usr/share/pear') in /s101-2/home6/camosreptiles/forum/library/core/class.configuration.php on line 364

Best Answer

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭
    Answer ✓
    if you are using it on Localhost @Camo - do you have Curl installed? you might have to enable Curl on localhost. i remember when i had first installation on localhost it threw me an error though it dont remember what it was. and the error was with OpenId plugin and Google Sign in Plugin.
    May b installing Curl will solve your problem but m not sure

    Theme Charcha for great desktop and mobile experience! - drop me a message :)


  • Aha! Still not learning
    Failed opening required '/s101-2/home6/camosreptiles/forum/conf/config-defaults.php
    What do you *think* it means. What have you tried. Did you succeed? Did you get other error messages? Did you find the specific file in that location? Did you look in the class.configuration.php file on line 364 why it's looking for config-defaults.php?
  • camocamo New
    edited October 2011
    Yes ofcourse I looked at the file but I still dont understand it.

    anyway, heres what happened..

    I couldnt enable OpenId because it said some crap about an ini file. I searched that error message message and found a discussion that mentioned, as a fix, inserting..

    $Configuration['EnabledPlugins']['OpenID'] = TRUE;

    in config.php, which i did, that then allowed me to enable it, went to it settings, clicked enable. logged out and checked it, ok it works (or seems to), great., then I try to enable google sign in because I previously searched issues regarding that and was advised to enable openId first. So...
    I enabled google sign in, went to settings and hit enable. after enabling, the error I posted here appeared in 'news' in the dashboard, at which point my freaking head exploded. Ok! The open Id dosent seem to work on second check.

    So, when I try logging in with google sign in, what do i get? Another error !

    (see below)
    Fatal Error in;

    No servers found!
    The error occurred on or near: /s101-2/home6/camosreptiles/forum/plugins/OpenID/class.lightopenid.php
    368: $this->server = $server;
    369: return $server;
    370: }
    372: throw new ErrorException('No servers found!');
    373: }
    374: throw new ErrorException('Endless redirection!');
    375: }
    [/s101-2/home6/camosreptiles/forum/plugins/OpenID/class.lightopenid.php:504] LightOpenID->discover();
    [/s101-2/home6/camosreptiles/forum/plugins/OpenID/class.openid.plugin.php:169] LightOpenID->authUrl();
    [/s101-2/home6/camosreptiles/forum/library/core/class.pluginmanager.php:713] OpenIDPlugin->EntryController_OpenID_Create();
    [/s101-2/home6/camosreptiles/forum/library/core/class.dispatcher.php:313] Gdn_PluginManager->CallNewMethod();
    [/s101-2/home6/camosreptiles/forum/index.php:53] Gdn_Dispatcher->Dispatch();

    Application: Vanilla
    Application Version: 2.0.18rc2
    PHP Version: 5.2.13
    Operating System: Linux
    Server Software: Apache
    User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/14.0.835.202 Safari/535.1
    Request Uri: /forum/entry/openid?
    Controller: LightOpenID
    Method: discover
    There is little point me checking these files when I have No idea what they do anyway!
    The files mentioned are untouched, e.g out of the box.

    The reason I try NOT to mess with my installation is BECAUSE Im not learning and I mess shit up! By the way Im still having this issue too!
  • UnderDogUnderDog Moderator
    edited October 2011
    And if you posted your whole story the first time, you would have made a nice opening post, so hopefully you've learned something.
    Now... look at the error messages you've posted:
    No servers found!
    Look in the code lines 368 and further, I would look a little above line 368 what is happening there. You do not need to understand it, just look at it and read it, then try to understand it.
    You are still doing all your coding on your live site. Why would you do that while you have a localhost too?
  • camocamo New
    edited October 2011
    Because I cant figure out how to get the filezilla server working to manipulate code on my localhost. I have it installed but thats as far as I got.
    God man, why must you be so deliberately obtuse and antagonising? why cant you just bloody well TELL ME WHAT IT MEANS? or is that you dont know either? Ill look at the code, but you go read a book in chinese and see if you can 'TRY to understand it" ! I didnt ask you to teach me, I asked you (or anyone) to help me. Why assume that I WANT to learn this headscrewing crap?, I dont, code does not interest me, I just want the forum and plugins to work, simple as that. Im the end user, Im here to enjoy the software, not debug it!

    Nope, still dont understand what its doing, or rather why its throwing that error.
    The damnned plugin says nothing about having to configure anything in config files or anywhere else, so how is looking at that file going to help at all?
    It simply does not work, and why is a mystery. its straight out of the box and Ive just recently done a fresh install. You tell me!
    My best guess its trying to connect to and not finding that server?
    beats the shit out of me.
  • 1) Learn to use the Edit button in this forum
    2) No servers found means that the openid you enabled cannot find any servers to connect to.
    3) Helping you doesn't mean CTR-C / CTRL-V ready code. Some effort from the user (in this case YOU) is needed
    4) If you work on your localhost you do not need filezilla, you can just edit your .php files with notepad
    5) Take your second post as an example of how all your opening posts in all your problems should be. Details, details, details, error messages, full stories of what you did, what you've tried, etc.
  • As obtuse and rude as ever!
    Why cant it find any servers to connect to? What am I supposed to do?
    Some documentation with this plugins wouldnt go astray.
    I dont want cut N paste code, I want to know what the hell Im supposed to do to make it work.
  • @sahotataran, I do have an installation on my localhost aswell, but Im not using it yet.
    Yes I did check I have curl enabled on my webserver, it was an issue I looked into while trying to install Facebook sign in, while I was still on version 2.0.18b4 (rc2 now), I had to contact my server people to find out at the time. Im not sure why the openid plugin gives that particular error, but I got around that by inserting a line directly into config.php, which then allowed me to enable it.
    It still does not work though (i think the google error is related), but it does not throw any error when you enter your openid, it just refreshes. (does not log you in.)
    Since google relies on openid, I think If I can solve the openid issue the google wont throw that error anymore.
  • lucluc ✭✭
    @camo: He is not rude.
    He is still trying to help you out even though you're, often, not making any effort to be helped.

    He's not the plugin author, he's not a vanilla author, just some guy that try to help you, and he may not even be using that plugin. He's taking time for you, and you're just venting.
  • He is stalking me, it feels like, he has a sarcastic comment to make to any topic I post, thats NOT helpful. And whilst I appreciate your right to your own opinion, your opinion does not help the issue either Luc.
    Thankyou for your input today, have a nice day.
  • [could not edit here, it wont load]

    ...Ill just add that much of the effort he claims I dont make is not posted because because it failed to yeild a solution. I spend hours beavering away on my computer before I post here.
    Searching the github sometimes helps, but the problem is that things there are difficult to follow, not commented, and not dated, its hard to know if you implemment a fix that seems related to your problem will actually help or just make it worse because it was very old.outdated, or not intended for your version, or something else has changed since, Ive also spend many hours trying various 'fixes' discovered on github, and from searching the web in general, and just as many hours fixing things when they screw the thing more.
    I dont appreciate sarcasm and arrogance.
    If I knew the answer to some persons problem, and I bother to reply, then Ill make the effort to be understood and helpful, even if it requires letter by letter instructions with screenshots.
    Theres no point in being half assed about anything, it works both ways mate!
  • @UnderDog :Pm received

    No servers found means that the openid you enabled cannot find any servers to connect to.

    I dont know where to go next with this, Is it my server its trying to connect to? How do I know without understanding how the thing works? Again, there is no documentation explaining this, or any need to configure beyond setting 'enable' in the dashboard.

    Trying to log in with it, gives no error at all (yes I have dev error master enabled in config.php) you add your openid, Im my case I used my Google profile url as documented here

    was able to log in with it elsewhere, but my on my application, after entering openid and clicking 'go' (or whatever), it just refreshes...


  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭
    i just noticed i get the same error when i try to login using google. Any Solutions @camo ?

    Theme Charcha for great desktop and mobile experience! - drop me a message :)

  • camocamo New
    edited October 2011
    @sahotataran None Ive been able find yet, have been searching github, found...

    more specifically..(I think similar problem, but its unanswered)

    Ours is Fatal Error in;

    Not sure if You/I should open a ticket there for our specific issue?
  • LOL, I just discovered the openId login here does the same thing, just refreshes!
  • Bump! Is there any newer version of openid than

    'Version' => '0.1a',
    'RequiredApplications' => array('Vanilla' => '2.0.14a

    and for google sign in, newer than

    'Version' => '1.0',
    'RequiredApplications' => array('Vanilla' => '2.0.14'),
    'RequiredPlugins' => array('OpenID' => '0.1a'),

  • @camo this would probably be a good time to write up a very descriptive bug report on github with steps to reproduce it here (since you said it happens here too).

    Be as descriptive and as courteous as you can and I'm sure they'll address it soon. Especially if they can reproduce/debug it on a server they own.

    My addons: NillaBlog | Vanoogle

  • edited March 2012

    Same problem here. I have curl enabled on my web server.

    @camo - did you manage to find a solution?

Sign In or Register to comment.