Fork me on GitHub
Please upgrade to 2.1.x here. The 2.0 branch is no longer being updated.
Critical: Update to 2.1.8, released 15 Jan.

Plugins are not working after upload

edited January 2012 in Vanilla 2.0 Help

Hello, I have had success in the past with plugin uploads. I'm confused because this time, the plugins are not viewable on my dashboard.

I uploaded via filezilla to the correct plugins directory. When I go to my hosting account, I can see the plugin files. They are there, in the forums/plugins directory. But when I go to my dashboard to enable them, I cannot view them. They just aren't there. The same 16 plugins that were there before I started the process are still there with no additionals.

I tried shutting down my computer and re-booting, this did not work. I also tried to use two different browsers: firefox and explorer. Any other suggestions?

Best Answers

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    Answer ✓

    tbh, given that it is relatively quick to load Vanilla, I'd make a new folder, upload Vanilla again and go through the set-up process. Shouldn't take more than 10 minutes.

    If using Vanilla from that folder works, you can either redirect your forum to that folder, or delete the original folder, then rename the new one with the old name.

  • dodgeriddodgerid
    Answer ✓

    Hi TammieEarl, just a quick question, how did you upload with filezila, did you unzip the plugin and then upload the folder or have you uploaded the zip file ?

    (I know it's broke right now, just trying to establish your original problem)

  • 422422 Developer MVP
    edited January 2012 Answer ✓

    Personally I think you are uploading the plugins incorrectly. ie:





    If you have access to cpanel , then go into file manager, and see if you can find a plugin that you have recently uploaded. Check its chmod settings... you may find they are set to 000.

    We always use auto for stuff like this, files I think should generically be 0644

    422 Real Estate Australia , now open Check it out

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    Answer ✓

    I'd definitely go down the route of re-installing Vanilla in a new folder, and linking that to your current database.

    If you still have problems after that, it is then almost certainly something on your webserver, rather than in Vanilla.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    Answer ✓


    You're welcome.

  • hbfhbf wiki guy? MVP
    Answer ✓

    FYI-- any plugins which when opened have a macos folder in them should be opened with a more robust zip utility such as 7-zip. then you will get the real contents, uncorrupted.

    I have encountered this numerous times and the files you get out of one of these archives using the default windows zipping utilities are usually garbage.



  • 422422 Developer MVP
    edited January 2012

    Can u ping a file within the plugin directly from your browser. Sounds like cache and file permission issue. Also how Did u upload in ascii / binary format

    422 Real Estate Australia , now open Check it out

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Don't know if this will solve it, but clearing the Vanilla/cache folder often helps after folders have been moved or renamed.

  • 422, I have no idea how to ping a file within the plugin. I also do not know if I uploaded in ascii or binary format. I used filezilla, that is the extent of my knowledge! If you will elaborate I will see what I can do though! Sorry!

    whu606, I will check that now. Thank you, I didn't think of that!

  • who606 I just deleted all browsing and temporary files and it did not fix the problem. Is there another place I need to go to clear the Vanilla cache?

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator


    You need to be able to access the files on your host's webserver (for example via CPanel - FileManager).

    There is a folder called Vanilla, and in that one called cache. Open the cache folder and delete all the files you find in there.

  • Oh! Thank you! going now...

  • Didn't work. I deleted a whole directory in there called Smarty. Not sure if that was smart or not. LOL

  • Is there a way to re-load all the files without disturbing the database? Three members may seem like nothing to worry about, but I don't want to annoy them and make them start over.

  • I loaded google chrome onto my computer and used it to try and get these plugins to work and this did not solve my problem. I'm going now to delete the plugins and re-upload. But in the meantime I need to know if I need to re-upload Smarty, which was in my cache folder, and if someone has any other great ideas I sure would like to hear them! Also, I am not ignoring you, 422, I just don't know how to use the help you gave me! If you will be so kind as to elaborate to help me out, I will try to use your ideas. THANK YOU!

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator


    afaIk all the files in the cache rebuild themselves as they are needed.

    You can always create the Smarty folder again manually in the cache folder. If you do that I would add a folder called 'compile' as well. I had to do that when I tried to run a theme which used a tpl template.

    The folder is definitely called plugins, I take it?

  • 422422 Developer MVP

    Bit more complex than that if uve deleted smarty, there are permission requirements too.

    To ping.

    Lets say we know the location of plugins folder and a plugin folder within it called dave and a file within that called steve.php.

    Ping by opening brwser and going to to plugin/steve.php and if u see results.. Then ur on ur way.

    If u uploaded via not ftp method, and extracted files.. Could be permission issue.

    422 Real Estate Australia , now open Check it out

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    You could try checking your config.php file in the conf folder to see if the plugins are enabled in there.

    If they aren't, you could try adding the lines manually, for example:

    $Configuration['EnabledPlugins']['Emotify'] = TRUE;

    turns on the Emotify plugin.

    If you find you have to reinstall Vanilla it shouldn't affect the database, but always make a backup of the db to be doubly sure.

    I think 422 means if you type: http://www.yourforum/plugins/

    do the plugins display as a list?

  • 422422 Developer MVP
    edited January 2012

    No they wouldnt display as list afaik. You need absolute url

    422 Real Estate Australia , now open Check it out

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Mine just did, but that maybe because I have my settings wrong!

  • I really think I've done something wrong. I must've accidentally deleted or overwritten a file that I need, while trying to get the plugins into the right place. This was never complicated before. I want to "re-install" Vanilla without losing my database files. how can I do this?

  • Yes, Whu606, Here is the link: that I typed into the address bar and yes, I did get a list of the plugins. The ones I've recently uploaded are there.

  • whu606, I just opened my config.php file and the new plugins are not listed. I'm going to play with that a bit...

  • I just added this to my config.php: $Configuration['EnabledPlugins']['fileuploaddetect-plugin-0-2b'] = TRUE;
    this did not work.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator


    If it comes to reinstalling Vanilla:

    Your db will be in a separate folder to your Vanilla install.

    Keep a note, from the config file, of your database name, user and password.

    Use something like phpMyAdmin to make a backup of the db referred to in your config file.

    Delete your Vanilla installation, or create a new folder and upload a fresh Vanilla installation, and link to the db during setup.

    That should do it.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    edited January 2012

    The line should be:

    $Configuration['EnabledPlugins']['FileUpload'] = TRUE;

    Sorry, think that may be a different plugin...

    The name of the EnabledPlugin should be the name of the folder it is in.

  • Yeah. None of this is working. I tried going back to yesterday's version (I had a backup and my server helped me restore it) that didn't work either.

    I did as you said and backed up my database. I'm getting ready to reinstall. But this is all so weird. This should just WORK.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Tammie - you are right, it should, and normally does. I know that's no great consolation.

  • thanks whu! I'm still working with my server. They are great! Even though they don't officially support vanilla, they are working with me. right now it looks like I am missing a file called php.ini ... does that ring any bells?

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    edited January 2012

    php.ini is the control file for PHP - which is the 'engine' for the code Vanilla is written in. It is separate to the Vanilla install, and should be provided by your host as part of the server side options on your webserver

    If your forum is working generally, then I'd be surprised if php.ini were the problem, but I'm not really very up on 'server side' stuff.

  • Well I'm working on that, hopefully it works but I doubt it - because like you said, my forum is working.

  • It didn't work. I'm going to shut the whole computer down and re-boot. Delete browsing history and cache. All that jazz. But it's not going to work, I'm going down the same path as before. Really bummed!

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    tammie - it is almost certainly nothing to do with your own computer. It will be something to do with the install on your webserver.

  • whu, that's what I will do - tomorrow - ran out of computer time today.

    I'm getting these weird debug messages at the bottom of my pages - on the user side AND the dashboard:
    Debug Information

    Canonical Url:

    13 queries in 0.0137870311737s
    Gdn_Model->GetWhere(array('UserID' => '1'))0.002283sselect *
    from GDN_User User
    where UserID = '1';PermissionModel->PermissionColumns()0.007093sselect *
    from GDN_Permission Permission
    limit 1;PermissionModel->CachePermissions('1')0.000310sselect MAX(p.PermissionID) as PermissionID, MAX(p.Garden.Email.Manage) as Garden.Email.Manage, MAX(p.Garden.Settings.Manage) as Garden.Settings.Manage, MAX(p.Garden.Settings.View) as Garden.Settings.View, MAX(p.Garden.Routes.Manage) as Garden.Routes.Manage, MAX(p.Garden.Messages.Manage) as Garden.Messages.Manage, MAX(p.Garden.Applications.Manage) as Garden.Applications.Manage, MAX(p.Garden.Plugins.Manage) as Garden.Plugins.Manage, MAX(p.Garden.Themes.Manage) as Garden.Themes.Manage, MAX(p.Garden.SignIn.Allow) as Garden.SignIn.Allow, MAX(p.Garden.Registration.Manage) as Garden.Registration.Manage, MAX(p.Garden.Applicants.Manage) as Garden.Applicants.Manage, MAX(p.Garden.Roles.Manage) as Garden.Roles.Manage, MAX(p.Garden.Users.Add) as Garden.Users.Add, MAX(p.Garden.Users.Edit) as Garden.Users.Edit, MAX(p.Garden.Users.Delete) as Garden.Users.Delete, MAX(p.Garden.Users.Approve) as Garden.Users.Approve, MAX(p.Garden.Activity.Delete) as Garden.Activity.Delete, MAX(p.Garden.Activity.View) as Garden.Activity.View, MAX(p.Garden.Profiles.View) as Garden.Profiles.View, MAX(p.Garden.Profiles.Edit) as Garden.Profiles.Edit, MAX(p.Garden.Moderation.Manage) as Garden.Moderation.Manage, MAX(p.Garden.AdvancedNotifications.Allow) as Garden.AdvancedNotifications.Allow, MAX(p.Conversations.Moderation.Manage) as Conversations.Moderation.Manage, MAX(p.Vanilla.Settings.Manage) as Vanilla.Settings.Manage, MAX(p.Vanilla.Categories.Manage) as Vanilla.Categories.Manage, MAX(p.Vanilla.Spam.Manage) as Vanilla.Spam.Manage, MAX(p.Vanilla.Discussions.View) as Vanilla.Discussions.View, MAX(p.Vanilla.Discussions.Add) as Vanilla.Discussions.Add, MAX(p.Vanilla.Discussions.Edit) as Vanilla.Discussions.Edit, MAX(p.Vanilla.Discussions.Announce) as Vanilla.Discussions.Announce, MAX(p.Vanilla.Discussions.Sink) as Vanilla.Discussions.Sink, MAX(p.Vanilla.Discussions.Close) as Vanilla.Discussions.Close, MAX(p.Vanilla.Discussions.Delete) as Vanilla.Discussions.Delete, MAX(p.Vanilla.Comments.Add) as Vanilla.Comments.Add, MAX(p.Vanilla.Comments.Edit) as Vanilla.Comments.Edit, MAX(p.Vanilla.Comments.Delete) as Vanilla.Comments.Delete, MAX(p.Plugins.Flagging.Notify) as Plugins.Flagging.Notify, MAX(p.Plugins.Debugger.View) as Plugins.Debugger.View, MAX(p.Plugins.Debugger.Manage) as Plugins.Debugger.Manage, p.JunctionTable as JunctionTable, p.JunctionColumn as JunctionColumn, p.JunctionID as JunctionID
    from GDN_Permission p
    join GDN_UserRole ur on p.RoleID = ur.RoleID
    where ur.UserID = '1'
    group by p.JunctionTable, p.JunctionColumn, p.JunctionID;CategoryModel::Categories()0.000294sselect c.*, lc.DateInserted as DateLastComment
    from GDN_Category c
    left join GDN_Comment lc on c.LastCommentID = lc.CommentID
    order by c.TreeLeft asc;CategoryModel::JoinUserData(array(6), 1)0.000340sselect *
    from GDN_UserCategory UserCategory
    where UserID = '1';CategoryModel->GetFull()0.000174sselect c.*, co.DateInserted as DateLastComment, co.InsertUserID as LastCommentUserID, d.Name as LastDiscussionTitle, d.CountComments as LastDiscussionCountComments, d.InsertUserID as LastDiscussionUserID, d.DateInserted as DateLastDiscussion, uc.DateMarkedRead as DateMarkedRead, uc.Unfollow as Unfollow
    from GDN_Category c
    left join GDN_Comment co on c.LastCommentID = co.CommentID
    left join GDN_Discussion d on d.DiscussionID = c.LastDiscussionID
    left join GDN_UserCategory uc on uc.UserID = 1 and uc.CategoryID = c.CategoryID
    where c.AllowDiscussions = '1'
    order by TreeLeft asc;UserModel->GetIDs(array('0' => '', '1' => 1))0.000233sselect *
    from GDN_User User
    where UserID in ('1');DiscussionModel->GetAnnouncements()0.000176s
    Cache: array ( 'Announcements' => false, )
    select d.DiscussionID as DiscussionID
    from GDN_Discussion d
    where d.Announce = '1';DiscussionModel->Get('0', '30')0.000555sselect d.Type as Type, d.InsertUserID as FirstUserID, d.DateInserted as FirstDate, d.CountBookmarks as CountBookmarks, d.Body as Body, d.Format as Format, d.DateLastComment as LastDate, d.LastCommentUserID as LastUserID, d.*, w.UserID as WatchUserID, w.DateLastViewed as DateLastViewed, w.Dismissed as Dismissed, w.Bookmarked as Bookmarked, w.CountComments as CountCommentWatch
    from GDN_Discussion d
    left join GDN_UserDiscussion w on d.DiscussionID = w.DiscussionID and w.UserID = 1
    order by d.DateLastComment desc
    limit 30;UserModel->GetIDs(array('0' => 1, '1' => ''))0.000839sselect *
    from GDN_User User
    where UserID in ('1');UserMetaModel->GetUserMeta(0, 'Garden.Analytics.Throttle', 0)0.000202sselect *
    from GDN_UserMeta u
    where u.UserID = '0'
    and u.Name = 'Garden.Analytics.Throttle';MessageModel->GetMessagesForLocation('Vanilla/discussions/index', array('0' => '[Base]', '1' => '[NonAdmin]'))0.000278sselect *
    from GDN_Message Message
    where Enabled = '1'
    and (Controller in ('[Base]', '[NonAdmin]')
    or (Application = 'Vanilla'
    and Controller = 'discussions'
    and Method = 'index'))
    and MessageID not in ('0')
    order by Sort asc;include('/home8/vonwardk/public_html/nolamil/forums/applications/dashboard/views/default.master.php')0.000768sselect DiscussionID
    from GDN_UserDiscussion UserDiscussion
    where UserID = '1'
    and Bookmarked = '1';
    Controller Data
    Title: 'All Discussions'
    Category: false
    CountDiscussions: 4
    Announcements: DataSet
    EMPTYDiscussions: DataSet
    Count: 4
    Fields: Type, FirstUserID, FirstDate, CountBookmarks, Body, Format, LastDate, LastUserID, DiscussionID, ForeignID, CategoryID, InsertUserID, UpdateUserID, LastCommentID, Name, Tags, CountComments, CountViews, Closed, Announce, Sink, DateInserted, DateUpdated, InsertIPAddress, UpdateIPAddress, DateLastComment, LastCommentUserID, Score, Attributes, RegardingID, WatchUserID, DateLastViewed, Dismissed, Bookmarked, CountCommentWatch, Url, CountUnreadComments, FirstName, FirstEmail, FirstPhoto, LastName, LastEmail, LastPhoto, Category, PermissionCategoryID, CategoryUrlCode
    _PagerUrl: 'discussions/{Page}'
    _Page: '0'
    _Limit: '30'
    CssClass: 'Vanilla Discussions index '

    Page completed in 1.0782s

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Well, that seems like the Debugger plugin is working...

Sign In or Register to comment.