Fork me on GitHub
Current releases are 2.1.5 (31 Oct 2014) and 2.0.18.13 (5 Aug 2014)

Ready for 2.1? Find out if your plugins are compatible. 2.0 will no longer be updated after Dec 2014.

2.0.18.2 Import fails silently - No idea where to go from here

edited January 2012 in Vanilla 2.0 Help

Trying to upgrade to 2.0.18.2 but the import just fails silently. Been using the latest vanilla2exporter.php to export my 2.0.6 database, but when importing the file through the admin menu nothing happens:

  • If using a zipped .txt.gz file (as generated by the exporter), the import page keeps the email and password information but presents the error "ImportFile is required".
  • If using an unzipped .txt file, the import page forgets all previous input and presents three errors; "You must select a file to import.", "Email is required." and "Password is required."

My current installation is a fresh 2.0.18.2 with no changes what so ever. I've tried all different combinations of "Use my Current Password" and "Generate import SQL only", but I never got past the import input page.

As I'm unable to see any sort of error message, I have no idea where to go from here. Please advice! I even tried adding;

$Configuration['Garden']['Errors']['LogEnabled'] = TRUE;
$Configuration['Garden']['Errors']['LogFile'] = 'logs/error-log';
$Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

but no logs/ directory is created, so I'm assuming no errors there. (I've restarted apache).

Also tried clearing the cache directory and verified directory permissions to uploads/conf/cache directories.

Tagged:

Answers

Sign In or Register to comment.