Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Using Vanilla With IIS 7

edited March 2012 in Questions

I've just installed vanilla into my iis 7 installation under /forum and i am getting a 404 error (Yes i have done the configuration). I've heard its a prob with .htaccess is there a way to convert it to web.config or turn it off all together http://apexgames.co.uk/forum/

Best Answer

Answers

  • x00x00 MVP
    edited March 2012

    IIS isn't even officially supported, I suggest you search the forums for IIS there have been successful installs.

    you could try renaming the .htaccess, then try.

    grep is your friend.

  • edited March 2012

    I've tried following other people's ways but they don't work. 404 every time.

    Is there a way of turning off these 'special' urls that need rules.

  • After converting the htaccess to web.config i can only go to this apexgames.co.uk/forum/index.php?p/dashboard/* any thing else 404's. Suggestions?

  • chanhchanh OngETC.com - CMS Researcher ✭✭

    I don't mean to bump an old thread but seem like no solution to this post and I think I do have a solution because this work for me.

    On site that run IIS, if you place the web.config file that I attached in to the same place as .htaccess then your rewrite rule should work just fine just like it would on apache

    file: web.config

    <?xml version="1.0" encoding="UTF-8"?> <system.webServer> </system.webServer>

  • chanhchanh OngETC.com - CMS Researcher ✭✭

    It won't let me attach or post the file so I rename the file to .txt so you will need to rename it back to web.config after you get the file.

Sign In or Register to comment.