Fork me on GitHub
Please upgrade to 2.1.x here. The 2.0 branch is no longer being updated.
Critical: Update to 2.1.8, released 15 Jan.

[Solved] Doing something wrong?

This discussion is related to the PM addon.

Hi since nobody else is having problems I must be doing something wrong.

For my pm message is currently set to:
Send Thermalzombie a Message

In my settings for the plugin inside the textbox all that is entered is:
PM

Tagged:

Best Answer

  • mcu_hqmcu_hq yippie ki-yay ✭✭✭
    edited March 2012 Answer ✓

    Did you put something like this: "Send {user} a Message}" (without quotes) inside the settings box and then click 'save'?

    The default should populate that box to 'PM' unless if you've changed it.

Answers

  • mcu_hqmcu_hq yippie ki-yay ✭✭✭
    edited March 2012 Answer ✓

    Did you put something like this: "Send {user} a Message}" (without quotes) inside the settings box and then click 'save'?

    The default should populate that box to 'PM' unless if you've changed it.

  • No all that is in the box is PM tried re-enabaling it as well still the same.

  • mcu_hqmcu_hq yippie ki-yay ✭✭✭
    edited April 2012

    Try putting the following in that box:

    Send {user} a Message

    The box should be populated with 'PM' upon default. If the plugin does not find the string, "{user}", then it will default to simply providing a link with the alt text as "PM" under each discussion.

    "{user}" will be substituted with the discussion author's username. You can place this into whatever string you want to be displayed. I listed an example in the settings. You don't have to use that exact string for it to work.

  • I am sorry I am not good at explaining things.

    this is what is displayed in forum.

    Send Thermalzombie a Message

    No matter what I put in Plugin box this does not change. I tried putting.

    Send {user} a Message

    and then saving then I tried entering.

    PM saving then tried Contact Me and in forum nothing changes.

    Is this information stored in the database can I change it there.

    Thanks for replying.

  • mcu_hqmcu_hq yippie ki-yay ✭✭✭
    edited April 2012

    Ah, it appears that I upload the testing file from my local copy instead of what I had on my server. I'll update the plugin. If you want to, just delete line 30 in class.pm.plugin.php

    Thanks for the heads up.

  • Thanks I deleted line 30 and is now fixed thanks.

  • DenisSDenisS My brain hurts Buriram ✭✭

    I installed and enabled but it don't show. I put (user)
    Text to Display

    Use {user} to substitute in a username in the text
    Example: Send {user} a Message => "Send Admin a Message" << not sure what this means

  • mcu_hqmcu_hq yippie ki-yay ✭✭✭
    edited January 2013

    If you use this{user} in the input box, then the username will be substitute into it. It probably makes more sense if you just look at the code for the plugin:

    $Text = C('Plugin.PM.Text', 'PM');
            $Needle = '{user}';
            $Pos = strpos($Text,$Needle);
            if($Pos){
                $Text = str_replace($Needle, $UserName, $Text);
            }
    
Sign In or Register to comment.