Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


[Documentation] Email Confirmation Role...

troppmanntroppmann New
edited April 2012 in Questions

OK, I looked around and didnt quite see what i was having happen here on my forum...user registers and instead of the role "Users will be assigned to this role until they've confirmed their email addresses." being used the user's role is blank.

so, what I get an application and approve it the user isn't able to be set to the role specified.

Until I manually add that role which I want added to those users the users can't login.

Make sense the problem? I saw a couple other threads on here not quite dealing with the same thing.

Anyway....little help anyone?

Best Answer

  • peregrineperegrine MVP
    edited April 2012 Answer ✓

    first off your role table looks pretty weird. I would change it to exactly what is below as a start until you get it working. and then adjust the permissions through the dashboard. Your choice to do as below with regards to table in link, but without, not much help can be provided.

    see http://vanillaforums.org/discussion/comment/157731#Comment_157731

    From now on, if a user does not do one of two things provide documentation on the wiki or click the like button, that is the end of my attempts to help that particular user.

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

    troppmann

Answers

  • peregrineperegrine MVP
    edited April 2012

    Do you have a line like this in your config.php

    $Configuration['Garden']['Registration']['ConfirmEmailRole'] = '4';

    Before Approval does the user id have of a role of applicant (4)

    and after approval do they have a role of member(8).

    maybe you could post a snapshot of what you displayed?.

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • This is what I have

    $Configuration['Garden']['Registration']['ConfirmEmailRole'] = '9';

    9 is the role i actually want the user to have...

    the approval and after approval numbers? I am looking at the DB and the GDN_user table...and the GDN_userrole table with a test applicant...i have a test user as an applicant...i dont see that user in the user table...i do however see that user in the dashboard user area....which doesnt make sense to me unless there is an application table which i dont see...

    the user so i am testing....I have the role set to this non-member limited role as a guest...when the user creates an account the user has no role...but has admin rights...immediately...logs out and tries to get back in and the user isnt in a group yet...which is the reason i got this thread going.

    if i change this to Basic and a new user register, still no role is applied...

  • peregrineperegrine MVP
    edited April 2012

    It it were me and I was having the problem, in general I might present the following information for questions I pose on this site.

    I am currently using version_____
    The installation is a new install and the problem has always existed.
    or 
    The installation is an upgrade and the problem didn't exist before the upgrade.
    or
    The installation is a migration from such and such.
    
    e.g. Here is a sample copy of my config (minus password top few lines of file).
    
    e.g. Here is listing of my current user_role table.
    

    e.g. here is a partial listing of any other pertinent tables.

    and anything else that might help someone help you solve your problem.
    
    ====
    
    as far as debugging 
    I might consider reinstalling the current version and trying previous versions to see if they work or checking if there is a more recent version within the same branch.
    checking for bugs that are reported , etc.
    https://github.com/vanillaforums/Garden/issues
    

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • 422422 Developer MVP

    Have you assigned roles and permissions in dashboard?

    422 Real Estate Australia , now open Check it out

  • troppmanntroppmann New
    edited April 2012

    Yeah that would probably help on this one...

    It is version 2.0.18.4 The installation was an upgrade from version 1.x The problem didnt exist before the upgrade. The config file is here. The user table is file is 'corrupt', try again.

    I have played with using the Guest role which came with the install as the role for applicants as well and the behavior is still the same.

    Havent done a reinstall yet and I am avoiding it because the transition to from v1 to v2 has been painful for admins and users.

  • 422 said: Have you assigned roles and permissions in dashboard?

    Yes I have.

  • peregrineperegrine MVP
    edited April 2012

    if you have phpmyadmin you can make a viewable html sql I won't be downloading files but if I can view them as txt or html files I will.

    of all 3 tables

    userrole role permission

    I would be glad to look at them and compare to mine for inconsistencies

    and the

    ** first two columns of the user table.**

    I'd also consider overwriting the source with version 2.18.0.3

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • I will give it a shot...

  • here are the txt files:

    permissions role userrole user

    working on the converstation version to .3 thought that would happen when i did the recent upgrade but now am poking around trying to find it....

  • oh, and thank you for your help.

  • Hey, again, thank you...I will give this a once over later this evening...I do appreciate the assistance.

  • Obviously you will also need to change the designations for the userroles to match the correct roleid. I don't know all this will help, but at least you will be starting off from what I think is standard. It may all be a red herring, but seems to work for me as far as the roleids and confirmation

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • UnderDogUnderDog Moderator

    The user table is file is 'corrupt', try again.

    If you look at the .xlsx file (change extention to .txt first) you'll see what's wrong. I don't know if the real user table is needed yet. If it is needed, make sure you do not dump the passwords and email addresses of your users in a .xlsx file the world can see :-S

    In which format did you dump the other .txt files?

  • peregrineperegrine MVP
    edited April 2012

    he did dump it the first two columns as i asked. http://www.halfacrecycling.org/sql/user.txt

    an easy way to dump the table if you don't have phpmyadmin at least with linux With phpmyadmin print view would have been the best way to show them in html

    mysqldump -uusername -p vanilla GDN_Role

    he just used delimiters of | without quotes.

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • at this point i have new users registering turned off...while i figure it out.

Sign In or Register to comment.