Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Problem with installing jsConnect

wcukwcuk New
edited April 2012 in Questions
This discussion is related to the Vanilla jsConnect addon.

Hello,

I am trying to install the plugin in a wordpress site. I have successfully integrated vanilla with my wp site, but a little bit confused as to where to put the jsconnect files. I put it in vanilla/applications folder, but nothing happens. If I put it in plugins folder, the vanilla seems to be not recognising. Can you please help?

Best Answer

  • peregrineperegrine MVP
    edited April 2012 Answer ✓

    On a different tangent. Are you have trouble seeing it in your dashboard?

    The instructions say put in the plugin folder.

    the whole extraction goes into plugins.

    all the files should be in plugins/jsconnect

    are you matching upper and lower case? How did you install it? cpanel? ftp? Did you manually create directories?

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

Answers

  • CaioCaio
    edited April 2012

    Did you try emptying the cache? Go to the cache folder and delete every .ini file inside, in the cache folder, open up the Minify folder if you're using minify (if you're not skip this) and delete everything inside.

  • Caio's answer doesn't make any sense to me.

    Peregrine has rightly understood my problem. Yes, my problem is not able to see it in the dashboard. The forum dashboard says at the top (under the applications sectio) to put jsconnect under applications and jsconnect instruction says to put it under plugin folder. I tried both but nothing seems to work.

    No I haven't matched upper and lowercase, I installed it through FTP by manually creating 'vanilla' folder.

    Thanks for your help, much appreciated.

  • peregrineperegrine MVP
    edited April 2012

    try installing another plugin of any kind and see if you can see it in the dashboard plugins area. The reason i suggest the plugin below that is that it doesn't mess with privileges or the database. It will show up in the vanilla dashboard and probably not on the wordpress dashboard.

    e.g. http://vanillaforums.org/addon/unreadicon-plugin

    just to test if that shows up.

    so the folder looks like all lowercase. Is that what you have?

    /vanilla/plugins/jsconnect

    it should show up way at the bottom of your plugin list as

    Vanilla jsConnect

    I personally dislike plugin names in the dashboard that show up very differently than the plugin name of the directory or don't match the directory name..

    Also, this is weird. like "In this discussion" plugin is in the directory VanillaInThisDiscussion, keeps you on your toes.

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • Hello,

    thanks for the comments. I deleted the jsconnect and installed the above plug in that you are saying and when I click on the Plugin page in the dashboard, I get the following message,

    "Bonk Something funky happened. Please bear with us while we iron out the kinks."

    so apparantly, none of the plugins are working! what could be wrong. I remember, when I was installing vanilla through FTP, there was no .htaccess file and it prevented from installing successfully until I created a blank .htaccess.txt file. Could that be giving this problem?

    Thanks again for your support,

  • I'm having a similar issue. None of the added plugins appear on the "plugins" page. I uploaded them via FTP (Linux terminal). Any ideas?

  • peregrineperegrine MVP
    edited November 2012

    which issue is your similar issue? what does the error message say?

    are you getting a bonk?

    is your folder unzipped in plugins e.g.

    vanilla/plugins/jsconnect

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • Sorry I wasn't clearer. I am not getting an error message or a bonk. I just don't see any manually uploaded plugins on the "plugins" page that can be enabled. I only see the same 16 plugins that came with the installation.

    The plugin is unzipped in vanilla/plugins/jsconnect

    I tried a different plugin (ProxyConnect) but I can't see it either.

  • peregrineperegrine MVP
    edited November 2012

    @julianlimon said: Sorry I wasn't clearer. I am not getting an error message or a bonk. I just don't see any manually uploaded plugins on the "plugins" page that can be enabled. I only see the same 16 plugins that came with the installation.

    The plugin is unzipped in vanilla/plugins/jsconnect

    I tried a different plugin (ProxyConnect) but I can't see it either.

    do you have a link to your site? Is this a new installation? What version of vanilla? You probably should have started a new thread since this topic is not really jsconnect related, but more of a general enabling plugin question. What type of server installation do you have?

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

Sign In or Register to comment.